No internet connection
  1. Home
  2. Technical Support

Tinypilot has stopped displaying after updating

By mark riggs @chayde2021-07-06 15:19:46.555Z

I attempted to update my Tinypilot software on my voyager and after the update I'm not longer getting any video on the GUI. I can see the onscreen keyboard but the "display" is just a little error icon. When I mouse over it my cursor changes into the crosshairs. I've tried rebooting the computer and the Tinypilot multiple times to no effect. The keyboard pass through is working, just the video is not displaying. I've included a screenshot of what I see below.

Solved in post #10, click to view
  • 11 replies
  1. C
    mark riggs @chayde2021-07-06 15:23:49.159Z

    Another thing I noticed is I'm not able to retrieve the debug logs, I clicked on the menu item but the "Retrieving Debug Logs" Just spins, eventually it shows this screen:

    1. Michael Lynch @michael2021-07-06 19:20:43.846Z

      Sorry about this. I haven't seen reports like this. Can you try retrieving the debug logs from the command-line?

      /opt/tinypilot-privileged/collect-debug-logs
      

      At the end, it will ask you to upload them and get a shareable URL, which you can post here, and that'll hopefully give us more insight into what's happening.

      1. Cmark riggs @chayde2021-07-06 19:23:49.054Z

        Here you go, thanks for looking !

        http://logs.tinypilotkvm.com/r7j3kdfK

        1. Michael Lynch @michael2021-07-06 19:33:07.487Z

          That's strange. Your device is missing ustreamer, the tool it uses to stream video. Can you think of anything that would have removed it?

          If you run the updater again, it should fix the issue:

          /opt/tinypilot-privileged/update
          
          1. Cmark riggs @chayde2021-07-06 19:47:24.976Z

            let me run it again right now, I did run the update again earlier today before I opened the forum topic. I found the command on the FAQs: /opt/tinypilot/scripts/upgrade && sudo reboot

    2. C
      In reply tochayde:
      mark riggs @chayde2021-07-06 20:00:58.408Z

      I just ran the update again, and I've still got the same view on the GUI. The craziest thing is when i mouse over the little icon the mouse moves on the laptop its connected to. It doesn't look like the update command installed the ustreamer application. The service is still failing and when i checked the directory listed in the service command there's no ustreamer there. Is there someplace I could manually download that file?

      `

      1. Michael Lynch @michael2021-07-06 20:30:49.165Z

        Oh, I have a theory of what's happening. The updater compiles ustreamer from source, so it removes the old version before compiling the new one. If the updater is failing at that point, that would explain why there's no uStreamer file there.

        Can you try running the updater once more and capturing the logs?

        sudo service tinypilot-updater start # this will run for ~5 mins
        sudo journalctl -u tinypilot-updater | curl -F '_=<-' https://logs.tinypilotkvm.com
        

        I don't want to make you jump through all these hoops, so it's okay if you don't have time to run this. But if you do, it would help prevent the bug in the future.

        I'll send you an email with a link to the stock microSD image so you can clean install TinyPilot Pro.

        1. Cmark riggs @chayde2021-07-06 20:32:21.564Z

          Not a problem, I'll run that now

      2. C
        In reply tochayde:
        mark riggs @chayde2021-07-06 21:11:35.226Z

        https://logs.tinypilotkvm.com/LxW3IwbT

        I appreciate all your help, I'll go through the reimage steps you sent. Thanks so much!

        ReplySolution
        1. Cmark riggs @chayde2021-07-06 21:15:41.054Z

          Reimaging worked I'm back in action, thanks again!

          1. In reply tochayde:
            Michael Lynch @michael2021-07-06 21:19:37.488Z

            Okay, I understand what happened now. There's a bug in the uStreamer installer, which I'm now tracking here:

            https://github.com/tiny-pilot/ansible-role-ustreamer/issues/45

            I think you can fix it without a clean install if you run sudo rm -rf /opt/ustreamer and then re-run the updater from the command line.