No internet connection
  1. Home
  2. Technical Support

Can't insert a period?

By JB @d1rewolf2021-02-17 01:11:42.800Z

Hello all. I just received my pilot today, and it was a very painless setup.

However, I'm unable to insert a period. This is in firefox (chrome won't allow me to bypass the SSL error). If I hit the period key on my keyboard or on the soft keyboard, it seems to reload the page instead.

Any idea how I can get past this? Unfortunately, periods are crucial....

Thanks!

Solved in post #5, click to view
  • 6 replies
  1. D
    JB @d1rewolf2021-02-17 01:13:51.485Z

    I should note for others...I was able to temporarily work around this by copying and pasting a period.

    1. D
      In reply tod1rewolf:
      JB @d1rewolf2021-02-17 01:16:07.346Z

      Well..correction. Copying/pasting worked once, but it seem to have stopped working as well.

      1. In reply tod1rewolf:
        Michael Lynch @michael2021-02-17 01:16:50.570Z

        Thanks for reporting this!

        This is a tricky case. I've never heard of anything like this, and I can't think of a reason why typing the period key would cause a reload. Can you post your debug logs? You can grab them by SSHing into your TinyPilot and running the following command:

        /opt/tinypilot/dev-scripts/dump-logs
        

        chrome won't allow me to bypass the SSL error

        As bizarre as it sounds, the way to proceed past the SSL warning is to type thisisunsafe while the Chrome window has focus.

        1. DJB @d1rewolf2021-02-17 01:54:08.464Z

          Sorry about the waste of forum space, but this ended up being tied to one of my browser extensions....starting without any extensions allowed the period to be inserted. However, I'm glad I asked, as that thisisunsafe tip is money. Thanks!

          ReplySolution
          1. Michael Lynch @michael2021-02-17 02:22:06.623Z

            Oh, thanks for the update!

            Browser extension was my initial suspicion, but I couldn't figure out why you'd see the reload even on the soft keyboard. That part still puzzles me. Were you using an OS X soft keyboard or did you see the reload even when you clicked the period button in the TinyPilot web app's keyboard?

        2. D
          In reply tod1rewolf:
          JB @d1rewolf2021-02-17 10:58:23.268Z

          I was using the TinyPilot built-in soft keyboard. I did some further troubleshooting, and it appears VimVixen is the plugin which causes the issue. Hope this helps, but obviously having a vim plugin running is probably not best when you're trying to pass through keystrokes ;-)