No internet connection
  1. Home
  2. General

Fix for TinyPilot update failure

By C M @chuckm
    2021-09-22 00:55:56.547Z

    In case this helps others.
    I tried to update TinyPilot software via Web UI and it failed.
    I logged in via SSH and ran /opt/tinypilot/scripts/upgrade.
    Output said file not valid yet and updates for this repository will not be applied.
    Google said to check the system date and indeed the date on the TinyPilot/RasberryPi was wrong.
    Ran >sudo date -s "Sep 21 08:10" and then date again to verify it was correct. Then the update worked.

    • 1 replies
    1. Thanks! It sounds like an issue with ntp. The TinyPilot doesn't have a battery-powered clock, so it relies on a network NTP server to tell it the current time after it has been powered off. If it hasn't been able to contact an NTP server, then it can get into a state where it's hours or days behind the real world time, so it gets confused when it sees update packages that appear to be published in the future.