No internet connection
  1. Home
  2. General

TinyPilot network doesn't seem to want to initialize

By Dru P @Dru
    2021-10-18 16:50:41.446Z

    Just got my TinyPilot and connected it up to a server to try to test it out, but the network on the TinyPilot never seems to get going. I tested the port with a laptop and was able to get DHCP and everything just fine. When I plug the network back into the TinyPilot, I don't ever get any lights and looking at the switch I plug it into, there doesn't seem to be anything going on.

    Is there perhaps a way for me to console into the TinyPilot to see what is going on?

    • 11 replies
    1. Thanks for reporting this! Sorry about the trouble getting up and running.

      When you power on the Voyager, do you see the green and amber status lights?

      If those status lights are on, then it does sound like an issue with the networking component. It could be a defective network adaptor on the Voyager, but that would be the first time that's ever happened in the field. If you are seeing the status lights from power, can you try a different Ethernet cable just to eliminate the possibility that the Ethernet cable is flaky? I know it worked with the laptop, but just to be sure.

      1. DDru P @Dru
          2021-10-18 20:39:10.120Z

          I appreciate the prompt reply!
          Just to make sure, I tested a few different cables that are known good, same result. I did notice that the very first time I connected the ethernet port, I got an amber light on the switch port like it was trying to connect. Also on my voyager I have a constant red light, but I did not see any activity on the green LED next to it even after a power cycle. There is, however a solid green LED on the power module.

          1. It sounds like the microSD got corrupted. Do you have a microSD writer? You can reflash it with the instructions here:


            If not, I can send you a new microSD. Sorry for the inconvenience!

        • Progress
        • D
          Dru P @Dru
            2021-10-20 22:07:43.626Z

            I was able to get the microSD card reflashed, but I still get the same behavior. To verify that I correctly reflashed the microSD, I stuck it into a similar model raspberry pi we have around the office and it looked like it was booting fine.

            1. Michael Lynch @michael2021-10-20 22:17:39.552Zreplies toDru:

              Hmm, you might have the dubious honor of being the first customer to have a networking adaptor die in the field. It's surprising because we test each Voyager by hand before shipping them out, but maybe something came loose in transit.

              I'll email you a return label so that we can replace this for you.

              1. Michael Lynch @michael2021-11-01 19:17:43.138Zreplies tomichael:

                I received your return, and I can't reproduce the issue. The device boots up fine for me. The green LED activity light flashes, and the network port has an amber light and flashes green like normal.

                I wasn't able to reach https://tinypilot.local on the microSD in the return, but I reflashed it, and it booted fine, and I was able to reach https://tinypilot.local.

                It's possible that the hardware failure is intermittent, so I'll send a replacement.

                Is it at all possible that the router/switch you're connecting the Voyager to is defective?

                1. D
                  Dru P @Dru
                    2021-11-01 19:23:24.802Zreplies tomichael:

                    It's possible, but more likely it would be the power source I had it connected to as I wasn't seeing any activity on the status light on the TinyPilot board. I will have more people in the office this week to get another pair of eyes on it.

                    1. D
                      Dru P @Dru
                        2021-11-04 19:25:47.221Zreplies toDru:

                        Just got the TinyPilot back, and it looks like the HDMI to VGA cable I was using was the culprit. Without that cable it looks like it is booting and the network port is responding.

                        1. Michael Lynch @michael2021-11-04 19:28:46.787Zreplies toDru:

                          Thanks for following up!

                          I've never heard of the cable causing that issue. Are you connecting TinyPilot directly to a computer? Or is it going to another HDMI device? I've seen that happen with cheap HDMI-based KVMs because they're actually backfeeding power into the TinyPilot's HDMI port, which interferes with the device's boot. But I wouldn't expect swapping HDMI cables to fix that issue.

                          1. D
                            Dru P @Dru
                              2021-11-04 19:46:37.588Zreplies tomichael:

                              I am connecting the TinyPilot directly to the computer, this was using a TrippLite cable that doesn't look to be manufactured any more.

                              1. Michael Lynch @michael2021-11-04 19:53:31.818Zreplies toDru:

                                Oh, interesting! Maybe faulty HDMI cables can cause this. Good for me to keep in mind in the future.