No internet connection
  1. Home
  2. Technical Support

Mouse movements not detected, but clicks works

By @kpo
    2021-10-28 16:41:18.781Z


    I have installed my tinypilot today, which works fine for video capture, keyboard input and mouse clicks.
    But it doesn’t work with mouse movements : I don’t see the cursor moving, either on the web page or on the remote PC.

    With the help of the support, I've trying various solution but none worked :

    • Test with Firefox and chrome browsers
    • Change the view of the cursor
    • Replace the grey cable
    • Try to select in a text editor (only the double-click select all the text)

    On another computer, everything works fine : the mouse position is detected and I can use it normally.
    On the computer I need to take control, a basic mouse (connect by USB) works fine.

    Thank you in advance for the help :)

    Best regards,

    • 3 replies
    1. Hi kpo, thanks for reporting this! Sorry for the delay, as I was traveling.

      Can you share details about the hardware and OS of the target machine? And to clarify, on the problem computer keyboard input and mouse clicks work properly, but mouse movement doesn't work?

      1. K@kpo
          2021-11-02 09:23:23.667Z

          Hi Michael, thanks for your answer and no problem for the delay :)

          I want to use the tinypilot on a Dell 7480 laptop, but I can't share more information about the OS, because it's an home-made OS - based on Linux - developped by my company.

          And you have clarified the problem very well :)

          1. There are two main types of mice: absolute and relative. A typical external mouse with a laser or trackball is a relative mouse in that it moves the cursor relative to its current position. Absolute mice are things like touchpads and drawing tablets, where they don't move the mouse cursor relative to its current position but to an absolute position on the screen.

            Does your company's OS support absolute-positioned mice? It sounds like it might only support relative-position mice, which would explain why the USB mouse you tested worked but TinyPilot doesn't.