No internet connection
  1. Home
  2. Technical Support

after bullseye upgrade ansible virtualenv job fails

By sizz0p m0dem @sizz0p
    2021-11-11 17:53:27.326Z

    Has anyone upgraded to bullseye and been able to get everything running after the upgrade? I noticed that openipmi, ustreamer and a couple other services were not starting. Some services were fighting over opening ports, so I resolved those issues.

    I was getting a permissions error about the journal, and after vacc'ing up the journal files, ustreamer and openipmi are still not starting.

    I'm trying to figure out what's going on now. Anyone else solved this already? Thanks.

    Solved in post #10, click to view
    • 18 replies
    1. Thanks for reporting this!

      Is this on Pro or Community?

      We added a bullseye fix for uStreamer yesterday and a fix for the core software a few hours ago in the community version. We're planning to cut a new release next week with the fixes for TinyPilot Pro.

      1. Ssizz0p m0dem @sizz0p
          2021-11-11 18:10:20.025Z

          Hi, Michael. Thanks for the fast response!

          This is on a pro device. I took an image backup of it because I knew I was proceeding at my own risk, but I'd love to get this up and running without reverting. I'm just using this guy in my rack at home, so it's not a huge deal if it's down for a week or so. I have everything back up except for ustreamer and there's also something weird with openipmi.

          I'll take a look at what you've linked for the community edition, and if you want me to do any testing, let me know. Thanks!

          1. In reply tomichael:
            Ssizz0p m0dem @sizz0p
              2021-11-17 18:14:14.640Z

              Hey, Michael. Still pushing that Pro fix this week?

              If not, I may revert to my backup because I'm going to be installing some new equipment at the end of this week and will probably end up using the KVM. Thanks!

              1. We're planning to publish the new release tomorrow, and it should be compatible with buster and bullseye.

                1. Ssizz0p m0dem @sizz0p
                    2021-11-19 00:36:36.457Z

                    Hi. It looks like much of the update worked, but the virtualenv task seemed to fail, I think.

                    I'm seeing this output when trying to run the updater:

                    TASK [tinypilot.tinypilot-pro : create TinyPilot virtualenv] **************************************************************************************************************************************************
                    fatal: [localhost]: FAILED! => {"changed": false, "cmd": "/opt/tinypilot/venv/bin/pip3 list --format=freeze", "msg": "[Errno 2] No such file or directory: b'/opt/tinypilot/venv/bin/pip3'", "rc": 2}

                    PLAY RECAP ****************************************************************************************************************************************************************************************************
                    localhost : ok=73 changed=4 unreachable=0 failed=1 skipped=34 rescued=0 ignored=0

                    Any suggestions?

                    1. In reply tomichael:
                      Ssizz0p m0dem @sizz0p
                        2021-11-20 19:43:45.155Z2021-12-09 18:56:28.079Z

                        OK. after your update I was eventually able to get everything up the pro build, but I was having some issues, so I decided to pop in another SD, install bullseye fresh and then install the community build of TP.

                        After doing so, I am still not able interact with the host machine. Video capture is working great, but it's not passing keyboard/mouse input.

                        I'm seeing this HID error in the logs:

                        What do you think? I know it says the check the physical connection, which I have done. I'm using the adapter and cables from your kit, and when I put a usb device in that port on the host machine, it works with other devices...I'm not sure what's going on.

                        1. Ssizz0p m0dem @sizz0p
                            2021-11-21 06:11:10.776Z

                            The problem with keystrokes was caused by switching to an Argon One v2 case, in an attempt to better cool the device. It's working after going back in the original case.

                            1. Ah! Yeah, the Argon One case breaks the USB OTG functionality of the USB-C that TinyPilot needs to emulate keyboard/mouse.

                              Thanks for following up!

                              1. Ssizz0p m0dem @sizz0p
                                  2021-12-05 00:24:40.950Z

                                  Hi. I had to give up on the build that I upgraded and reinstall bullseye and then reinstall TinyPilot. I was able to get everything working with the non-pro version of TP on Bullseye.

                                  Is there a way that I can upgrade the device that was bought with a pro license from the non-pro version of TP to pro? Thanks!

                                  1. Yes, there are instructions here for upgrading from Community -> Pro via the command line:


                                    Let me know if you run into any issues on Bullseye.

                                    1. Ssizz0p m0dem @sizz0p
                                        2021-12-06 14:03:52.361Z

                                        Thanks! I see a couple of download links, but I can't seem to find the instructions...

                                        1. If you run the command under "Install from command-line" it will upgrade your system to Pro.

                                          1. Ssizz0p m0dem @sizz0p
                                              2021-12-06 14:14:20.517Z

                                              I don't see any instructions. I see 2 download links to image files and a doc about flashing an SD card, but nothing about TinyPilot.

                                              1. Are you seeing a page like this? The install command is in the grey box where the red arrow is pointing:

                                          2. In reply tomichael:
                                            Ssizz0p m0dem @sizz0p
                                              2021-12-07 16:54:07.758Z

                                              Hi Michael. I am not. I get redirected to the download page after verification on the original page.

                                              I am running pihole and various browser plugins for ads, so I'll check on other devices. If I'm able to figure it out, I'll post again that it was on me. Thanks.

                                              (Same behavior on multiple devices. Site asks for order number and email and then presents me with 2 download links but not what you see.)

                                              1. Sorry about that! I just sent you the correct link via email.

                                                1. Ssizz0p m0dem @sizz0p
                                                    2021-12-07 20:16:09.058Z

                                                    Winner Winner! Chicken Dinner! Thank you! Worked great.

                                • Progress
                                  with handling this problem
                                • S
                                  sizz0p m0dem @sizz0p
                                    2021-11-12 01:36:30.854Z

                                    Here's the bug info on openipmi in bullseye: