No internet connection
  1. Home
  2. General

TinyPilot Voyager 2 Keyboard does not work in Bios or Windows boot menu

By Silva @Silva
    2022-01-05 13:46:51.915Z

    Just got an TinyPilot Voyager 2. Setup with no issues. Easy to reach via browser.
    Left lower corner of browser window, when at the Windows login prompt,
    shows green and "connected"

    However...Keyboard and Mouse work well in Windows even at the pre login page
    but NOT during Bios or for Windows boot menu. Neither the Keyboard from remote
    controlling PC neither the Virtual Keyboard

    Things I tried:

    1. Confirmed all connections are correct and tried
      several USB ports with the PC

    2. Restarted several times both PC and TinyPilot

    3. PC Bios is ASUS 6T Deluxe V2
      A bit old...But patched to latest available version.

    1. TinyPilot is latest version ( 2.3.1 )

    Noticed similar issue here:
    Just bought a TinyPilot and the keyboard doesn't work at Bios with an Asus P6X58D-E motherboard
    but did not try the suggestions applied there. Was not sure if they make sense
    for the TinyPilot Voyager 2

    Suggestions ?

    Best Regards
    L. Silva

    • 9 replies
    1. S
      Silva @Silva
        2022-01-05 14:12:20.226Z

        Also just tried disabling virtual media per the FAQ...Made no difference.

        sudo sed
        's/init-usb-gadget\s{1,}\/init-usb-gadget --no-mass-storage \/g'
        /lib/systemd/system/usb-gadget.service &&
        sudo systemctl daemon-reload &&
        sudo service usb-gadget restart &&
        echo "tinypilot_enable_mass_storage_gadget: no" |
        sudo tee -a /home/tinypilot/settings.yml

        1. In reply toSilva:

          Thanks for reporting this! There seems to be an incompatibility with this line of motherboards because the other poster also had an ASUS P6xx board.

          We've since applied kernel patches, but I just realized that due to a change in how we built the 2.3.1 images, it didn't get applied unless you upgraded from a previous version. Can you try running this command from your TinyPilot:

           /opt/tinypilot/scripts/upgrade && sudo shutdown -r now

          That will force a reinstall of 2.3.1. It won't change your settings, but it should apply the kernel patch properly so that it can send keyboard input to the ASUS motherboard.

          1. SSilva @Silva
              2022-01-06 11:15:33.018Z

              Hi Michael,

              Applied your suggestion, and I am happy to report that solved the issue.
              I can now manage the Bios or the Multi Boot OS prompt menu :-)
              ( Love the product by the way..).

              What would be the best way to keep the TinyPilot up to date going forward ?
              Can I use the commands you posted or should I rely on the web app menu
              "System" -> "Update" ?

              L. Silva

              1. Going forward, you can update from the web UI. The manual update was to work around a stale kernel module in the pre-built image.

            • S
              In reply toSilva:
              Silva @Silva
                2022-01-08 01:11:25.658Z

                Just a somewhat unrelated note...but maybe a useful follow up for somebody thinking of trying the same.

                I got one of these:

                and it working quite nicely with the TinyPilot.

                The vendor has a somewhat crude but working app that allows you to reach it
                and change the IP but only to change the ports. No video or keyboard over the network.

                You can see it superimposed on the two printscreens.
                You might notice on one is using port 1 and on another port 2 going both always
                via the TinyPilot. Worked better than I thought.

                The communication protocol is documented here:

                Would be nice to have the control of the KVM switch also in the interface of the TinyPIlot
                Maybe something that you Michael already considered? I guess you would want to make
                it generic to support different vendors.

                1. Progress
                2. S
                  Silva @Silva
                    2022-01-05 15:13:20.943Z

                    Tried with a HP Pavillion laptop currently setup with dual boot Windows 10 and Fedora.

                    TinyPilot HDMI capture was unable to grab or sync up to Bios Screen, Windows Display
                    or Fedora Login Screen. Just showed either NO SIGNAL or a gray display.

                    Back at the original Assus PC with no progress yet.

                    1. Michael Lynch @michael2022-01-05 21:13:13.261Zreplies toSilva:

                      Certain laptops refuse to display output to anything but their native monitor during boot. It's not specific to TinyPilot, as they'll refuse to output to any display device.

                      Can you check the bios on the HP Pavillion laptop to look for options for displaying to an external monitor during BIOS/boot?

                      1. S
                        Silva @Silva
                          2022-01-06 11:17:13.857Zreplies tomichael:

                          Laptop is on the road right now ...Will try in a few days and report findings
                          here in 3 to 4 days.

                          1. S
                            Silva @Silva
                              2022-01-07 21:17:34.965Z2022-01-07 21:49:15.621Zreplies toSilva:

                              Ok. It works. Installed Ubuntu on it but nothing related to the initial issue.

                              HP Pavilion Laptop does not have such an option I could find in the Bios, but
                              Command (Windows key) + P allows to toggle between just external screen, internal or both.

                              The default will make the TinyPilot the second screen as an extended screen.

                              When I left the Laptop at its default resolution of 1920 x 1080 (landscape aspect ratio )
                              the TinyPilot had screen sync problems and in the screen shown
                              in the first printscreen below.

                              The configuration I used to make all this work, is as can be seen on the second screen.
                              Screens as Screen Mirroring in Ubuntu and a lower resolution of 1280 x 720.

                              I am Ok with this, although its not the native resolution of the Laptop.
                              If you think it should work at 1920 x 1080 let me know
                              your suggestions. USB for mouse and keyboard working fine.

                              Working config