No internet connection
  1. Home
  2. General

Power splitter doesn't give power to raspberrypi

By Sungwoo Park @cos18
    2022-02-11 05:48:06.697Z

    Hello. I love your project to control my home mac. I bought your power splitter to give more power to pi, but raspberrypi doesn't boot completely. In raspberrypi there light only green but not red. I found that that light means there is not enought power to pi. I use 5v3a power adapter to power splitter. Is splitter defective?

    • 12 replies
    1. We test all of the power connectors manually before shipping them out, so defects are rare, but they still can happen.

      Does the Pi boot up if you connect the Pi directly to the target machine with a USB-C to USB-A cable?

      1. C
        In reply tocos18:
        Gene Montgomery @Cthulhu7747
          2022-02-16 02:13:40.799Z

          You really need a 5.25V power supply when using a power splitter:

          https://smile.amazon.com/gp/product/B07D8ZZSFT/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1

          1. N
            In reply tocos18:
            Neil Tender @ntender
              2022-06-27 16:49:02.436Z

              Hi, I'm experiencing the same problem. When I use the power splitter, Raspberry Pi 4 boots up part way but then freezes - HDMI output shuts off and monitor no longer gets signal. When I bypass the power splitter, Pi boots up okay. I'm using the 3A power adapter that is recommended on the GitHub page:
              https://smile.amazon.com/dp/B0728HB18G
              I'll go ahead and purchase and try the 5.25V adapter suggested by Gene Montgomery. I'll report back. If it works, then maybe the problem is voltage drop through the splitter?
              What type of power adapter was used when splitter was tested?

              1. DDiego @diego2022-06-27 18:02:02.779Z

                Hello @ntender, thank you for posting your question here.

                What power splitter are you referring to? Do you mean this one? Or are you using a different power splitter?

                1. NNeil Tender @ntender
                    2022-06-27 18:33:19.409Z

                    yes, that is the one!

                    1. DDiego @diego2022-06-27 20:28:18.960Z

                      Those instructions mention a "5 V / 3 Amp USB power adaptor".

                      1. NNeil Tender @ntender
                          2022-06-27 22:31:17.859Z

                          I'm following these instructions, which have a link to a specific power adapter available at Amazon (which is the one I'm using):
                          https://mtlynch.io/tinypilot/#how-to-build-your-own-tinypilot
                          This power adapter puts out 5V for USB, and it is rated at 3A for this voltage range. So I think it's correct for both sets of instructions (the ones you referenced and the ones I followed, which are similar).
                          But yet it's not working when I go through the TinyPilot Power Connector. Am I doing anything wrong here? Is there a problem with the TinyPilot Power Connector?
                          Thanks!

                          1. DDiego @diego2022-06-28 23:00:47.484Z
                            • When you use the power splitter... How do the LEDs look on the Raspberry Pi?
                            1. NNeil Tender @ntender
                                2022-06-29 04:56:02.991Z

                                I tried powering up the Pi a few times with the power splitter. The results are not the same every time. The red and green LEDs flicker for awhile. Then after a couple of minutes, the LEDs settle -- sometimes I see solid red, sometimes solid green, and sometimes both red and green at the same time. In all cases, the bootup does not complete successfully.
                                If I power up without the power splitter, then the results are different. The red and green LEDs flicker for awhile, but then it always ends up settling on the solid red LED illuminated by itself. And the Pi always boots successfully.
                                Please let me know if this helps and if I can provide you with any more useful info.

                                1. DDiego @diego2022-06-29 21:08:33.702Z

                                  The problem would have to be one of:

                                  1. Defective USB-C to USB-A cable
                                  2. Defective microUSB to USB-A cable
                                  3. Defective Power Splitter
                                  4. Defective Pi
                                  5. Defective PSU

                                  It’s probably not (1), (4), or (5) since the setup works for you if you skip the Power Splitter.

                                  It could still be (2), so it would be nice if you can try with another microUSB to USB-A cable.

                                  1. NNeil Tender @ntender
                                      2022-06-30 14:28:04.560Z

                                      Hi, thanks for the great tips! I figured out the problem - it is the microUSB to USB-A cable. I tried a different (shorter) cable along with the power splitter and it worked!
                                      I broke out my voltmeter and took some measurements. With the long cable, the voltage in the Pi was only 4.70 which is too low. This explains why it wasn't working. With the short cable, it was 4.93 which is in the acceptable range.
                                      So sounds like I need to get a new long cable that has lower loss - a higher quality one with thicker gauge wire.
                                      Thanks again for your help. It would never have occurred to me that the problem was the cable.

                                      1. DDiego @diego2022-06-30 19:59:48.154Z

                                        Hi Neil! I'm glad you were able to sort it out! Have a great day!