No internet connection
  1. Home
  2. Technical Support

Video showing broken image icon, keyboard and mouse still work.

By Richard Wang @rcwang
    2022-02-12 06:17:16.414Z


    I just purchased this TinyPilot Pro a few weeks ago. It has been working fine until today when I start getting the broken image icon. Keyboard and mouse (within that tiny image icon) still kinda works. I noticed there's a thread having the exact same issue as mine, but our error messages seem a bit different. Mine says:

    Feb 12 05:59:45 tinypilot systemd[1]: Started uStreamer - Lightweight, optimized video encoder.
    Feb 12 05:59:45 tinypilot ustreamer[641]: Unknown encoder type: omx; available: CPU, HW, NOOP
    Feb 12 05:59:45 tinypilot systemd[1]: ustreamer.service: Main process exited, code=exited, status=1/FAILURE
    Feb 12 05:59:45 tinypilot systemd[1]: ustreamer.service: Failed with result 'exit-code'.

    I tried the suggested method below but still didn't work:

    cd /opt/ustreamer/
    sudo make clean
    sudo make
    sudo systemctl restart ustreamer.service

    My log can be found here:
    Please help, thanks in advance.

    Solved in post #2, click to view
    • 3 replies
    1. Thanks for reporting this! Sorry for the dead stream.

      It looks like you're using a Voyager series or a DIY TinyPilot with the HDMI to CSI bridge. Is that right?

      If so, when you recompile uStreamer, you need to pass an extra argument:

      cd /opt/ustreamer/
      sudo make clean
      sudo make WITH_OMX=1
      sudo systemctl restart ustreamer.service

      Can you try that and let me know if it gets your stream back?

      1. RRichard Wang @rcwang
          2022-02-14 19:52:48.414Z

          Your solution works! Thank you Michael!

          1. Great, thanks for letting me know!