No internet connection
  1. Home
  2. Technical Support

[solved] TinyPilot URLs fail to resolve

By @SnDz
    2022-02-12 19:46:48.189Z2022-02-12 20:10:32.626Z

    My tinyPilot's red light is on. It is connected to a computer (Ubuntu Linux 20.04) via USB. I have plugged in an ethernet cable directly from ISP router to Tinypilot. I see the Ethernet powers green and orange lights when ethernet is plugged in.

    https://tinypilot/ shows this error:

    This site can’t be reached
    tinypilot.local’s DNS address could not be found. Diagnosing the problem.

    The same errors appear on tinypilot.local and tinypilot.localdomain

    This is in Brave browser. Chrome and Firefox show the same error.

    I have also tried accessing the Tinypilo web UI from another computer (MacOS Monterrey) on this network. It also failed to connect in the browser after waiting 10+ minutes.

    Both computers are plugged into the same ISP router. They have no internet connection issues.

    I do not believe any blacklists or firewalls are in place to block the tinypilot domains.

    What else could be preventing the TP from being connected to?

    Solved in post #10, click to view
    • 13 replies
    1. B
        2022-02-13 01:56:15.883Z

        Hi as a test, can you try network connectivity without using the ISP router?

        I have a router with an ethernet port that can be configured as a WAN (uplink) or LAN (local) connection.

        Perhaps your router has the same setting.

        1. S@SnDz
            2022-02-13 10:23:27.015Z

            Sure, I tried the following:

            1. Unplug my computer's ethernet from the router. It could no longer access the internet. No pages loaded.
            2. Unplug my Tinypilot from the router. The computer could not access it.
            3. Replug in the computer to the router. It could access internet but not the tinypilot.
            1. B@burg
                2022-02-13 13:00:35.680Z

                Okay, I should have been more clear. I was trying to remove just the ISP router from your network architecture. Internet access isn't required for this test.

                Can you try creating a local network using an unmanaged switch to connect your computer and the TinyPilot?
                This would also require using a static IP address if you were relying on DHCP from the ISP router.

                1. S@SnDz
                    2022-02-13 14:20:24.954Z2022-02-13 15:18:41.392Z

                    Thanks, can you recommend an unmanaged switch?

                    Is there anything else I can test before I buy that?

                    1. B@burg
                        2022-02-14 01:59:57.115Z

                        There are more things to troubleshoot before buying something that was intended to be a test...I was hoping you had one lying around!

                        What is the Manufacturer and model of your router?

                        Do you have access to the configuration settings of the router?

                        I'm wondering if DNS is enabled or not.

                2. C
                  In reply toSnDz:
                  Gene Montgomery @Cthulhu7747
                    2022-02-13 18:32:18.577Z

                    Have you tried connecting to the TinyPilot using its IP address?

                    1. S@SnDz
                        2022-02-13 18:38:46.893Z

                        I have not, do you know how to locate its IP address? My main computer is on Ubuntu 20.04 and I also have a Mac Mini with MacOS Monterrey

                        1. CGene Montgomery @Cthulhu7747
                            2022-02-13 18:43:35.000Z2022-02-13 19:02:26.478Z

                            Your router should have a DHCP client page; the TinyPilot's IP address should show up there.

                            You could also install nmap on your Ubuntu machine and run sudo nmap -sn -vv (or whatever your subnet is) to get an inventory of devices on your network.

                            Here is an example:

                            Nmap scan report for 172.16.X.X
                            Host is up, received arp-response (2.5s latency).
                            MAC Address: XX:XX:XX:XX:XX:XX (Raspberry Pi Trading)

                        2. S
                          In reply toSnDz:
                            2022-02-14 15:51:34.698Z

                            Guys, this is resolved. A network admin did the following:

                            1. Looked up all IPs on the network.
                            2. Looked up the tailscale IP
                            3. connected via ip address in the browser.

                            Thanks for the help!

                            1. R
                              In reply toSnDz:
                                2022-02-14 22:11:24.262Z

                                When I click on the Advanced Button, I don't get the link to proceed to the site... Suggestions?

                                I tried in Chrome and Brave.

                                1. Sorry about this! Browsers are unfortunately uncooperative with TLS for local devices.

                                  Can you try the steps here?


                                2. Progress
                                3. R
                                    2022-02-14 22:18:29.111Z

                                    So I was able to get into the tinypilot from FireFox, but nothing is showing up on the main screen of the target computer...

                                    1. Michael Lynch @michael2022-02-14 22:33:36.324Zreplies torobgpeak:

                                      @robgpeak - Hmm, that's really strange. I'll help you figure out what's going wrong there.

                                      Can you start a separate thread for this?