No internet connection
  1. Home
  2. General

TinyPilotPro KVM with HDMI direct to 12900K motherboard and no video

By diegomontoya @diegomontoya
    2022-02-21 02:11:23.863Z2022-02-21 02:18:47.150Z

    Running 2.3.2 and yet we still can't video to show using two separate HDMI direct cables.

    This is Asus z690M-PLUS D4 board with 12900K cpu.

    OS is Linux Ubuntu 22.04.

    Btw, the machine is running in CLI mode, no x11/xorg running. So just simple shell/server mode.

    1. Bios mode works.
    2. Once Ubuntu 22.04 boots to CLI, there is nothing on screen.
    3. Tried two different cables.
    4. No UI is installed on the ubuntu 22.04 system. Just direct boot to CLI

    UPDATED:

    1. We first connected tinypilot pro to the linux cli server after the os booted and it showed nothing.
    2. Tried two different hdmi cables and nothing.
    3. We reboot the linux/ubuntu 22.04 machine and now everything works.

    There appears to be a bug where HDMI output is not detected if tinypilot is connected to a linux machine post boot?

    • 2 replies
    1. In reply todiegomontoya:

      Thanks for reporting this!

      Does it display to a physical monitor if you connect it post-boot?

      Some systems don't display to a new output if you connect it after the system is already booted, so TinyPilot won't be able to capture output in those instances until you reboot the target machine.

      1. D
        In reply todiegomontoya:
        Diego @diego2022-02-24 19:01:15.034Z

        Hello @diegomontoya ! I'm curious if the behaviour you described is still happening (meaning there is no video if you connect TinyPilot past boot), or if your issue has been permanently fixed.

        If it stills shows no video when you connect it past boot, I would try the following (assuming you have TinyPilot connected to one HDMI port and a monitor to another HDMI port).

        sudo update-pciids
        lspci -nn |grep 'VGA'
        

        That might fix the issue without you having to reboot. They are meant to be typed in your Ubuntu 22.04 server. Let me know if you try this. Thanks!