No internet connection
  1. Home
  2. General

Hello. Cannot connect to the tinypilot

By Alexander Brazhnikov @AlexB
    2022-03-02 19:01:14.481Z

    Hello.
    I bought my pilot 2 wks ago. Tinypilot worked fine till yesterday. My computer and the tinypilot are on the same network.
    I can ping it but I cannot open anything in the browser. It shows err "tinypilot refused to connect."
    The ethernet connection is good. No router or port forwarding is involved.
    I already reboot the pilot.
    Any suggestions?

    • 8 replies
    1. Sorry you're running into this! Do you have more than one TinyPilot on the same network? If so, you'll need to assign one of them a different hostname. If they're both named tinypilot, they'll conflict with each other on the network. You can change the hostname through System > Hostname from the web dashboard.

      Can you share the exact error you're seeing in the browser when you try to connect?

      1. A
        In reply toAlexB:
        Alexander Brazhnikov @AlexB
          2022-03-03 00:00:45.654Z

          Currently I have only one tinypilot in my network

          1. A
            In reply toAlexB:
            Alexander Brazhnikov @AlexB
              2022-03-03 00:01:03.868Z

              This site can’t be reachedtinypilot refused to connect.
              Try:

              Checking the connection
              Checking the proxy and the firewall
              ERR_CONNECTION_REFUSED

              1. D
                In reply toAlexB:
                Diego @diego2022-03-03 01:23:33.891Z

                Hello Alexander! I looked into old posts, and I found out another user was able to fix the same error after connecting to the TinyPilot using straight IP address.

                Would you be able to test if that works out for you? i.e. look in your router for the DHCP entry that is assigned to the TinyPilot, then use that IP address in your browser.

                1. A
                  In reply toAlexB:
                  Alexander Brazhnikov @AlexB
                    2022-03-03 14:49:32.825Z

                    Hello!
                    The assigned IP address is correct. I checked it with Advanced IP scanner as well as on the router in DHCP section...

                    1. I'm not sure what's going wrong here. It seems like the nginx server on your TinyPilot is failing for some reason. We'll send you a new microSD.

                      1. AAshish Yadav @ashish9433
                          2022-04-13 14:27:50.843Z

                          @michael I am having exactly same issue. Using Network scanner i was able to identify the IP and do SSH. I tried running the update command couple of time (/opt/tinypilot-privileged/update && sudo reboot) It fails giving error "that could not open log '/var/log/dpkg.log': Is a directory"
                          Though i went there and found that the file exists there but i was unable to cat/tail the file. Any suggestions how do i fix it?

                          I have two device, one has been working/running fine since more than 4 months and this one is giving trouble every 2-3 weeks

                          1. DDiego @diego2022-04-13 15:21:28.413Z

                            Hello @ashish9433 - I'm sorry you are having this issue. If you don't mind please open a separate thread for your issue, as it it a different problem.

                            It looks like something may be corrupted: /var/log/dpkg.log should be a file and not a directory. You can try a factory reset.