No internet connection
  1. Home
  2. Technical Support

Latest update disabled my ability to remotely control my computers.

By @gameandtester2021-03-10 18:11:46.982Z

So with the set up I have, is a POE Hat, and a USB 3 cable with the V+ blocked and plugged into the PC from the USB Power slot of the Pi (4 Mdl B).

This setup was working for me before I updated to the latest version and then I no longer have the ability to send keyboard/mouse input to the target computer.

Any idea if anything has changed based on how input is handled to the target computer?

  • 8 replies
  1. Michael Lynch @michael2021-03-10 22:11:52.178Z

    Thanks for reporting this!

    There were only minor changes around the mouse/keyboard forwarding, so it's surprising that this should suddenly stop working.

    Can you share your debug logs from System > View Logs?

    1. T@tom2021-03-20 06:56:20.079Z

      Any update on this? Having the same issue

      1. Michael Lynch @michael2021-03-22 12:57:41.016Z

        Sorry about this! I pushed a bad change on Friday that broke input forwarding. It's fixed now. If you update to the latest version, it should restore input forwarding.

    2. R
      In reply togameandtester:
      @rcdc2021-03-21 11:21:46.653Z

      I think I'm having the same problem just after a new install on a new Raspberry Pi. Video but no keys or cursor control

      1. R@rcdc2021-03-21 11:44:52.775Z

        not sure if this helps elucidate the issue but I presume it's related to the general thing of keyboard and cursor not working now - when I try to run the mouse jiggle code I get this error around Line 22 in SSH terminal: "line 22: echo: write error: Resource Temporarily unavailable"

        1. In reply torcdc:
          Michael Lynch @michael2021-03-22 12:57:07.059Z

          Sorry about this! I pushed a bad change on Friday that broke input forwarding. It's fixed now. If you update to the latest version, it should restore input forwarding.

        2. Progress
          with handling this problem
        3. J
          stephane suvee @jetconnect2021-03-21 09:22:01.457Z

          Hello , new install on raspberry pi4 and same problem. Image is ok , but no mouse and keyboard.
          in Windows 10 i have this a "!" on the 2 components.

          In the drivers i have this " L'appareil USB\VID_1D6B&PID_0104&MI_01\7&3103452e&0&0001 n’a pas été migré à cause d'une correspondance partielle ou ambiguë."

          I have this on the 5 computer i test.

          1. Michael Lynch @michael2021-03-22 12:56:58.849Zreplies tojetconnect:

            Sorry about this! I pushed a bad change on Friday that broke input forwarding. It's fixed now. If you update to the latest version, it should restore input forwarding.