No internet connection
  1. Home
  2. Technical Support

Black screen?

By Jimmy Pierre @guru76
    2022-04-09 10:19:27.741Z

    Hi,

    I installed PinyPilot yesterday manually on this Raspberry 4:
    cat /etc/os-release
    PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
    NAME="Raspbian GNU/Linux"
    VERSION_ID="11"
    VERSION="11 (bullseye)"
    VERSION_CODENAME=bullseye
    ID=raspbian
    ID_LIKE=debian
    HOME_URL="http://www.raspbian.org/"
    SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
    BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

    Everything went fine, but when I point any browser to http://{IP} or http://{hostname}, I get a black screen. If I move the mouse inside the black screen, the mouse moves on target too :)

    Please point me to some debugging that I could do please.

    Best wishes,
    Jimmy

    • 13 replies
    1. D
      Diego @diego2022-04-11 18:25:50.877Z

      Hello @guru76 - Welcome to the forum!

      • When you say "black screen", do you mean a black NO SIGNAL screen, or just plain black screen?
      • Are you connecting your RaspBerry Pi to a PC, or a laptop? How are you connecting to it (wires details)?

      I recommend the following reading which has plenty of info on how to build your own KVM-over-IP device.

      1. GJimmy Pierre @guru76
          2022-04-11 19:21:04.720Z

          Hi Diego,

          I noticed that I actually used these instructions to build theTinyPilot. I tried three other boxes using the same connections:

          1. Server 2019 = OK
          2. Windows 10 Pro = OK
          3. Debian/Proxmox = OK

          but now it comes: Windows 11 Pro = KO

          The next step would be to use a Ezcoo 4 port HDMI switch in this architecture. I tried that as well, I can change the input manually. Again the three boxes mentioned above worked and Windows 11 Pro is KO. A combination of keys should change the input from he keyboard too.

          Is the problem of the black screen related to Windows 11 in your opinion?

          Cheers,
          Jimmy

          1. DDiego @diego2022-04-11 20:00:04.765Z

            Hi Jimmy,

            Have you tried switching the cables in the HDMI switch? One port might be defective. If it is not that, then I would say it looks like it is related to Windows 11 indeed, as all other Operating Systems work ok.

            • When you say "black screen", do you mean a black NO SIGNAL screen, or just plain black screen?
            • Can you provide more details on the wiring of this setup? What HDMI capture dongle are you using?
            1. GJimmy Pierre @guru76
                2022-04-11 20:37:16.736Z

                Hello Diego,

                Thanks for your help indeed.

                As a matter of fact, I am using : https://www.amazon.fr/gp/product/B08CH23D5V/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

                All the cables are brand new and tis is how they are connected :

                Raspberry Pi 4

                1. From USB-C splitter, USB-C >>> USB-C RPi
                2. LAN RG-45 >>> RG-45 RPi
                3. USB-A RPi >>> Video Capture >>> Output HDMI Ezcoo

                EZCOO
                a. Four kb/mice (OUT) USB-A cable >>> USB-A EZCOO
                b. Actual (IN) kb/mouse >>> USB-A EZCOO
                c. HDMI EZCOO >>> VIDEO CAPTURE >>>USB-A RPi
                d. USB-A (front) >>> USB-C Splitter (DATA)

                POWER SUPPLY
                i. USB-C >>> USB-C splitter

                Black screen with Windows 11, when I move the mouse inside the black screen, it moves on the target computer.

                Thanks,
                jimmy

                1. DDiego @diego2022-04-11 21:02:33.627Z

                  Hi Jimmy,

                  Can you try a direct connection between the TinyPilot and the Windows 11 machine without the ezcoo KVM involved?

                  1. GJimmy Pierre @guru76
                      2022-04-12 06:17:18.836Z

                      Hello Diego,

                      By all means yes! I followed your advice, a direct connection between Raspberry / Windows 11, same results. I also swapped cables. No joy!

                      Have a great day !
                      Jimmy

                      1. DDiego @diego2022-04-12 13:22:45.118Z

                        Hey Jimmy - Thank you for your bright attitude!

                        So we narrowed it down to the Windows 11 machine indeed.

                        • Are you at least able to see the POST / BIOS messages? Anything at all?
                        • Does the black screen include a NO SIGNAL message?
                        • What kind of machine is it, is it a laptop or a PC (model if possible)?
                        1. GJimmy Pierre @guru76
                            2022-04-12 17:02:29.190Z

                            Hiya Diego,

                            I rebooted a few times, no POST / BIOS messages at all. Just a black rectangle.THe black screen is really "silent".

                            It's a X260 Lenovo, 8GB RAM/256 GB ssd.

                            Cheers,
                            Jimmy

                            1. DDiego @diego2022-04-13 15:45:39.202Z

                              Hi Jimmy! This is a tough one. Not sure what is going on. Can you try the following?

                              • On the Windows 11 machine hit Win+P and then select "Duplicate." Perhaps you have it configured to not to display to a second monitor, trying to rule that out.

                              • If the above doesn't work, can you check the Display settings on the Windows 11 machine. Do you see the TinyPilot as a display output?

                              1. GJimmy Pierre @guru76
                                  2022-04-15 11:49:31.708Z

                                  Hiya Diego,

                                  First, thanks for for time in helping to solve this dilemma :)

                                  WIN + P said no projector

                                  And 2. TinyPilot not detected.

                                  I even went into the BIOS to see if something related to display was disabled .... No joy!

                                  I have been updated again and again, no joy either.

                                  I will now hunt Windows 11 forums for some clues and will keep you posted accordingly.

                                  Best wishes,
                                  Jimmy

                                  1. DDiego @diego2022-04-15 15:12:58.105Z

                                    Hello Jimmy!

                                    I'm running out of ideas here, so yes, it would be good to check those forums you mentioned. Let me know if you find anything!

                                    1. In reply toguru76:
                                      GJimmy Pierre @guru76
                                        2022-04-15 15:50:00.066Z

                                        Hi again Diego,

                                        Let me explain what I did on Windows 11:
                                        Normally on a vanilla installation, I had nothing to do in order to duplicate a display, or extend it to a second display. W11 seem to work differently, in that you must tell it to detect, bla bla bla.
                                        After testing a few scenarios, I had a one to one connection between W11 and TinyPilot and I went for a full Windows Update for the display drivers and even those drivers that W11 did not carry along during initial installation by going to Lenovo website and downloading drivers one by one. I was updating the BIOS when I sort of saw the mirror of what I was doing on the TinyPilot browser. I waited a minute, there was a reboot! I moved the mouse and the mouse moved in TinyPilot, ok the keyboard was not reacting, but I would see the screen!
                                        I can therefore report that the video display is fine, fluid. When I have time, I will check the kb/mouse issue. Tomorrow I have my Software Freedom Day and has already written a post: https://nui.fr/travaux-mi-mars-a-mi-avril-2022/
                                        Thanks a lot Diego for your support!
                                        Talk soon,
                                        Jimmy

                                        1. DDiego @diego2022-04-15 15:58:20.742Z

                                          Hey Jimmy, that is awesome! Thank you for sharing. And thank you for the blog post link!