No internet connection
  1. Home
  2. Technical Support


By Dominik @domdorn
    2022-04-28 09:48:12.112Z

    I've got my Tinypilot Voyager last december via In my logs I now get messages about Under-Voltage. How is this possible?
    I'm using exactly the components that where shipped..

    [    6.875685] Under-voltage detected! (0x00050005)
    [   27.673651] Voltage normalised (0x00000000)
    [   29.753636] Under-voltage detected! (0x00050005)
    [   33.913642] Voltage normalised (0x00000000)
    [   38.073727] Under-voltage detected! (0x00050005)
    [   52.633661] Voltage normalised (0x00000000)
    [ 1003.222852] Voltage normalised (0x00000000)
    [ 1019.863163] Under-voltage detected! (0x00050005)
    [ 1059.381709] Voltage normalised (0x00000000)
    [ 1080.180676] Under-voltage detected! (0x00050005)
    [ 1182.096933] Voltage normalised (0x00000000)
    [ 1184.176851] Under-voltage detected! (0x00050005)

    I also tried to post the full dmesg log, but the server complained about "Request Entity too large"

    Solved in post #8, click to view
    • 10 replies
    1. Thanks for reporting this! Sorry your Voyager is having power issues.

      The possible causes are (in descending order of probability):

      • Bad USB-A to micro-USB power cable
      • Bad USB-A to USB-C cable
      • Bad Power Connector
      • Bad power supply

      Did you always get those messages or is this new? It's possible that you either received a faulty cable or something happened to the cable that weakened the connection (e.g., someone rolled over it with a chair). Can you try swapping the power and data cables going into the Power Connector? If the problem is in the USB-A to micro-USB power cable, swapping the power and data cables should confirm that.

      If you have another USB-A to USB-C cable, you can try swapping it out for the TinyPilot's USB-A to USB-C to see if that's causing the problem.

      If you have another 5 V / 3 A power supply available, you can swap that in to see if the power supply is the issue.

      I also tried to post the full dmesg log, but the server complained about "Request Entity too large"

      If this happens in the future, you can upload directly to our log server by running this command:

      dmesg | curl -F '_=<-'

      It will print out a URL that you can share.

      1. DDominik @domdorn
          2022-04-28 15:22:46.032Z

          I don't know how long this has been going on cause I just looked today into the tinypilot as I was unable to connect (turns out it was a zerotier issue on my mac). I'm using the exact components that where shipped (except for the HDMI cable, as none was included). Also no one is able to roll-over the cable or anything, as its in a safe place, see .. the Pi is normal in the black box together with the switch you can see there, so there's no strain on the cable and basically no movement at all. Only thing I could think of is that the pi is not flat on a surface. However, since the morning its flat on my table and I got also now plenty of entries in the log ( or which I took right after making a pic of the charger - see next sentence) . This is the charger that was included, I was expecting that it fits the requirements ( and ) as it was included in my order from . Unfortunatelly, I don't have another usb-a to usb-c cable, as my other equipment is all apple based.

          1. Can you try swapping the power and data microUSB cables going into the Power Connector? If the problem is in the USB-A to micro-USB power cable, swapping the power and data cables should confirm that.

            1. DDominik @domdorn
                2022-04-28 19:51:00.275Z

                I've switched the cables, and from the dmesg it looked stable.. after starting this post, I've opened the web ui which switched on the screen of the laptop and exactly then an undervoltage appeared which shortly after stopped again.. then when I moved the mouse or entered something using the keyboard (via webui), it started undervolting again and stopping shortly after..
                It looks like its draining power through the HDMI or USB from the raspberry pi to the laptop?

          2. In reply todomdorn:
            @fft2022-04-29 06:30:02.442Z

            Hi Dominik,
            I just got noticed from Michael. I do want to exchange the full "Power unit stack" for free, but I cannot find your shipping address, as I do not find any Dominik (or the given E-Mail) in my database. Just post the serial number here, and I might be able to find your address, or send a mail to with all the data.
            thank you

            1. DDominik @domdorn
                2022-04-29 08:28:12.468Z

                Hi Jürgen,
                thanks, I've sent a mail to the given address with the original invoice attached.


              • D
                In reply todomdorn:
                Dominik @domdorn
                  2022-05-03 10:32:56.466Z

                  Received the new cables + charger few hours ago.
                  Logs before (with old charger):

                  Logs now after an hour uptime:

                  No more under-voltage 🥳🚀 thanks a lot!

                  1. Diego @diego
                      2022-05-04 20:48:59.050Z

                      Hi Dominik! Thank you for the update, I'm glad your issue was resolved!

                    • D
                      In reply todomdorn:
                      Dominik @domdorn
                        2023-08-23 17:43:53.246Z

                        Sorry to revive the old thread.. after just purchasing the upgrade to 2.6.0 and flashing the card, I've looked at the logs again and I again have undervoltage errors with the power supply you sent me last year.
                        I don't get how this is possible? Would it save power if we reduced the screen resolution?

                        1. David @david2023-08-23 18:35:04.068Z

                          I'm sorry that you're running into power issues again, @domdorn.

                          This is pretty unexpected behavior - I definitely don't think that's anything to do with your 2.6.0 update. It could just be unfortunate timing. Changing your target machine's resolution likely won't make any significant difference to your device's power draw (although you're welcome to experiment if you like).

                          Do you have access to other power supplies / cables that you could test with? I'm wondering whether this could be a simple bad power cable.