No internet connection
  1. Home
  2. Technical Support

Updating TinyPilot behind proxy

By j0shi @admj0shi
    2022-05-12 09:40:59.345Z

    Hi,

    we currently have a couple of TinyPilot Voyagers and are in a company network and sitting behind a proxy.
    We would like to update via WebGUI but there is no way to set a proxy via webGUI.

    I have enabled SSH and set the proxy via command for GIT, PIP and APT

    GIT:

    git config --global http.proxy http://<proxy.server>:<port>
    

    PIP:

    export https_proxy="http://<proxy.server>:<port>"
    

    APT:

    With vi I edited the file "90curtin-aptproxy" under /etc/apt/apt.conf.d
    

    Then I did the following command:

    /opt/tinypilot/scripts/upgrade
    

    Which installs 2.3.2, but the current version is 2.4.0

    https://tinypilotkvm.com/pro/changes

    How can I configure the TinyPilot in such a way that we could also use update it via WebGUI and how come the terminal command is installing an older version and no the current 2.4.0?

    Thanks and kind regards

    • 4 replies
    1. D
      Diego @diego2022-05-12 16:16:56.112Z

      Hello @admj0shi - Welcome to the Forum, and thank you for posting your questions here.

      I'm sorry you are having this issue. Unfortunately, I can’t think of any reason why the upgrade script would update to the wrong version.

      • If you don't mind, can you share the output with me? Use the command below, so that the output will be uploaded to us. Please reply back with the URL you will be given.
      sudo /opt/tinypilot-privileged/update 2>&1 | \ 
        curl -F '_=<-' https://logs.tinypilotkvm.com
      
      1. Aj0shi @admj0shi
          2022-05-13 06:46:52.172Z2022-05-13 07:56:43.894Z

          Hi thank you very much.
          The following link has been created.
          http://logs.tinypilotkvm.com/MSAN2NOA

          1. DDiego @diego2022-05-13 18:19:43.403Z

            Hey @admj0shi! Can you try the following?

            • Please edit /home/tinypilot/settings.yml and delete this line: tinypilot_repo_branch: 2.3.2
            • Then try to update again:
            sudo /opt/tinypilot-privileged/update 2>&1 | \ 
              curl -F '_=<-' https://logs.tinypilotkvm.com
            
            • Remember to reply back with the URL you will be given.
            1. DDiego @diego2022-05-13 21:04:07.976Z

              Actually, if you have not done it yet... instead of deleting the line please replace it with: tinypilot_repo_branch: 2.4.1

              That's because otherwise the default repo is master, which is not necessarily a stable release. Right now, master equals 2.4.1 because we just released, but long-term, you will not want to keep updating against master.