No internet connection
  1. Home
  2. Technical Support

No mouse when connecting TinyPilot via AIMOS KVM

By David Bridges @DAB42
    2022-05-16 00:50:40.884Z

    When my TinyPilot is connected directly to a PC it works fine, but if I try to connect it via an AIMOS KVM as described in the KVM compatibility list (i.e. combined with HDMI splitter) the keyboard works but the mouse does not, the pointer jiggles randomly across the screen.

    I have a Voyager 2 with the latest firmware. The video on the Internet that illustrated the KVM setup was using the older version of the TinyPilot hardware, is this no longer supported in the new version?

    • 14 replies

    There are 14 replies. Estimated reading time: 13 minutes

    1. D
      Diego @diego2022-05-16 17:25:09.723Z

      Hello David! I'm sorry you are having this issue.

      The AIMOS KVM handles power strangely, it draws power from HDMI. We have tested this device to work best when using a powered HDMI splitter.

      The video on the Internet that illustrated the KVM setup was using the older version of the TinyPilot hardware, is this no longer supported in the new version?

      The hardware used in the video and the Voyager 2 hardware can both support an AIMOS KVM, provided you use it with a powered HDMI splitter.

      1. DDavid Bridges @DAB42
          2022-05-17 06:30:18.662Z2022-06-20 22:16:52.359Z

          I was using a powered HDMI splitter, per the instructions in the video.

          This one: OREI UltraHD 4K @ 60 Hz 1 X 2 HDMI Splitter 1 in 2 Out 2 Port 2: 8-Bit - HDMI 2.0, HDCP 2.0, 18 Gbps, EDID, Duplicate / Mirror 4K Screens - UHDS-102, includes 100-240 50/60 Hz auto-switching power supply.

          1. DDiego @diego2022-05-17 19:32:31.586Z

            @DAB42 - We have the AIMOS KVM, and we just tested it with a Voyager 2 and TinyPilot Pro 2.4.1, and everything worked as expected.

            Here are some things you can try:

            • Try plugging the TinyPilot into one of the other USB inputs on the AIMOS, like Hub 1 or Hub 2 (on ours, every port worked, though).

            • Verify that no virtual drives are mounted (under System > Virtual Media)

            If none of these work, then it’s possible that your AIMOS device may be defective.

            1. DDavid Bridges @DAB42
                2022-06-20 02:03:04.987Z

                The suggestion to try one of the USB hub connections worked, the mouse and keyboard are both working, thanks. However, the hotkeys are not (but the manual switch on the AIMOS does.)

                The compatibility list on the Wiki indicates that they should, is there some workaround required?

                I tried my physical/remote keyboard and the virtual one on the TinyPilot GUI. The keypresses are shown at the bottom right of the TinyPilot window but they don't appear to be passed to the AIMOS. Hotkey switching does work for a keyboard connected directly to the AIMOS.

                1. DDiego @diego2022-06-20 23:26:10.187Z

                  Hi David! Can you confirm no virtual drives are mounted (under System > Virtual Media)? Other users have found this to be the reason of hotkeys not working.

                  1. DDavid Bridges @DAB42
                      2022-06-21 03:05:07.059Z

                      I can confirm that no virtual drives are/were mounted. "Manage Virtual Media" reports "There are currently no disk images available for mounting."

            2. Progress
              with handling this problem
            3. D
              David Bridges @DAB42
                2022-06-21 03:09:55.005Z

                In case you need this info:

                Software versions
                TinyPilot version: 2.4.1 3893245
                uStreamer version: v4.13 61ab2a8
                OS version: Linux tinypilot 5.10.63-v7l+ #1496 SMP Wed Dec 1 15:58:56 GMT 2021 armv7l GNU/Linux

                1. D
                  Diego @diego2022-06-21 19:46:48.069Zreplies toDAB42:

                  Hi David,

                  So in our tests, the AIMOS KVM worked perfectly, including hotkeys. That's why this device is in the KVM compatibility list.

                  • Do you get the same behavior on both USB hub ports?
                  • Are you able to use hotkey switching successfully if you plug a real keyboard into the USB hub port?
                  • Are you using the cables that you purchased from TinyPilot?
                  1. D
                    David Bridges @DAB42
                      2022-06-22 08:06:22.759Zreplies todiego:

                      Hi,

                      I tried both USB hub ports, same issue.

                      If I plug a real keyboard into either of the USB hub ports hotkey switching doesn't work. If I plug a real keyboard into the keyboard or mouse USB ports, hotkey switching works correctly.

                      I am using the cables that were supplied with the TinyPilot.

                      1. D
                        Diego @diego2022-06-22 18:29:24.204Zreplies toDAB42:

                        Hey David,

                        The guys at DBTech made a review of TinyPilot + splitter + AIMOS KVM about a year ago, and hotkeys worked for them. Check this video for details (NOTE: he is using a Voyager 1, but that shouldn't be a problem, just ignore that part -- you can see how he is plugging the TinyPilot USB DATA cable into the keyboard port of the AIMOS KVM).

                        Considering the following:

                        • Hotkeys do not work if you plug a real keyboard into any of the hub ports in the AIMOS KVM.
                        • Hotkeys work if you connect a real keyboard to the keyboard port in the AIMOS KVM.
                        • The video from DBTech shows they plugged the TinyPilot USB DATA cable into the keyboard port in the AIMOS KVM, and they show that the hotkeys do work.

                        I would say we should go ahead and try connecting the TinyPilot USB DATA cable to the keyboard port in the AIMOS KKVM, instead of a hub port. Can you try that for me, please?

                        1. D
                          David Bridges @DAB42
                            2022-06-22 21:09:18.554Zreplies todiego:

                            Hi, this is becoming a circular discussion.

                            The YouTube video you reference, "Expand Your TinyPilot to Support MULTIPLE Devices" (https://www.youtube.com/watch?v=wBMGGnwWmqI) is the one that inspired me to try connecting the TinyPilot to a KVM. In fact, I purchased the same AIMOS KVM as is used in the video because it was shown to work successfully - albeit using an older version of the TinyPilot. I followed the steps in that video and connected the data cable of the TinyPilot to the USB keyboard port on the AIMOS.

                            When I plug the TinyPilot USB data cable into the keyboard port of the AIMOS KVM, the keyboard works correctly, but the mouse does not. Any attempt to move the mouse results in the mouse pointer "jiggling" around in the bottom-right corner of the screen, but not moving from that corner. Left and right mouse clicks work but mouse movement does not.

                            Note that I've also tried different mice on my remote "administration" PC that is connected to the same network as the TinyPilot (both hard wired via Ethernet to the same switch), Bluetooth mice, and ones physically connected to the admin PC via USB. I got the same results, the mouse pointer couldn't be controlled. I've also tested different PCs running Windows 10 and Windows 11, and two different HDMI splitters, the first one being a similar model to the one used in the video.

                            If I plug the TinyPilot USB data cable into either of the USB hub ports on the AIMOS KVM, then the mouse and keyboard function correctly, but the hotkeys do not.

                            As previously stated, when I plug a real keyboard into the keyboard or mouse ports of the AIMOS KVM, it is able to hotkey switch between PCs connected to the AIMOS.

                            I'll be trying a potential workaround to this issue, by plugging a wireless "keyboard injector" device into the USB keyboard port of the AIMOS KVM, which should enable me to remotely switch the AIMOS via WiFi. This would fix the problem, but I'm still curious as to why the TinyPilot can't do this - power, interference, code...?

                            1. D
                              Diego @diego2022-06-27 20:25:35.444Z2022-06-28 21:46:11.364Zreplies toDAB42:

                              Hello David - I apologize for the late reply. I also apologize for pointing to the video you had already seen.

                              So I believe hotkey switching is never going to work on any of the USB hub ports. You tried connecting a real keyboard to those ports and hotkey switching didn't work. I don't see how it is going to work with the TinyPilot if it didn't work with a real keyboard. In fact, I think the only ports able to initiate hotkey switching are the USB keyboard and USB mouse ports.

                              If you want to give it a try, I looked for an older version of init-usb-gadget (the file TinyPilot uses with the settings to impersonate a keyboard and mouse). The DBTech guys published their video on May 4, 2021, so I looked for around that date. Let me know if this works for you. If it doesn't, I'm afraid I don't know what else to try.

                              The idea is to see if this old code (same as it was when it worked for the DBTech guys), works for you. You would need to connect the TinyPilot USB DATA cable into the AIMOS USB keyboard port, run the commands below, and see if the mouse is usable (and of course, if hotkey switching works).

                              PROCEDURE -> Just copy the below snippet into a terminal.

                              cd /opt/tinypilot-privileged/ && \
                                sudo mv init-usb-gadget init-usb-gadget.original  && \
                                sudo wget https://raw.githubusercontent.com/tiny-pilot/ansible-role-tinypilot/e5ca542946efa0e97a67e1380d323dc77a0b9452/files/init-usb-gadget && \
                                sudo chmod +x init-usb-gadget && \
                                sudo reboot
                              

                              FALLBACK -> If it doesn't work, please run the following snippet to revert the changes:

                              cd /opt/tinypilot-privileged/ && \
                                sudo mv init-usb-gadget.original init-usb-gadget && \
                                sudo chmod +x init-usb-gadget && \
                                sudo reboot
                              
                              1. D
                                David Bridges @DAB42
                                  2022-06-28 02:33:39.150Zreplies todiego:

                                  Applying these changes appears to have "bricked" my TinyPilot. I no longer have video output, even when connecting the TinyPilot directly to a single PC without using the AIMOS and HDMI splitter at all. I ran the fallback to reinstate the original init-usb-gadget but it didn't fix the problem.

                                  Looks like I will have to reinstall the OS. I am still able to access the TinyPilot via ssh. I've tried several restarts.

                                  1. D
                                    Diego @diego2022-06-28 21:45:25.180Z2022-06-28 23:02:24.605Zreplies toDAB42:

                                    Hi David - I'm very sorry, I missed one line in the snippets. I have updated the commands in my post above, for if you want to give it another go.

                                    Although I'm not sure why you lost video capture (since nothing in the snippets touch anything related to video), I believe you should be able to fix your TinyPilot by doing:

                                    cd /opt/tinypilot-privileged/ && \
                                    sudo chmod +x init-usb-gadget && \
                                    sudo reboot