No internet connection
  1. Home
  2. Technical Support

TinyPilot freezes after mounting virtual media

By @dugz
    2022-06-16 18:14:20.426Z2022-06-17 01:33:24.123Z

    Hi! I am having some trouble when mounting virtual media on Lenovo Thinkcentre M70q computers with the Voyager 2

    When I mount an ISO file (both in flash and CD-ROM modes), the video freezes, and it seems to me (but it is hard to confirm because of the lack of visual feedback) that the keyboard and mouse input also freezes.

    I have had this problem in the past with other computers when mounting in flash mode, and switching to CD-ROM mode used to work, but not this time.

    Going to System/Power/Restart unfreezes the video and the computer resumes accepting keyboard and mouse input, but by then the ISO file is unmounted, so I can't move forward.

    I can collect any logs or information necessary to help troubleshoot it. If anyone can help, just let me know.

    Thank you!

    • 4 replies
    1. D
      Diego @diego2022-06-16 20:46:34.691Z

      Hello @dugz - Thank you for reporting this issue!

      I'd like to confirm wether it is only the video that is freezing, or the entire unit. Can you try the following?

      • SSH in to your TinyPilot and keep the SSH terminal window open.
      • From the TinyPilot web interface, attempt to mount an ISO file and wait until it freezes.
      • At this point, go back to the SSH terminal window, and collect logs from there: sudo /opt/tinypilot-privileged/collect-debug-logs copy the URL it will give you and paste it in your response.

      If the SSH terminal window is not responding, please collect logs this way:

      • Proceed to restart the TinyPilot (TinyPilot web interface > System > Power > Restart).
      • Collect logs from the web interface as soon as possible (TinyPilot web interface > System > Logs > Get Shareable URL). Copy the URL it will give you and paste it in your response.

      I have a couple questions, if you don't mind:

      • What OS are you running in the target computer? (the Lenovo Thinkcentre M70q).
      • How big is the ISO file you are trying to mount? Does this freezing situation happen with any ISO file you try to mount?
      1. D2@dugz
          2022-06-17 01:29:29.156Z

          Hi Diego!

          Here are the URLs:
          Ubuntu (1.2 Gb), flash mode: https://logs.tinypilotkvm.com/bALsNyH1
          TinyCore (21 Mb) CD-ROM mode: http://logs.tinypilotkvm.com/mRUaMuaI

          The SSH session was not affected after mounting the ISO files. I started the SSH session before mounting, mounted, and then on that same session was able to collect the logs.

          To answer your questions:
          _It came pre-loaded with Windows 11. I have not even gone throught the initial Windows setup process (Windows OOBE), though. The freeze occurs even if the computer has not reached the OS. For instance, if I try to mount the ISO while on the BIOS screen, it also happens.
          _It's Ubuntu 20.04.4 Live Server, about 1.2 Gb. I tried another ISO (from http://tinycorelinux.net/downloads.html), same results.

          Thanks again for your help!

          1. D2@dugz
              2022-06-17 02:32:33.743Z2022-06-17 03:58:19.926Z

              Hello again Diego.

              Your question about the OS got me thinking, and I decided to go through with finishing Windows's setup, and after I got to the desktop, I tried mounting the ISO. It actually did not freeze then, and after that, I was able to reboot the computer without restarting TinyPilot, and the ISO remained mounted. After that, I could see it as a boot option and managed to get Ubuntu installed.

              So I worked around the problem your with help and insight, and luckily could move forward with my work.

              Though, if this computer did not have an OS pre-installed, I would not be able to work around it and would have to get physical access to it, so I still think this issue is worth investigating,

              1. DDiego @diego2022-06-17 21:02:27.159Z

                Hi @dugz - Thank you for the update. I'm glad you were able to resolve your issue!