No internet connection
  1. Home
  2. General

TinyPilot for Laptops?

By Eric @ersmith.wsu2021-03-22 17:18:06.365Z

I stumbled upon the TinyPilot build while scouring the internet for potential laptop/kvm solutions for my remote support scenarios.

Previously I have used a Lantronix Spider for similar applications with desktops and servers. My biggest challenge is with laptops and the inability to view the boot/bios level operations without walking someone on the far end through the process of changing the display settings in the bios to output via HDMI/DP. Laptops will not present boot/bios video over HDMI or DP otherwise.

So my question is, do you know of a way to solve this problem? Or can your device do so? I have a feeling that TinyPilot (or any other for that matter) would require the same interaction with the end user first.

Either way, I think I will pick up one or two of these devices. Just wanted to see if you have any thoughts on this challenge.

Solved in post #2, click to view
  • 3 replies
  1. Michael Lynch @michael2021-03-23 20:58:49.051Z

    Thanks for reaching out!

    Unfortunately, TinyPilot doesn't have any special way of forcing the laptops to display pre-boot interfaces on an external port.

    In my experience, it varies by laptop. Some of my laptops mirror the screen to an HDMI/DisplayPort output when one is attached while others refuse without pre-configuring the BIOS. On my BitLocker enabled Surface laptops, I haven't found a way of getting a display on an external monitor during a BitLocker pre-boot prompt.

    ReplySolution
    1. EEric @ersmith.wsu2021-03-29 22:39:58.741Z

      Thanks for the reply. Just received the TinyPilot and have began testing. I was able to ssh into the device and reset the password, but it appears the web server isn't running. I am unable to navigate to https://tinypilot/ nor can I reach it by the dhcp leased IP it has acquired. Any tips for troubleshooting that piece?

      1. Michael Lynch @michael2021-03-30 22:11:54.196Z

        It takes three to five minutes for the web server to spin up on first boot (it's securely generating unique TLS keys for your device). Is it possible you caught it in the still-setting-up window?

        If it's still not serving, can you run this command from your TinyPilot and post the shareable URL it prints at the end?

        /opt/tinypilot/dev-scripts/dump-logs