No internet connection
  1. Home
  2. Technical Support

Not sure why keyboard still doesn't work for me

By @rcdc2021-03-23 09:54:14.742Z2021-03-23 13:33:13.292Z

I ran the update to the latest version as of a few minutes ago but still get nothing at all either via the soft keyboard or from my hardware keys forwarding. Likewise no cursor movement.

Any common gotchas for me to check? Since it doesn't appear to the bad update now...

Raspian full OS, using my own capture card, lot of video latency and freezes but I'll worry about those later and presume they're unrelated. I did also do the changes advised in the "10 second latency raspbian full OS" thread down to like 720p resolution and 10fps etc etc but they didn't seem to make a real difference.
The funny thing is, if I explicitly refresh the browser window viewing the Tinypilot stream, I can skip all the latency and it displays the latest video within just a second or two, but then after that it's back to 10sec latency etc

Some logs here across multiple unplug cycles etc

https://logs.tinypilotkvm.com/hrW2m5jA

  • 3 replies
  1. Michael Lynch @michael2021-03-23 22:28:00.399Z

    Thanks for reporting this!

    What parts are you using to connect the Pi to the target computer?

    1. R@rcdc2021-03-24 08:34:32.278Z

      About 3 or 4 different USB-C -> USB-A male cables tried now. Apologies, I don't have the names etc. Some of them definitely would be cables that normally seem to work for my other more 'picky' USB-C devices data connections and the quick charge current, etc
      Tried some USB-C to USB-C cables also, the one that did send power to the RP4 still didn't get me any key/mouse forwarding unfortunately

      the Capture card:
      https://www.amazon.co.uk/gp/product/B07V3L95W7/ref=ppx_yo_dt_b_asin_title_o08_s00?ie=UTF8&psc=1
      I just realised that maybe the capture card is actually too 'good' and sending a high data rate compared to other cards could be the reason for such huge latency. I have a cheaper usb HDMI capture stick arriving in the post today though and I'll try it

      I've tested this card sending HDMI from one laptop to another (into OBS) and got latency under 1 second so I guess something is causing the extra latency here too, which actually seems like almost 30 seconds a lot of the time, when the signal updates at all. It's really strange

      If any more logs help just let me know
      Thanks a mill

      1. Michael Lynch @michael2021-03-24 20:21:06.805Z

        Hmm, I suspected bad USB-C cable, but it'd be surprising if all four were bad, especially if they support quick-charge. Can you try SSHing in and running this command?

        # Should type "Hi" on the remote screen
        echo -ne "\x20\0\xb\0\0\0\0\0" > /dev/hidg0 && \
          echo -ne "\0\0\xc\0\0\0\0\0" > /dev/hidg0 && \
          echo -ne "\0\0\0\0\0\0\0\0" > /dev/hidg0
        

        If it doesn't work, can you share logs again after running the command?