No internet connection
  1. Home
  2. Technical Support

Keyboard Mouyse not working, HDMI ok, tested on 2 computers, changed USB cables,

By @drkrk9
    2022-08-04 16:55:45.210Z

    Just like the title says, I can't get any keystrokes or mouse pointer changes to work. I tried on a computer that was working just fine with TinyPilot (windows 10); restarted computer and raspberry pi many times, changed all usb cables and secured connections and nothing improved... connected to different computer (linux that worked with tinypilot in the past)... nothing.
    What could it be?

    • 3 replies
    1. D
        2022-08-04 17:31:07.263Z

        So, I found that the /var/log directory was 13Gb... I deleted the logs, restarted and now it is working. Why would that be?

        1. Diego @diego
            2022-08-04 22:27:41.531Z

            Hi @drkrk9 - I'm sorry you had this issue. I'm glad you found out how to recover. I'm not sure why the /var/log directory was full, it could be many things.

            • Do you, by chance, remember which files had to be deleted?

            • Would it be possible for you to upload logs for me to review? This is how you would upload them: TinyPilot web interface > System > Logs > Get Shareable URL (copy the URL it will give you and paste it in your response).

            • Can you check if there is any file/s growing up now, after you cleaned the directory? If you could share the last few lines of any file that is growing abnormally, that would be great.

            1. D@drkrk9
                2022-08-05 00:54:41.126Z

                Thank you for the reply. I have an SD Card image backup that has the files, I will dig them out and share what I can with you.

                As for my problem, a revision... never just delete the log files :D that gave me a BAD GATEWAY web error when trying to connect to the tinypilot after a subsequent restart/shutdown. I restored the SD card image back and Instead I deleted the *log.1 files that were 4Gb each (there were 2 files like this), I couldn't delete the messages file that is also 4Gb but the other 2 gave me enough space.