No internet connection
  1. Home
  2. Technical Support

CS2 Resolution - No Signal

By @KimberlyP
    2022-09-02 00:30:31.968Z

    I've come from over 30 years in the DOS and Windows world, and a newbie to Raspberry pi/Linux/Unix(and variants). I built the TinyPilot KVM with the Pi 4 and GeekWorm CS2 camera module to manage my security camera DVR. I tested it with my laptop, and it works fine at 1366x768. However, my DVR reports 'No Signal'. Its HDMI output is 1280 x 1024 @ 60Hz. I've tried running commands to set an EDID file, but I get the message, "VIDIOC_S_EDID: failed: Inappropriate ioctl for device".

    Is there any simple way to set the default input resolution without dealing with binary or text files? In newbie-speak please.


    Solved in post #9, click to view
    • 9 replies
    1. David @david2022-09-05 14:07:28.286Z

      Hi @KimberlyP, sorry to hear you're having this issue. Let's see if I can help you get your TinyPilot working with your DVR.

      Firstly, to answer your question, there isn't a simple way to set a default resolution. TinyPilot's HDMI input supports a range of resolutions, so there's often no need to modify any files.

      It looks like you've built your TinyPilot yourself, so before I try and diagnose anything I'd like to make sure I've got the correct info:

      Can you confirm which OS your TinyPilot is running?

      And would it be possible for you to upload your TinyPilot logs for me to review? Ideally with the DVR connected so I can see if there are any specific errors. It's a simple process - on the TinyPilot web interface navigate to System > Logs and then click Get Shareable URL. This will give you a link that you can simply paste in your response.

      1. K
        In reply toKimberlyP:
          2022-09-06 23:15:05.891Z

          Hi David,

          Thank you so much for taking the time to help me resolve this issue. Here's what I've got:

          Debian Linux pikvm 5.15.61-v7l+ #1579 SMP Fri Aug 26 11:13:03 BST 2022 armv7l

          I was sifting through the PiKVM logs over the weekend without any trouble to see if I could figure it out. However, today when I select System/Logs TinyPilot browser session keeps disconnecting about 12-13 seconds after I select System/Logs. It wasn't doing that before. Also, when testing with my laptop again today, it no longer works there. I connected a monitor to the pi, and the Linux desktop appears to be functioning just fine.

          1. In reply toKimberlyP:
            David @david2022-09-07 15:07:29.031Z

            Thanks for sharing your OS info. Did you build a TinyPilot or a PiKVM? Your OS listing contains PiKVM, and you've mentioned looking through PiKVM logs which is a little confusing.

            It looks like the installed OS you're using isn't supported by TinyPilot - the kernel version is listed as 5.15 and TinyPilot currently only supports 5.10 which Raspberry Pi calls Raspberry Pi OS (Legacy).

            On build your own TinyPilot devices the recommended OS is Raspberry Pi OS Lite (legacy). Can you re-flash your device and re-install the TinyPilot software by following those two sections of the guide?

            I think a clean install will help with your issue with grabbing the TinyPilot logs and connecting with your laptop. Then we can focus on your DVR.

            1. In reply todavid:
                2022-09-08 02:35:05.030Z2022-09-09 14:14:14.477Z

                Hi David,

                I built my Tiny Pilot with the Pi-4 and the GeekWorm CS-2 camera module. I've done as you suggested and flashed the SD to the legacy Debian Linux version 5.1. Everything works fine again (including logs) with the laptop, but still have 'no signal' with the DVR. I've pulled the logs after starting up with the DVR connected. The logs show TP trying a resolution of 1920x1080, but the DVR is only capable of 1280x1024.

                Debian GNU/Linux pi 5.10.103-v7l+ #1529 SMP Tue Mar 8 12:24:00 GMT 2022 armv7l


                Thanks again,


                1. David @david2022-09-09 14:30:15.077Z

                  Ok, great!

                  After looking through your logs, it seems like TinyPilot's video streaming service is trying to initialize using the default HDMI to USB capture device settings instead of settings for HDMI to CSI.

                  Can you run this line:

                  echo 'ustreamer_capture_device: tc358743' | sudo tee --append /home/tinypilot/settings.yml

                  And then re-run the install script:

                  curl \
                    --silent \
                    --show-error \
           | \
                      bash - && \
                    sudo reboot

                  That should allow TinyPilot's video streaming service to initialize correctly.

                  If connecting to your DVR still doesn't work, I'll need to look at the new logs to dig deeper into the issue.

                  1. K@KimberlyP
                      2022-09-09 15:58:43.595Z

                      Hi David,

                      I ran the command and script, but now the video window is gone, leaving just a virtual keyboard.




                      1. David @david2022-09-09 20:52:46.061Z

                        Sorry about that, that's entirely my fault - I made a mistake on the first command. It should be:

                        echo 'ustreamer_capture_device: tc358743' | sudo tee /home/tinypilot/settings.yml

                        Can you run the corrected command, and then the install script again?

                        curl \
                          --silent \
                          --show-error \
                 | \
                            bash - && \
                          sudo reboot

                        Your new logs show that your TinyPilot can see your DVR's output settings, so I think we're getting closer to the solution.

                        1. K@KimberlyP
                            2022-09-10 00:11:41.429Z


                            You're awesome! Not only does it now work with Firefox, where it only worked with Chrome before, I now have the DVR desktop!

                            Thank you so much!


                            1. David @david2022-09-12 12:45:14.179Z

                              Hi Kimberly - Fantastic, thanks for the update! I'm glad I was able to help fix that for you.