No internet connection
  1. Home
  2. Technical Support

TinyPilot connected to network but cannot reach the user interface

By @astigmatism
    2022-09-15 00:07:41.377Z2022-09-15 02:37:30.610Z


    I can no longer reach the tinypilot user interface in my browser despite the device appearing to be normal. My home network configuration tool shows "tinypilot" as a DHCP client with a local address. I can ping that address and receive a response. Despite this, I can no longer reach the user interface with the url "https://tinypilot/" which I had been using successfully for several weeks prior. I have tried different browsers and machines but this address does not resolve on any of them (nor do "https://tinypilot.local/" or "https://tinypilot.localdomain/" or just its ip address ""). This issue just happened one day after powering up, no updates or other software/firmware changes were applied beforehand.

    Is there an additional method to reach the tinypilot? If only to restore the device? Thanks :)

    • 3 replies
    1. Diego @diego
        2022-09-15 05:18:19.448Z

        Hello @astigmatism! I'm sorry you are having this issue. Thank you for posting your questions here in our Forum.

        • You mentioned you are able to see an entry in your router for the TinyPilot, and that it shows an IP address assigned to it via DHCP. Would that IP address be I am not sure I understood if you have tried to connect to that IP address, using your browser: - Have you? If you are absolutely sure this is the IP address the TinyPilot has, and you are unable to connect, then this would mean some services are not yet loaded/started (nginx for example). That would happen if the device is not booting correctly, most likely due to corrupt microSD card.

        • Have you tried to do SSH to that IP address? If you had SSH enabled, you might be able to connect to it. If you happen to be able to connect, please run the following command to collect logs (copy the URL it will give you and paste it in your response):
          sudo /opt/tinypilot-privileged/collect-debug-logs

        1. A
          In reply toastigmatism:
            2022-09-16 03:45:32.021Z

            Hello Diego. Thank you for your quick response.

            1. Yes, I attempted a connection with the local IP address to no avail.
            2. Sadly, I did not ever enable SSH connection support

            Alternatively, I found that as a customer with an Order ID, I can download the Tiny Pilot Pro software image and flash it to an SD card. I'll try this on a separate card to see if this restores the device.

            1. Diego @diego
                2022-09-16 18:02:06.175Z

                Hello @astigmatism - OK, if SSH is not enabled then I am afraid you are locked out and the next step is, unfortunately, to proceed with a Factory Reset. Let me know how it goes or if you need any further assistance. I'll be happy to assist :)