No internet connection
  1. Home
  2. Technical Support

New TinyPilot Voyager 2 Video distorted

By Thad @thadehresman
    2022-09-20 15:03:59.850Z

    Using the VGA to HDMI adapter, I'm getting terrible picture on a Dell PowerEdge R240 server (we have 4 of these servers and they all do the same thing). The screenshot below is of the Ubuntu Server install screen using the ISO image uploaded to the TinyPilot. Is there something I'm missing I'm needing to do?

    • 17 replies

    There are 17 replies. Estimated reading time: 16 minutes

    1. K
        2022-09-20 16:16:00.919Z

        Hey - we're in the same boat; I'm currently dealing with this issue.

        I initially resolved it with some kernel parameters (later added to /etc/default/grub; update-grub) - something like vga=normal nofb and something else I think; maybe also edit the /etc/init.d/whatever script that sets up the console... but several of our servers just can't be rebooted for things like this.

        In theory this can all be resolved by customizing the VGA adapter's EDID (your image looks like too high refresh or dotclock). My situation is a little more complicated because I am connected to an Iogear VGA KVM switch and I didn't like how the tinyPilot window glitched around when the host changed resolutions and when switching machines. So I bought this VGA to HDMI scaler so the tinyPilot can always receive at 1280x720p60 instead.

        Now I'm having the opposite issue - all the high resolutions scale down and look great (and switch modes instantly), but I think this scaler is advertising 640x480 refresh rates which are too high for the tinyPilot because now I can't see the low resolution boot screens... HAHAHA! I'm pretty sure it's an EDID thing and I've ordered some EDID emulators to test; my hope is to just re-write the one built in the TrippLite scaler and be done with it... Hopefully all this sparks some ideas.

        1. Diego @diego
            2022-09-22 10:42:54.622Z

            Hello @thadehresman and @khmann - Thank you both for reporting your issues here in our Forum.

            • Would it be possible for you to upload logs for me to review? This is how you would upload them: TinyPilot web interface > System > Logs > Get Shareable URL (copy the URL it will give you and paste it in your response).

            • Have you tried with a different, high quality HDMI cable? Most of the display issues get resolved by using a good compatible cable. We use and recommend Cable Matters, as we rarely have issues with that brand.

            1. K@khmann
                2022-09-22 14:45:17.888Z2022-09-26 13:29:23.472Z

                I went ahead and got a "Shareable URL", but I don't think it will be very useful because I'm not at the datacenter and I only have the above mentioned scaler connected.

                I did however uncompress all the daemon.log.* and sort out all the DV timings I've ever encountered by number of occurrence. Unfortunately I can't say which were the Ubuntu, but I know they happened quite a few times so they should be pretty far down the list. I'm suspicious of that 1600x1200p60@162MHz... If we don't hear back from Thad above, I can collect the logs when using your adapter but it will be next week before I can go there to switch things around.

                EDIT: I have what you need, the daemon.log file from back when we were using your adapter and having these problems. Don't really want to paste all 26k lines here...

                  2  -- Got new DV-timings: 1152x864p60.00, pixclk=108000000, vsync=261, hsync=448
                  2  -- Got new DV-timings: 959x1080p60.00, pixclk=37092000, vsync=4294966778, hsync=141
                  3  -- Got new DV-timings: 1920x1080p60.00, pixclk=74184000, vsync=4294966778, hsync=280
                  3  -- Got new DV-timings: 682x768p60.00, pixclk=43330560, vsync=38, hsync=214
                  3  -- Got new DV-timings: 800x600p61.00, pixclk=40453248, vsync=28, hsync=256
                  4  -- Got new DV-timings: 1024x768p60.00, pixclk=32497920, vsync=4294966931, hsync=320
                  7  -- Got new DV-timings: 800x600p60.00, pixclk=39790080, vsync=28, hsync=256
                 10  -- Got new DV-timings: 640x480p60.00, pixclk=25200000, vsync=45, hsync=160
                 29  -- Got new DV-timings: 799x1200p60.00, pixclk=81000000, vsync=50, hsync=281
                 35  -- Got new DV-timings: 800x1200p60.00, pixclk=81000000, vsync=50, hsync=280
                 43  -- Got new DV-timings: 1066x1200p60.00, pixclk=108000000, vsync=50, hsync=374
                 43  -- Got new DV-timings: 1280x1080p60.00, pixclk=98955000, vsync=45, hsync=186
                 50  -- Got new DV-timings: 1279x1200p60.00, pixclk=129600000, vsync=50, hsync=449
                 59  -- Got new DV-timings: 1280x1200p60.00, pixclk=129600000, vsync=50, hsync=448
                 59  -- Got new DV-timings: 1600x1200p60.00, pixclk=162000000, vsync=50, hsync=560
                 84  -- Got new DV-timings: 1280x1080p60.00, pixclk=99022500, vsync=45, hsync=187
                 89  -- Got new DV-timings: 959x1080p60.00, pixclk=74250000, vsync=45, hsync=141
                105  -- Got new DV-timings: 1024x768p60.00, pixclk=64995840, vsync=38, hsync=320
                117  -- Got new DV-timings: 960x1080p60.00, pixclk=74250000, vsync=45, hsync=140
                126  -- Got new DV-timings: 1024x1080p60.00, pixclk=98955000, vsync=45, hsync=442
                148  -- Got new DV-timings: 1535x1080p60.00, pixclk=118800000, vsync=45, hsync=225
                161  -- Got new DV-timings: 1280x720p60.00, pixclk=74250000, vsync=30, hsync=370
                168  -- Got new DV-timings: 1279x1080p60.00, pixclk=98955000, vsync=45, hsync=187
                183  -- Got new DV-timings: 1536x1080p60.00, pixclk=118800000, vsync=45, hsync=224
                241  -- Got new DV-timings: 1535x1080p60.00, pixclk=98955000, vsync=45, hsync=4294967227
                248  -- Got new DV-timings: 1535x1080p60.00, pixclk=99022500, vsync=45, hsync=4294967228
                304  -- Got new DV-timings: 640x480p75.00, pixclk=31500000, vsync=20, hsync=200
                383  -- Got new DV-timings: 1024x1080p60.00, pixclk=99022500, vsync=45, hsync=443
                412  -- Got new DV-timings: 640x416p70.00, pixclk=25144000, vsync=33, hsync=160
                509  -- Got new DV-timings: 1279x1080p60.00, pixclk=99022500, vsync=45, hsync=188
                7121 -- Got new DV-timings: 1920x1080p60.00, pixclk=148500000, vsync=45, hsync=280
                1. In reply todiego:
                  TThad @thadehresman
                    2022-09-23 19:00:10.802Z


                    Yes, we have tried other HDMI cables. Not specifically Cable Matters, but AmazonBasics and I even brought one that came with an Xbox Series X from home to try. Same problem.

                    In weird news; Rocky Linux/CentOS work fine. It's only Ubuntu server....

                    1. David @david2022-09-27 19:56:57.329Z

                      Thanks for those logs. It looks like the DV-timings that are being sent from the target machine aren't supported with by default EDID on TinyPilot.

                      Could you try editing the EDID with the command in Michael's post?

                2. K
                  In reply tothadehresman:
                    2022-09-29 22:49:04.521Z

                    Finally had a chance... unplugged everything, connected official tinyPilot converter, powered up the tinyPilot.
                    Then I fired up the Ubuntu machine. SuperMicro bios went and did all it's stuff, then eventually the screen went all scrambled. I switched back and forth a little bit, the Ubuntu machines consistently glitch out or say no video. I uploaded my log

                    1. David @david2022-09-30 11:29:05.932Z

                      Thanks for the detail and the screenshot. Was this using the alternate EDID from Michael's post or unchanged from default?

                    2. A
                      In reply tothadehresman:
                        2022-10-18 17:02:47.361Z

                        Hey Guys. I have exactly the same problem on our Supermicro machines. Tried both Ubuntu 20.04 LTS and AlmaLinux 8.5 minimal ISOs.

                        I cannot upload the screenshot (you have 1 MB limit for pictures), but it actually the same as @khmann posted.

                        The firmware version is the latest - 2.5.0

                        I tried with both Flash devices and CDROM mount options. We use an official HDMI-VGA adapter shipped from

                        Any help is appreciated.

                        1. Progress
                          with handling this problem
                        2. A
                            2022-10-18 17:26:25.321Z

                            Changing EDID as mentioned per NO SIGNAL but keyboard and mouse are working #post-16 make no difference, even it caused more glitches in video (restart help, but in this case ISO is unmounted) and even kernel panic

                            Screenshots available at

                            1. David @david2022-10-19 11:10:04.727Zreplies toarthurl:

                              Hi @arthurl, sorry that you're also running into this issue.

                              Thanks for trying it with the alternate EDID and posting those images. Could you share your logs so I can take a look at what resolution and framerate your target machine is requesting?

                              On the TinyPilot web interface, navigate to System > Logs and then click Get Shareable URL. Then you can share the generated URL in your response.

                              1. A
                                  2022-10-19 11:59:48.879Zreplies todavid:

                                  @david I've booted the server to the normal OS - CloudLinux (fork of CentOS 7), so the following log is available -

                                  In addition, sometimes keyboard stopped working, so the only workaround is to restart TiniPilot (but in case ISO is mounted, everything is crashed)

                                  I was able to record another log when keyboard failed -


                                  1. A
                                      2022-10-19 12:02:25.854Zreplies todavid:

                                      One more thing, I've uploaded new screenshot (10-19-2022 0001)

                                      Here you can see what happens when keyboard stopped working.

                                      1. David @david2022-10-19 12:21:58.257Zreplies toarthurl:

                                        Thanks for sharing that log. It looks like CloudLinux displays correctly with the alternate EDID, is that correct?

                                        Would you like me to look into the image issue on Ubuntu 20.04 or the keyboard issue first?

                                        1. A
                                            2022-10-19 12:51:49.686Zreplies todavid:

                                            @david If it's possible, please check keyboard issue.

                                            Right now, I'm using original EDID, because Michael's alternative caused video glitching.

                                            Meanwhile, I will test Ubuntu and AlmaLinux installation ISOs and provide you with the logs.

                                            1. David @david2022-10-19 18:05:57.573Zreplies toarthurl:

                                              No problem!

                                              You mentioned that sometimes the keyboard stops working. Is the keyboard issue intermittent, or does it cut out after performing a specific action?

                                              Are you using the USB cable that came with your TinyPilot? Could you try testing the USB cable with a different device, or a different USB cable with you TinyPilot to see if there's an issue with the cable?

                                              1. A
                                                  2022-10-20 11:31:34.288Zreplies todavid:

                                                  @david actually the following steps made:

                                                  1. Login to TiniPylot >> See No Signal >> Trying keyboard >> Getting Keystroke failed
                                                  2. Reboot TinyPilot >> See CloudLinux login screen and a lot of errors related to USB >> Keyboard doesn't work
                                                  3. Reboot one more time >> Finally get keyboard working
                                                  4. It's unstable, the logs available in the latest screenshot -

                                                  So it looks like the connection isn't stable. Do you have any suggestions? Are you able to test it from your side?

                                                  1. David @david2022-10-20 15:16:57.966Zreplies toarthurl:

                                                    Do you have any suggestions? Are you able to test it from your side?

                                                    Am I right in saying that you're using only the keyboard and you're not using a mouse?

                                                    Can you test the USB cable with a different device or use a different cable between your TinyPilot and the target computer to see whether it helps the connection issue?