No internet connection
  1. Home
  2. Technical Support

Not able to connect to TinyPilot Voyager 2 over WiFi

By @pilot
    2022-10-07 01:58:48.222Z2022-10-07 02:06:07.656Z

    I am having trouble connecting to my TinyPilot Voyager 2 over WiFi. It was loading just fine through Chrome until I turned on Windows Defender in Windows 11 after uninstalling another antivirus software. There are no issues connecting when my computer is directly plugged into the router using an ethernet cable. I am not the most technical person, so would appreciate any help resolving this issue.

    Solved in post #8, click to view
    • 8 replies
    1. David @david2022-10-07 12:41:01.817Z

      Hi @pilot, I'm sorry that you're running into connection issues over WiFi.

      Do you have access to another browser (other than Chrome) like Edge or Firefox that you could try and use to connect? Could you also try to connect using the other URLs: https://tinypilot/, https://tinypilot.local/, or https://tinypilot.localdomain/?

      1. P@pilot
          2022-10-07 20:32:07.263Z

          Thanks, I am able to access it now through Chrome too now after trying Firefox and MS Edge where it loaded just fine. Any idea why it was failing when trying to access through Chrome?

          Also, I have another issue now. I have updated TinyPilot to the latest 2.5.0 release twice and both times at the end it gave the "update successful" message. But when I go to system > update, it again shows that my version is still 2.4.1 and gives the option to update to 2.5.0. Is there something I am supposed to do after running an update? I already restarted the device both times to see if that helps, but it did not.

          1. In reply todavid:
              2022-10-09 04:02:26.389Z

              Sorry, the not being able to connect over Wifi issue started up again. Tried Chrome, Edge, and Firefox. Please advise how it can be resolved. And still having the version update issue too. Updated successfully a couple more times, but it's still showing the current version as 2.4.1 with the option to update to 2.5.0.

              1. David @david2022-10-10 11:08:21.482Z

                Have you noticed if there is anything that 'triggers' the connection issue over WiFi? For instance, does it only happen immediately after you disconnect from ethernet?

                Could you try closing your TinyPilot browser tab, rebooting your TinyPilot, and then try connecting again?

                I've tried re-producing your issue by disconnecting my ethernet and switching to WiFi, but I haven't run into that connection issue, so I can't tell exactly why you're running into that.

                For your update issue, are you able to share your logs for me to look at? On the TinyPilot web interface, navigate to System > Logs and then click Get Shareable URL. This will generate a link to your logs that you can share in your reply.

                1. P@pilot
                    2023-02-19 04:35:44.541Z

                    Apologies for the super delayed response. Fired up my Voyager 2 today after a long time and it is still having the same issues.

                    1. Not able to update TinyPilot. Tried updating it twice just now and it says update complete at the end, but it remains stuck on 2.4.1. Here is the system log link:

                    2. There is nothing in particular that triggers the WiFi connection issue. Have rebooted multiple times, tried different browsers, different URLs etc. Will try setting up WiFi again using SSH. Can I get more detailed instructions on where the country, wifi ssid and passphrase need to be set once I have SSH'd in? How do I run the below commands? Do I just type them into the terminal at the pilot@tinypilot prompt? And replace the "${WIFI_COUNTRY}" with "${US}" etc.? Can WiFi be set up through the raspi-config interface instead?

                    sudo raspi-config nonint do_wifi_country "${WIFI_COUNTRY}" &&
                    sudo raspi-config nonint do_wifi_ssid_passphrase "${WIFI_SSID}" "${WIFI_PASSPHRASE}" &&
                    sudo reboot

                    1. David @david2023-02-20 13:01:37.464Z

                      No trouble at all, @pilot!

                      Firstly, for the update issue, it sounds like you may have enabled the read-only filesystem, but that seems unlikely if you haven't used the command line before. One option is to SSH in to your device and then run the command to turn-off the read-only filesystem to see if that fixes the update issue. However, I think the best option here would be to re-flash your SD card with the latest release since it includes an upgrade to the base operating system too.

                      Are you able to re-flash your SD card with the latest TinyPilot software? A potential issue here is that you need to manually enable SSH after a fresh install - and you need to access the TinyPilot web interface to enable it. Does this work for you (i.e. can you still access the web interface using ethernet)?

                      1. P@pilot
                          2023-04-02 05:28:55.128Z

                          I got someone to help with SSH and disabled the read-only filesystem. After doing this I was able to update to the latest version. And with the updates the WiFi connectivity issue seems to have resolved itself as well.

                          1. David @david2023-04-03 11:11:00.495Z

                            Thanks for the update @pilot! I'm glad you were able to update your software and resolve this issue.

                            Please feel free to reach out again if you have any other questions.