No internet connection
  1. Home
  2. Technical Support

Update failed 2.4.1 -> 2.5.0

By @chef7
    2022-10-18 01:46:39.150Z2022-10-21 02:14:18.478Z

    First off love the software veryyyy convenient!! Previous web-gui updates have worked without issue, until now. The logs show "ERROR Update process timed out" --- After multiple reboots, I am at a loss. Is there a bash script to run the update through a shell instead of the webGui?

    TASK [ansible-role-tinypilot-pro : create tinypilot group] *********************
    2022-10-17 20:14:46.079 main ERROR Update process timed out
    2022-10-17 20:14:46.085 update.result_store INFO Writing result file to /home/tinypilot/logs/latest-update-result.json

    Solved in post #4, click to view
    • 5 replies
    1. David @david2022-10-19 11:00:56.170Z

      Hi @chef7, firstly thanks for your kind words!

      I'm sorry that your update is failing. Are you able to share your full log file so I can look into why your update is timing out and to find a solution for you?

      On the TinyPilot web interface, navigate to System > Logs and then click Get Shareable URL. That will create a link for you to share here.

      1. Comment deleted
        1. David @david2022-10-20 19:21:04.357Z

          Thanks for sharing that log, @chef7! I can't see anything odd going on other than the timeout. So it might just be that our timeout on the update is slightly too short.

          If you're happy to update via the CLI you can run the following which will run through the update without a timeout:

          sudo /opt/tinypilot-privileged/update
          Reply1 LikeSolution
          1. C@chef7
              2022-10-21 02:13:08.892Z

              Thank you David, that resolved the issue!

              1. David @david2022-10-21 11:43:14.768Z

                You're welcome! I'm glad that solved the issue! Please feel free to reach out if you have any other issues or questions in the future.

              2. In reply todavid:
                  2022-10-21 02:18:26.961Z

                  I should preface this with that I am running TinyPilot as an addition to Raspberry PI OS. (bullseye)