No internet connection
  1. Home
  2. Technical Support

Can't update to 2.5.0

By Mustafa Arif @mustafa
    2022-10-24 14:57:49.677Z

    Here is the error message: 'The update failed: Command '['sudo', '/opt/tinypilot-privileged/update']' returned non-zero exit status 2.'

    Solved in post #7, click to view
    • 7 replies
    1. David @david2022-10-24 18:31:37.217Z

      Hi @mustafa, I'm sorry that you're running into this update issue.

      Are you able to share your device's logs with me so I can review them? On your TinyPilot's web interface, navigate to System > Logs and then click Get Shareable URL. That should give you a URL that you can paste in your reply.

      1. M
        In reply tomustafa:
        Mustafa Arif @mustafa
          2022-10-24 19:51:03.784Z
          1. M
            In reply tomustafa:
            Mustafa Arif @mustafa
              2022-10-25 00:29:03.460Z

              FYI I tried this command as well sudo su tinypilot bash -c "cd /opt/tinypilot && git checkout."

              1. M
                In reply tomustafa:
                Mustafa Arif @mustafa
                  2022-10-25 00:50:05.675Z

                  Looks like this is the error: TASK [ansible-role-ustreamer : get uStreamer repo] *****************************
                  fatal: [localhost]: FAILED! => {"changed": false, "cmd": ["/usr/bin/git", "fetch", "--tags", "origin"], "msg": "Failed to download remote objects and refs: error: Could not read 967574a78af4c5b13789a59039ff8fd71abcdd8c\nfatal: bad object 967574a78af4c5b13789a59039ff8fd71abcdd8c\nerror: did not send all necessary objects\n\n"}

                  what is the solution to fix this?

                  1. In reply tomustafa:
                    David @david2022-10-25 11:21:32.625Z

                    Thanks for the logs! Yeah, it looks like there's an issue with that git repository.

                    You can run the following command to remove the repository:

                    sudo rm -r /opt/ustreamer

                    After that, you can update through the web interface and it should be able to clone it correctly.

                  2. M
                    In reply tomustafa:
                    Mustafa Arif @mustafa
                      2022-10-26 14:16:49.749Z

                      Thanks!! it worked.

                      1. David @david2022-10-26 17:54:59.034Z

                        Fantastic! I'm glad that you're back up and running with the new update.

                        Please reach out again if you have any other questions or issues!