No internet connection
  1. Home
  2. Technical Support

Brand new TinyPilot, but keyboard/mouse doesn't work

By Adam @adam
    2022-10-30 02:56:52.718Z

    Just received my TinyPilot Voyager 2 kit, already running 2.5.0. Connected it to my Minisforum TH50 Mini PC, and neither the mouse nor keyboard was detected. I noticed the following entries in the log file...

    Oct 30 02:54:42 tinypilot python[615]: Process ProcessWithResult-255:
    Oct 30 02:54:42 tinypilot python[615]: Traceback (most recent call last):
    Oct 30 02:54:42 tinypilot python[615]: File "/usr/lib/python3.7/multiprocessing/", line 297, in _bootstrap
    Oct 30 02:54:42 tinypilot python[615]:
    Oct 30 02:54:42 tinypilot python[615]: File "/opt/tinypilot/app/hid/", line 45, in run
    Oct 30 02:54:42 tinypilot python[615]: result.return_value = self._target(*self._args, **self._kwargs)
    Oct 30 02:54:42 tinypilot python[615]: File "/opt/tinypilot/app/hid/", line 65, in _write_to_hid_interface_immediately
    Oct 30 02:54:42 tinypilot python[615]: hid_handle.write(bytearray(buffer))
    Oct 30 02:54:42 tinypilot python[615]: BrokenPipeError: [Errno 108] Cannot send after transport endpoint shutdown
    Oct 30 02:54:42 tinypilot python[615]: 2022-10-30 02:54:42.555 socket_api ERROR [SENSITIVE] Failed to forward mouse event: Failed to write to HID interface: /dev/hidg1. Is USB cable connected? [/SENSITIVE]

    Using the cable that came with the kit. Cable is good, because I used it to connect a USB-C keyboard to a USB-A port on the same computer.

    • 11 replies
    1. David @david2022-10-31 12:20:36.794Z

      Hi Adam, Sorry that you're running into this issue with the keyboard and mouse.

      Can you share the full log with me so I can review it? On your TinyPilot's web interface, navigate to System > Logs and then click Get Shareable URL. You can then paste that URL in your reply.

      1. A
        In reply toadam:
        Adam @adam
          2022-11-04 20:21:01.354Z
          1. David @david2022-11-07 12:04:54.461Z

            Thanks for sharing your logs! I can't see anything specific that would suggest what the cause of the issue is.

            Can you double-check that the cable is connected to the port labeled as 'data' on your TinyPilot, and could you try connecting the cable to different USB-A ports on the target machine?

            1. AAdam @adam
                2022-11-09 19:10:16.308Z

                I've tried different target machines, no luck. None of the target computers receive commands from the TinyPilot. Getting video just fine, just no keyboard/mouse input. As I also said, I tested using the USB-C/USB-A cable to connect a keyboard to the target computer and the cable works fine.

                1. David @david2022-11-10 13:13:57.633Z

                  Thanks for the update. It seems unlikely to be a hardware issue on the device itself (though I won't rule it out completely), so my next idea would be to re-flash the SD card to completely reset to factory settings.

                  Are you able to re-flash the SD card by following those instructions in our FAQ? I'm hoping that by doing that it will resolve any potential software or filesystem issues that might be causing the keyboard and mouse to not work.

                  1. AAdam @adam
                      2022-11-10 21:53:21.299Z

                      Reimaged, still not working. Here is a new log...

                      1. David @david2022-11-11 15:38:36.986Z

                        Thanks for testing that! It's possible that TinyPilot may not be compatible with the Minisforum TH50. From what I understand, it's a small form factor PC and it looks like it might have a custom motherboard. So there's a chance that there's some kind of compatibility issue there.

                        Do you have a different computer that you can connect your TinyPilot to to test whether the keyboard and mouse functionality works with it? That would help determine whether it's a compatibility issue or not.

                        1. AAdam @adam
                            2022-11-11 15:57:38.556Z

                            As mentioned earlier, I’ve tried multiple target computers. The mini PC was just the first. One is my main Windows desktop which uses a ASUS ROG Strix Z370-F

                            1. David @david2022-11-11 17:20:08.494Z

                              My apologies! I mis-read that comment about multiple target machines when I reviewed what we had already tried. Sorry about that.

                              Can you send us an email at so we can work out a resolution for you?

                              1. AAzmat @azmat
                                  2022-11-22 13:42:58.308Z

                                  I am also having the same issue. Please post the answer if/when available.

                                  1. David @david2022-11-22 14:22:09.380Z

                                    Hi @azmat, sorry that you're also running into this issue.

                                    Could you create a new thread with some additional details about your setup?

                                    • Are you using a purchased Voyager 2, or is this a build-your-own model?
                                    • Can you tell me what make / model your target machine is?