No internet connection
  1. Home
  2. General

Wifi setup

By @bu2d
    2021-04-18 15:50:38.748Z

    How do I setup the hobbyist kit to use wifi instead of ethernet? Ran out of room on my switch.

    • 5 replies
    1. First ssh in to your device and follow these steps:

      1. run sudo raspi-config
      2. Choose "1 System Options"
      3. Choose "S1 Wireless LAN"
      4. Enter your wireless SSID when prompted.
      5. Enter your wireless password when prompted.
      6. Select "5 Localisation Options"
      7. Select "L4 WLAN Country"
      8. Select your country from the list
      9. Select "Finish" to save the settings.
      10. When prompted to reboot, select "Yes"

      When you reboot, if you type ifconfig, you should see the wireless connection listed under wlan0.

      1. JJason @jasonnet
          2021-11-02 01:11:16.472Z

          I'm doing the initial set up of the TinyPilot with wifi instead of ethernet. These steps are not working for me. When complete ifconfig lists, eth0, lo, and wlan0. Interestingly, the wlan0 one does mention "ether"

          wlan0: flags=4099<UP,BROADCAST<MULTICAST>  mtu 1500
                  ether e4:5f:....9b  txqueuelen 1000 (Ethernet)
                  RX packets 0  bytes 0 (0.0B)
                  RX errors 0  dropped 0  overruns 0  frame 0
                  TX packets 0  bytes 0 (0.0 B)
                  TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
          

          I think the only caveat in what I've done is that I've not previously connected to ethernet because I don't have ethernet near any of the computers I'm testing. Instead I connected a monitor and keyboard to the R.Pi and was hoping to get started via wifi instead of ethernet.

          1. Thanks for reporting this!

            Interestingly, the wlan0 one does mention "ether"

            That's normal. The Pi's wlan0 section always includes that.

            I think the only caveat in what I've done is that I've not previously connected to ethernet because I don't have ethernet near any of the computers I'm testing. Instead I connected a monitor and keyboard to the R.Pi and was hoping to get started via wifi instead of ethernet.

            Is it possible that your WiFi SSID or password are incorrect? The behavior you're seeing matches what happens when you configure WiFi settings but the Pi fails to connect because the configuration is incorrect.

            1. JJason @jasonnet
                2021-11-03 20:31:41.199Z

                Thanks Michael.

                I did test to see if behavior would improve if the R.Pi was closer to the router and indeed that resolved the wi-fi problem

                Unfortunately my target equipment can't be there. I am now assuming that the R.Pi is not as capable as my other equipment at picking up a weak wifi signal and that my computers are simply in a zone where they can connect to the wi-fi but the R.Pi can not.

                Thanks again for your support.

                1. Oh, glad we figured out the problem.

                  You could also try purchasing a USB wifi adapter. You might have better reception using a WiFi adapter with an external antenna like this one or this one.