No internet connection
  1. Home
  2. Technical Support

Lost Mouse

By @imome9a
    2022-11-08 02:33:19.113Z

    Hello, I lost mouse functionality in one of my TinyPilot Voyager 2 PoE KVM's (I own 4 of the exact same model, I love'em). I try updating Windows thinking that may have been the culprit but after installing all optional updates and several reboots I tried testing the USB cable by swapping with one of my other TinyPilot Voyager 2 PoE KVM's USB cables that was known working. No luck. I then tried swapping the KVM itself and was back up and running with mouse support. I tried connecting the presumed faulty KVM with another machine and same result, no mouse. I suspect this to maybe be a hardware or software issue with the TinyPilot Voyager 2 PoE KVM. Any chance of getting this RMA'd? I have attached my invoice.

    • 25 replies

    There are 25 replies. Estimated reading time: 13 minutes

    1. I
        2022-11-08 02:34:51.860Z

        I didn't realize I couldn't attach a PDF. Let me know if you would like me to email my invoice.

        1. C
          In reply toimome9a:

          Hi imome9a - thank you for your kind words about the TinyPilot Voyager 2 and I'm sorry to hear that the mouse has stopped working on one of them.

          Could you please provide a link to the logs from your affected TinyPilot device (you can do this by going to System -> Logs -> Get Shareable URL)? Could you please also check if the keyboard still works via the same TinyPilot device?

          1. I
            In reply toimome9a:
              2022-11-08 03:49:24.765Z

              The keyboard hasn't had any problems on the affected TPilot, just the mouse.


              1. C
                In reply toimome9a:

                Thank you for sharing the logs. This is an unusual issue as normally we'd expect both the keyboard and mouse to be affected at the same time. It's not clear if this is a hardware or software fault but there may be an easy way to find out - can you please try swapping the microSD card from the affected TinyPilot device with the microSD card from your working TinyPilot device? To avoid the risk of data corruption please completely shut down and power off each TinyPilot device before removing the microSD card.

                1. I@imome9a
                    2022-11-09 15:30:41.406Z

                    will do, ill give that a go later this evening and report back

                    1. In reply tocghague:
                        2022-11-11 18:28:45.890Z

                        I guess we can lean towards hardware issue maybe? I swapped the SD cards around and got the same result on the TinyPilot KVM experiencing the mouse issue. I swapped the SD cards back to their original, respective, KVM's and now i notice the lack of mouse functionality on a second KVM (the previously working KVM that I had pulled the SD card from to test in the problematic KVM). I generated a log link for this now second non-functioning mouse issue. I still have two other TinyPilots that dont have any mouse issues as just an FYI.

                        2nd KVM mouse issue logs:

                      • I
                        In reply toimome9a:
                          2022-11-14 14:46:35.810Z

                          Looking for an update guys, if there is a software fix, awesome. Hopefully its not hardware but ether way, i need to get this KVM back to functional. I lean on these guys heavily for a work flow.

                          1. David @david2022-11-14 15:24:28.033Z

                            Hi @imome9a, thanks for your patience!

                            It seems very odd for this mouse issue to propagate across devices after swapping the SD card. Unfortunately, the 2nd TinyPilot's logs don't have any data from the USB / mouse, so I can't infer anything from them.

                            Can I just confirm that I've got this info correct?

                            • TinyPilot1's mouse doesn't work (but the keyboard does)
                            • The USB cable was checked and is working correctly
                            • You swapped the SD card with one from a working TinyPilot (TinyPilot2)
                              • The mouse issue persists on TinyPilot1 with TinyPilot2's SD card
                              • After replacing the SD card back into TinyPilot2, you now have the same mouse issue on TinyPilot2
                            1. I@imome9a
                                2022-11-14 15:26:57.370Z

                                You are 100% correct in your timeline/breakdown (I found it super odd as well). I'm more than happy to continue supplying whatever logs you might want/need, just let me know.

                                1. David @david2022-11-14 15:59:14.417Z

                                  Fantastic, thanks!

                                  I noticed that your first log didn't really have much info in it. Can you share another log from TinyPilot1? But can you click and move the mouse around the screen, and hit some random keys before you grab the log? Doing that should add some more data into the log for me to review.

                                  1. I@imome9a
                                      2022-11-14 16:04:08.283Z

                                      Here you go.. I used my keyboard (functional) and used my mouse (not functional) for a min or two and immediately generated this log:


                                      1. David @david2022-11-14 20:58:54.304Z

                                        Thanks for sharing those logs - there are no USB errors or anything like that in there, which is surprising.

                                        Can you tell me what your target machine is? i.e. the make / model / OS?

                                        And do you still have the mouse issue across different target machines? Can you test this again?

                                        1. I@imome9a
                                            2022-11-15 01:45:56.860Z

                                            Typically this KVM is connected to a Lenovo X1 Windows 10 laptop but during my testing I connected it to my personal laptop which is a Framework (Ubuntu Linux 22.04) laptop.

                                            1. I@imome9a
                                                2022-11-15 12:28:32.693Z

                                                The mouse issues was across both platforms.

                                                1. David @david2022-11-15 20:36:24.315Z

                                                  Thanks for clarifying!

                                                  Can I ask whether you're using a KVM switch or a USB hub to connect this TinyPilot to the target devices? I'm really just checking every possible variable to make sure there's nothing we've missed.

                                                  Could you try re-flashing your SD card? A fresh install might help here if it's a software issue.

                                                  1. I@imome9a
                                                      2022-11-16 12:33:44.827Z

                                                      My tinypilot is directly connected to the target machine and my network. No hubs or other KVMs in the mix here. Only correlation I can make is these last two tinypilots have become plagued with the no working mouse issue. My first two tinypilots are humming away just fine.

                                                      1. Thank you for confirming that your TinyPilot devices are directly connected. We really appreciate you taking the time to work through these diagnostics with us!

                                                        We've been going through the possibilities within the team and we think this is unlikely to be a hardware issue. Keyboard and mouse input travel mostly on the same channel and this would be the first ever report of a hardware issue causing the mouse to fail while the keyboard still functions. It’s also very unlikely that an identical hardware failure would affect two devices in quick succession.

                                                        I appreciate it's a hassle, but we've put together a few more tests that will hopefully help us to narrow down where the issue is occurring:

                                                        • Can you please check your browser console logs for any errors or warnings?

                                                        • Can you try accessing either of your TinyPilot devices with a different computer and browser? If that's not an option, could you please try using incognito or private browsing mode? This test is so we can check what happens in a clean session with no extensions.

                                                        • Can you try enabling SSH and copying the following snippet into the terminal? It will send mouse input directly to the mouse interface, eliminating any kind of network or client machine issues from the equation.

                                                          for i in {1..5}
                                                             echo "$(date --iso-8601=seconds):" "Moving mouse cursor"
                                                             echo -ne "\0\x03\x16\x58\x4c\0\0" > /dev/hidg1
                                                             sleep 1
                                                             echo -ne "\0\xbc\x1b\xdd\x2a\0\0" > /dev/hidg1
                                                             sleep 1
                                                        1. I@imome9a
                                                            2022-11-16 15:44:35.414Z

                                                            I tried from incognito (Chrome) ...didnt work
                                                            I tried from different browser (Firefox and Chrome) ...didnt work
                                                            I tried the code in the SSH terminal,, successfully ran the code BUT mouse didnt move

                                                            Im more than happy to do screenshare if that helps expedite.

                                                            1. I@imome9a
                                                                2022-11-16 15:44:52.734Z

                                                                Also.. no browser log errors

                                                                1. I@imome9a
                                                                    2022-11-16 15:46:58.433Z

                                                                    Also tried from another machine-- same result.. maybe i can try flashing the card? Is there an ISO I can download?

                                                                    1. I@imome9a
                                                                        2022-11-16 15:48:38.018Z

                                                                        Disregard, i found the link you posted with guidance for re-imaging. Giving that a shot.

                                                                  • In reply tocghague:
                                                                      2022-11-16 16:04:27.800Z

                                                                      I was able to resolve the issue by re-flashing the card! I can give you the opportunity to scrutinize the last dysfunctional KVM before I reload its card if you would like? Let me know.

                                                                      1. That's great news, I'm pleased to hear that it's working!

                                                                        We'd be very interested in finding out what actually caused this issue. Could you create a compressed image of the microSD card and share it with us?

                                                                        The following instructions explain how to do this on a Linux host via a microSD card reader. Please let me know if you're using a different host and I'll provide alternate instructions.

                                                                        1. Safely shutdown the affected TinyPilot device and remove the microSD card.
                                                                        2. Open a terminal session on your host computer but don't insert the microSD card just yet.
                                                                        3. In the terminal session, run lsblk. This will show the current storage devices on the system.
                                                                        4. Insert your microSD card into the reader and run lsblk again. A new section should appear.
                                                                        5. Compare the output of the two commands to find the name of your microSD card.
                                                                          • The name of the device can vary, but it will most likely be along the lines of sdc.
                                                                          • There may be child devices (e.g. sdc1 and sdc2). Only the top level (e.g. sdc) is needed.
                                                                        6. If any of the new devices have an entry under 'MOUNTPOINT' unmount them by running umount <mountpoint here> for each one.
                                                                        7. Run the following command dd if=/dev/<device name> bs=1M | gzip > tinypilot.img.gz. It will take some time for this to complete.
                                                                        8. Upload the file to us at
                                                                        1. I@imome9a
                                                                            2022-11-16 21:21:45.938Z

                                                                            I found the issue to be the tinypilot-jiggle.bash service that I had pulled down via Git ( This process had gotten hung up and needed some attention. After cleaning off this systemd service and reinstalling I didn't have any issues. I should have caught this much sooner. I apologize for all the wasted efforts on this.

                                                                            1. Thanks for confirming! There's absolutely no need to apologize - it's great that your TinyPilot devices are now both working again and as a bonus we now know what caused this and we'll be able to look out for it in future.