No internet connection
  1. Home
  2. Technical Support

Update Failed // Not Working with AMOS KVM

By Software Consulting @consultingcompany
    2022-12-10 02:03:29.980Z

    I've had a Tinypilot since March since I began my software consulting journey. As I settled into my roles, the use for an IP-KVM waned, but I liked how the TinyPilot worked out of the box. I let it collect dust since February.

    Recently, the need to control input remotely on multiple computers has risen again. I bought the AMOS KVM ( and basically got everything working except for the hotkey switching.

    After doing some research, I found out the problem was something something yada yada related to the way the TinyPilot emulates HID or something (I'm not that technical past the command line), and there was a certain version of the software that allowed you to turn of HID emulation or something that will allow the TinyPilot to work with the AMOS switch.

    I tried to update the TinyPilot Software through the web interface, and now it's botched. I am posting here for help to solve the following two problems.

    1. updating through the webUI failed/broke the software. How do I fix this so the TinyPilot at least works again?
    2. Can I get a version that works with the AMOS KVM so I can control multiple computers?

    Thank You so much

    • 4 replies
    1. C

      Hi @consultingcompany - thanks for your message, I'm sorry to hear you've had issues updating.

      I've looked into using the AIMOS KVM with TinyPilot and there are a couple of factors to consider. The first is that the AIMOS KVM is unusual in that it draws power from the HDMI ports and so it is recommended that you use a powered HDMI splitter to avoid stability issues. The second is that the AIMOS KVM appears to be incompatible with the virtual media feature that was added to TinyPilot Pro in version 1.5.0.

      Up until recently the workaround for the compatibility issue was to bring in a file from an older version of TinyPilot Pro and essentially remove the virtual media support. However, that shouldn't be necessary anymore as a change was made in TinyPilot Pro 2.4.0 to automatically disable virtual media support if nothing was mounted.

      I've checked and version 1.5.0 of TinyPilot Pro was released in May 2021 and 2.4.0 was released towards the end of March 2022. As your TinyPilot device has been in storage since February it's probably running a version of the software that includes virtual media support but not the later change to automatically disable it. It's likely that upgrading to the latest version will solve the issue.

      It sounds like your device isn't offering the web interface following the failed upgrade and it's unclear if you have SSH access available. The most straightforward option is to carry out a factory reset. I appreciate it's a hassle but I suspect it'll be the quickest and easiest way to restore access to your TinyPilot device while also upgrading the software.

      1. Hey I appreciate the quick reply!

        So I actually factory reset the TinyPilot last night and flashed the latest and greatest build. I am having two problems right now.

        • The TinyPilot is now able to trigger the KVMs keyboard shortcut for switching, HOWEVER
        • I am running a Windows Desktop and a Ubuntu Server Optiplex Micro Box on the KVM.
        • The Tinypilot is able to get the video from the Windows Desktop, The Keyboard Entries Work, but the Mouse Lags/Is Unstable/Doesn't Work
        • The TinyPilot is sometimes able to enter input into the Ubuntu Server, but is unable to get the video

        in all cases, the hotkey switching works, but I'm facing problems with getting the HDMI output for a basic CLI Debian server to show, along with input - on Widnows Desktop, the curser is broken

        I used this guide as a reference, and I am having issues (

        1. I am using the powered HDMI Splitter recommended in that guide as well

          all hardware is from that guide

          1. Thanks for the update, I'm pleased to hear that there's been some progress!

            Could you please provide logs for each scenario you mentioned? You can generate a sharable link by going to System, then Logs and then clicking on Get Sharable URL.