No internet connection
  1. Home
  2. Technical Support

No Signal on DVI-Con KVM from Guntermann and Drunck

By @ttaugs
    2022-12-19 09:07:03.542Z

    we have a KVM-Matrix-Switch here in our Company.
    In our Office we are eight people with only one KVM and Monitor.
    So we decided to buy a tinypilot, to put the system into browser.

    The Guntermann and Drunck DVI-CON is the end of the KVM-Matrix, with DVI-Output.
    Booting the System will be seen with TinyPilot, but as soon as he switches to the actual video signal from the KVM, I get no Signal.

    I also tried the other EDID from the FAQ, with the same issue.

    The Specs of the DVI-Output from G&D:
    DVI Single-Link
    Auflösung DVI / VGA
    1920 x 1200 @ 60Hz
    1280 x 1024 @ 85Hz

    Any Solutions for me?


    • 2 replies
    1. David @david2022-12-19 15:24:25.451Z

      Hi Thomas, sorry that you're running into this No Signal issue with your KVM.

      And thanks for letting me know that you already tried the alternate EDID from the FAQ.

      Unfortunately, 1920x1200@60hz is not supported by TinyPilot due to bandwidth constraints. However, 1280x1024@85hz is theoretically possible, as far as I know - but it's not a display setting that we've tested because 85hz is quite uncommon nowadays.

      I did a few tests to try and see if 1280x1024@85hz works on TinyPilot, but all of them failed. The image scrambles and makes the display illegible:

      You're welcome to try this EDID with 1280x1024@85Hz enabled on your TinyPilot with the G&D KVM, but I don't think it will work.

      If you'd like to try it, ssh into your TinyPilot and run these commands:

      EDID="$(mktemp -d)/tc358743-edid.hex"
      echo -ne "" | sudo tee "${EDID}" && \
        echo '00ffffffffffff0052628888008888882d1e0103' | sudo tee -a "${EDID}" && \
        echo '800000781aee91a3544c99260f50547fef8081c0' | sudo tee -a "${EDID}" && \
        echo '8140810081809500a9c081406140271f80f07138' | sudo tee -a "${EDID}" && \
        echo '164038c0350040442100001eec2c80a070381a40' | sudo tee -a "${EDID}" && \
        echo '3020350040442100001e000000fc0054696e7950' | sudo tee -a "${EDID}" && \
        echo '696c6f740a202020000000fd003b3d0f2e100000' | sudo tee -a "${EDID}" && \
        echo '000000000000014702031c7a4c010204139f2021' | sudo tee -a "${EDID}" && \
        echo '223c3d3e3c2066030c00300080e2007f673e00d0' | sudo tee -a "${EDID}" && \
        echo '5100364060883700800010000000e13200a05000' | sudo tee -a "${EDID}" && \
        echo '2a40302037008000100000180c30005050002a40' | sudo tee -a "${EDID}" && \
        echo '0820c80080001000001800000000000000000000' | sudo tee -a "${EDID}" && \
        echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
        echo '000000000000000000000000000000ff' | sudo tee -a "${EDID}" && \
        sudo v4l2-ctl --device=/dev/video0 --set-edid=file="${EDID}" --fix-edid-checksums

      And to revert the EDID (from our How do I change my TinyPilot's EDID? article):

      sudo cp ~/tc358743-edid.hex.bak "${EDID}" && \
        sudo chown ustreamer:ustreamer "${EDID}" && \
        sudo v4l2-ctl --device=/dev/video0 --set-edid=file="${EDID}" --fix-edid-checksums

      Please let me know if that helps at all!

      1. T
        In reply tottaugs:
          2022-12-21 05:00:12.219Z

          Hello David,
          thank you for your suggested solution.
          Unfortunately it doesn't work, I also have a picture like you above.
          OK, since I don't have the option to set the resolution on the KVM at G&D, I won't be able to use the Tinypilot on it.
          Nevertheless many thanks.