No internet connection
  1. Home
  2. Technical Support

Unable to see TinyPilot in IP scanner (TinyPilot not showing in Talescale)

By Gauri @Pauri
    2022-12-28 23:33:31.244Z

    Hello Friends

    Need help with setting up TinyPilot for the first time on my personal laptop. Followed all the steps as mentioned but I am unable to see TinyPilot in IP scanner. Also the TinyPilot in the not showing in Talescale admin window). Tried all the possible ways as suggested in your forum but no luck.

    I also tried looking for TinyPilot in my home router for the DHCP entry that is assigned to the TinyPilot, but I couldn’t see it there either.

    Request to please help.

    Solved in post #6, click to view
    • 9 replies
    1. David @david2022-12-29 12:47:46.128Z

      Hi @pauri, sorry you're having issues getting your TinyPilot's IP address.

      First, I'd like to check that your TinyPilot behaves correctly during boot. When you power your TinyPilot, do you see the solid red power LED and the flashing green LED? And do you see the two ethernet LEDs lighting up too?

      If your TinyPilot's LEDs behave correctly, my initial suggestion is to re-flash the SD card. Then power the device and leave it to boot for about 5 minutes. If the TinyPilot lost power at some point during its first boot, it may have impacted part of the setup.

      1. PGauri @Pauri
          2022-12-29 21:41:55.071Z

          I see the solid red power LED and the flashing green LED. However I do not see the two ethernet LEDs lighting up. The ethernet cable is plugged in the first slot of my wireless modem router and one end into the TinyPilot. Do you still want me to re-flash the SD card? Please suggest.

          1. David @david2022-12-30 12:15:27.856Z

            If you're not seeing the ethernet LEDs, the issue is more likely with the ethernet cable or the router. So I wouldn't recommend a re-flash in this case.

            To test your connection, could you connect the ethernet cable into a different port on the router and see if the ethernet LEDs on your TinyPilot start flashing?

            If that doesn't work either, we should test the ethernet cable to make sure it's working. You can test that by connecting a different device to the ethernet cable and checking whether you get an internet connection. You should disconnect the alternate device from WiFi when testing this - otherwise the device may fall back to using WiFi if it can't connect to the internet over the ethernet connection.

            1. PGauri @Pauri
                2023-01-03 06:09:32.230Z

                I can see the ethernet LEDs. The ethernet cable is working great. I tested the ethernet cable by connecting my laptop [Wi-Fi was disabled], and it worked. Do you want me to re-flash the SD card? And even after re-flashing the card, what if I don't get the expected results? Do you guys recommend sending a replacement device?

                If yes, what is the procedure to get a replacement device, and how soon can I get it considering I need it on priority?

                1. David @david2023-01-04 12:14:20.101Z

                  Thanks for testing that out!

                  Just to clarify, does "I can see the ethernet LEDs", mean on the ethernet LEDs on your laptop? If so, a re-flash may help - so I'll recommend doing that, just so that we've covered all bases. It's also a good idea to try a different ethernet cable if you can in case the current one is flaky.

                  If a re-flash along with a different ethernet cable doesn't work, it could be a hardware issue with your TinyPilot. We fully test every device before shipping, so our hardware defect rate is very low. If any parts are defective, we'll replace them within 90 days of purchase.

                  Reply1 LikeSolution
                  1. PGauri @Pauri
                      2023-01-04 20:12:15.749Z

                      This is what I did

                      A. When I power my TinyPilot device
                      -- I see solid red power LED and a flashing green LED
                      -- I also see the two ethernet LEDs lighting up too on the TinyPilot
                      -- TinyPilot's LEDs behave correctly when connected from my wi-fi modem router to TinyPilot

                      B. I could see the ethernet LEDs on TinyPilot and the Laptop using my ethernet cable. [This was done to check whether the Ethernet cable is faulty or not]

                      C. Everything looks ok with Points A and B above. However, as recommended, I will go ahead and get a new ethernet cable and test it once again. Also, as recommended, I will re-flash along with a different/new ethernet cable.

                      Once done, I will post my response with my results/analysis.

                      1. David @david2023-01-05 13:09:06.718Z

                        Thanks for the update! If you have ethernet LEDs flashing on the TinyPilot it sounds more like an issue with software rather than a hardware fault. A re-flash is a good idea, but if that doesn't work we should look at your switch and the DHCP settings.

                        During the first boot after the re-flash, can you leave the TinyPilot for about 5 minutes to set up completely?

                        Let me know how the re-flash goes!

                        1. PGauri @Pauri
                            2023-01-06 05:40:26.590Z

                            Success, everything is working as expected now with the desired results. Thank you for recommending trying it with a new Ethernet cable. A new ethernet cable did the magic. Problem resolved. Thanks, David.

                            1. David @david2023-01-06 13:14:51.095Z

                              Fantastic! I'm glad that it's now working, thanks for the update!

                              Please feel free to reach out again if you have any other questions or issues.