No internet connection
  1. Home
  2. Technical Support

Video screen problem.

By Michael Busch @mjbusch81
    2022-12-30 15:13:12.196Z

    Having issues with display back. Only option is to reboot the device. How do I go about getting this resolved?

    Solved in post #6, click to view
    • 13 replies
    1. David @david2023-01-03 12:12:27.808Z

      Hi @mkbusch81, sorry that you're running into this display issue.

      Thanks for sharing that screenshot!

      Can I ask which device you're rebooting to temporarily resolve the issue? Is it your TinyPilot or your target machine?

      Could you share a log from your TinyPilot for me to review when this display issue appears? On your TinyPilot's web interface, navigate to System > Logs and click Get Shareable URL. Then paste the link in your reply.

      1. MMichael Busch @mjbusch81
          2023-01-03 17:48:41.495Z

          To fix the issue I just reboot the Tinypilot. The target machine is a Intel Nuc running Windows 10.

          1. David @david2023-01-04 13:04:55.438Z

            Thanks for sharing that log! Unfortunately, it hasn't revealed anything in this case.

            Does disconnecting and then reconnecting the HDMI cable restore the image, or is it only resolved with a reboot?

            Could you try changing your TinyPilot's EDID and see if that helps?

            1. MMichael Busch @mjbusch81
                2023-01-04 15:27:17.753Z

                The only fixes I have found is to either reboot the KVM or disable screen sleep mode. I guess I can try changing the EDID if disabling sleep doesn't seem to work in the long term. It's only been a week using the Tinypilot.

                1. David @david2023-01-04 18:50:43.985Z

                  Ahh, if your target machine auto sleeps after a period of time, TinyPilot can't wake it up - which might be where the underlying issue is. This is a known issue with a fix that we can't yet integrate into the TinyPilot software.

                  Disabling sleep mode on your target machine should solve this!

                  1. S@speedswan
                      2023-01-09 18:19:59.200Z

                      I have this same problem and my machine is set not go to sleep either the machine or the screen.
                      I'm using 1080p resolution although I had been previously using on a 1080p machine with no problems.
                      It tends to happen about every 24 hours currently
                      The machine that has problems is an Intel NUC9i5QNX running Windows 10
                      The machine that works is an Intel NUC8I3CYSM running Windows 10

                      1. David @david2023-01-10 12:40:27.271Z

                        Hi @speedswan, sorry that you're also running into this issue.

                        Does your screen look the same as the image that mjbusch81 shared?

                        Could you share a log from your TinyPilot when you see this issue again? On your TinyPilot's web interface, navigate to System > Logs and click Get Shareable URL. Then paste the link in your reply.

                        If you haven't tried already, changing your TinyPilot's EDID or changing your NUC's output display settings to 720p at 60Hz may help.

                        1. S@speedswan
                            2023-01-10 21:28:13.454Z

                            I'm seeing exactly the same as the image above.

                            Is there any way to share the log link with you directly as opposed to pasting it here?

                            I'll try changing the EDID and resolution and report back - it's currently set to 1080p30

                            1. David @david2023-01-11 12:36:28.975Z

                              Thanks for confirming that you have exactly the same issue.

                              If you're concerned about sharing potentially sensitive information in the log, you can toggle Hide Sensitive Data on the log interface before clicking Get Shareable URL. Once I've reviewed the log, you can always edit your reply to remove the link.

                              1. S@speedswan
                                  2023-01-11 20:25:27.208Z

                                  It does the same with 720p60

                                  Here's the log

                                  I'll try to look at the EDID stuff later

                                  1. David @david2023-01-12 12:18:52.775Z

                                    Thanks for sharing that log! It looks like the resolution is switching away from 720p for some reason. I wonder if it could be a problem with that NUC's output?

                                    Does the issue appear predictably, or is it random? And can you temporarily fix the issue by disconnecting and the re-connecting the HDMI cable?

                                    Let me know if an EDID change makes a difference.

                                    1. S@speedswan
                                        2023-01-14 19:52:20.676Z

                                        Remember when I said my screen was not set to go to sleep - that was a lie, after I disabled the screen going to sleep it fixed it.

                                        Oddly enough, on the other NUC it's set for the screen to go to sleep and it's fine, so it must be something that version of the NUC does that the TinyPilot doesn't like - anyway, we have a workaround now and thanks for the help!

                                        1. David @david2023-01-16 12:40:39.160Z

                                          Thanks for the update! I'm glad we figured out the issue in the end!

                                          Oddly enough, on the other NUC it's set for the screen to go to sleep and it's fine

                                          Interesting - perhaps it could be a different 'level' of sleep like a low power mode?