No internet connection
  1. Home
  2. Technical Support

Keyboard works - but no SVGA video display

By David @david2023-01-05 12:23:29.414Z

  • 7 replies
  1. G
      2023-01-04 19:37:38.939Z

      Hi @michael ,

      Just unboxed a TinyPilot Voyageur 2 today and am trying to get it going for our customer. Same as others here, keyboard works when I boot to DOS - this is an old IBM ThinkCentre - but no SVGA video display. I have also tried the TP on a Dell PowerEdge R6515 and a Dell Optiplex 3020M, all with same results. I've tested the HDMI cable separately and I know it works. The TP's logs > Ustreamer logs look like this:

      uStreamer logs
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.439 stream] -- Using resolution: 1920x1080
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.439 stream] -- Using pixelformat: UYVY
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.439 stream] -- Querying HW FPS changing is not supported
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.439 stream] -- Using IO method: MMAP
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.459 stream] -- Requested 5 device buffers, got 5
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- ERROR [558.460 stream] -- Unable to start capturing: Invalid argument
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.472 stream] -- Device fd=10 closed
      Jan 04 19:34:55 tinypilot ustreamer[575]: -- INFO [558.472 stream] -- Sleeping 1 seconds before new stream init ...
      Jan 04 19:34:56 tinypilot ustreamer[575]:

      Not sure what "Unable to start capturing: Invalid argument" but doesn't look good.

      Any suggestions?

      • Greg
      1. G@gpk
          2023-01-04 19:42:34.063Z
          1. David @david2023-01-05 12:35:51.197Z

            Hi Greg, sorry that you're running into this No Signal issue.

            And thanks for sharing those logs too! It looks like your target device is outputting at 1080p, 60Hz, which isn't supported on TinyPilot. The solution is to change the output settings on those devices to a resolution and refresh rate that TinyPilot does support.

            Are you using the VGA adapter that we sell with TinyPilot? If so, there are different display settings supported the VGA adapter.

            Can you try changing the output settings on one of your target machines to see if that resolves the issue? I'm not sure which OS your target machines are running, but typically you find resolution and frame rate options in your computer's system settings under "Display."

            1. G@gpk
                2023-01-05 20:51:55.100Z

                Hi David,

                It seems unlikely all 3 devices I connected to, including one old PC, would all have the same problem, doesn't it? We actually need BIOS-level and DOS-only access to at least one PC - is there a way to reduce resolution and refresh rate on systems that don't have Windows on them?

                I guess I was envisioning Lantronix Spyder-like behaviour, which, although it had other problems (blech, Java), hasn't demonstrated a No Signal issue. Really was hoping TP would be just drop-into-place-and-go - is that unrealistic?

                • Greg
                1. David @david2023-01-06 15:52:02.847Z

                  I completely understand that this No Signal issue is frustrating. If you haven't seen it already, we have an article dedicated to No Signal problems that people run into, and some possible solutions. A plug and play experience is what most people have with their TinyPilot - especially if they're using HDMI to HDMI. Unfortunately, introducing adapters (or uncommon resolutions) sometimes leads to issues like this on rare occasions.

                  Could you try changing your TinyPilot's EDID? I think that might help here, particularly if the output resolutions on those machines are different to the HDMI resolutions listed in our supported resolutions FAQ.

                  Are you using an adapter between your target machines and TinyPilot? Is it the VGA adapter that we sell alongside TinyPilot?

                  Changing the display settings on systems without Windows can vary. In the past, I've successfully changed display settings on Linux using xrandr. If changing your TinyPilot's EDID doesn't help, I can dig deeper into changing the display settings on your machines.

                  1. G@gpk
                      2023-01-10 14:17:17.454Z

                      Hi David,

                      I just attempted the EDID settings change, and rebooted the TP, still no change.

                      "Are you using an adapter between your target machines and TinyPilot? Is it the VGA adapter that we sell alongside TinyPilot?" - YES to both

                      The fact it didn't work at the BIOS screen on an old PC running DOS and a simple video card, and also failed to show anything at all on two other more modern systems, makes me think this may be a faulty TP?

                      The business use for this TP is to connect it to PCs running industrial equipment (think Windows7, XP Embedded, etc) - it needs to be drop-dead simple to connect and provide techs in Germany or USA remote access to PCs where TeamViewer is not an option. If TP is the wrong tool for that job, please let me know that too - we don't need to spend more time and energy on this in that case.

                      • Greg
                      1. David @david2023-01-10 16:48:44.704Z

                        Thanks for the update, Greg!

                        Do you have a machine with an HDMI output you can use with your TinyPilot to check that it all works as expected? I'd like to see whether the VGA adapter is the cause of the issues you're experiencing.

                        If your TinyPilot works with HDMI, we can narrow it down to being an issue with the VGA adapter - rather than a faulty device. If that's the case, I'll help find a suitable solution.