No internet connection
  1. Home
  2. Technical Support

How to enable H264?

By David @david2023-02-06 12:44:47.031Z

Solved in post #13, click to view
  • 13 replies

There are 13 replies. Estimated reading time: 11 minutes

  1. T
      2023-02-04 08:37:22.087Z

      Using Tailscale over IP. H264 Enabled/Disabled , Enabled again.
      Browswer says it's running MPEG. Settings are on H264 though.
      Did sudo reboot. pilot browswer restart. Does physical plug/unplug do better or its same as sudo reboot?

      How to enable H264?

      Used this line in browswer edge/chrome same.
      document.getElementById('remote-screen').shadowRoot.getElementById('mjpeg-output').src === '' ? 'h264' : 'mjpeg' <- Logs <installed This verson of Tailscale

      Getting this also when clicking Update in browswer
      1. David @david2023-02-06 13:01:15.781Z

        Hi @TopBun, sorry that you're running into issues with H.264.

        TinyPilot falls back to MJPEG if it doesn't get an H.264 signal, which explains why you're seeing the MJPEG stream with H.264 selected in your settings.

        Can you SSH into your TinyPilot and run the following command?

        sudo service janus status

        If janus is running, it should return Active: active (running), if not, Active: inactive (dead).

        If it's not running, could you restart the Janus service and see if that brings up the Janus server (and H.264 streaming)?

        sudo service janus restart

        If restarting the Janus service doesn't work, can you share the output of sudo service janus status with me?

      2. T
        In reply todavid:
          2023-02-06 18:40:29.219Z
          1. David @david2023-02-06 19:57:24.599Z

            Thanks for sharing that screenshot!

            I'm not sure why, but it looks like your janus service is masked.

            Can you try running these commands and see if janus restarts and re-enables H.264 for you:

            sudo systemctl unmask janus && \
              sudo service janus start && \
              sudo service janus status
          2. T
            In reply todavid:
              2023-02-07 23:21:44.310Z

              Seems Janus unmasked? Any other steps to do to activate H264? Browser and Interface says it's MPEG(Video settings are on H264 in the TinyPilotPro interface).
              I Did sudo reboot and browser reboot/refresh. Using Chrome.


              1. David @david2023-02-08 12:37:30.091Z

                TinyPilot now fully supports H.264 as of version 2.5.2 with settings available in the web interface. So you don't need to use the old command-line instructions to enable H.264.

                There's a lot of odd issues cropping up that I can see - like the "Failed to retreive version information" error, and the "command not found" error for files that should exist. Those issues tend to point towards a corrupt filesystem on the SD card.

                I know it's inconvenient, but are you able to re-flash your SD card with the latest TinyPilot image? That should resolve all of these issues, and then allow you to perform a clean install of Tailscale using the commands in our Tailscale blog post.

                I noticed that you re-flashed your SD card not long ago too. Are you using the same SD card? If so, it sounds like your SD card could be close to the end of its lifespan.

                In this case, I'd recommend trying to boot from USB, or to get a new SD card. You can also try the read-only filesystem (once everything is setup and working) to help reduce the likelihood of encountering filesystem corruption again.

                1. T@TopBun
                    2023-02-15 22:06:58.194Z

                    Tinypilot Voyager 2 Flashed with 2.5.2 version to USB key.
                    Installed tailscale
                    in web changed to H264, but still no change. It says it's running MPEG.
                    Janus seems working.
                    UPdated to 2.5.3 . Still in MPEG.
                    Maybe flashing to 2.5.2 and updateint to 2.5.3 does not work?
                    Tried to enable/disable enable H264 via SSH again doesn't work either.

                    How to Enable H264?


                    1. David @david2023-02-16 12:29:17.346Z

                      Just to re-iterate - you no longer need to enable H.264 via SSH on the command line. TinyPilot fully supports H.264 as of the 2.5.2 software release. Running those old commands (which we no longer publish) from last year may break the H.264 configuration on versions 2.5.2 and 2.5.3.

                      Here's what I'd recommend doing:

                      • Re-flash with 2.5.3
                      • Boot your TinyPilot
                      • Open the TinyPilot web interface locally, without Tailscale (if possible)
                      • Turn on H.264 from the "Video Settings" menu
                        1. Go to System > Video settings on the TinyPilot web interface
                        2. Click the "Streaming Mode" dropdown
                        3. Set the streaming mode to H.264
                        4. Click "Apply"

                      The problem could be something similar to the issue in this thread where network settings prevent H.264 streaming. If H.264 still doesn't work after performing those steps I outlined, could you send another log and tell me about your network setup when connecting to your TinyPilot?

                      1. T@TopBun
                          2023-02-21 05:05:38.649Z

                          Over Lan it streams H.264. Over ip it is still im MPEG, refreshed browser restarted devices.
                          Changed router Nat Filtering in to Open.
                          Have an Arris modem, cant log into it. Could a modem be NAT Filtering not open? Modem: arris surfboard sb8200 docsis 3.1. Router Netgear is not a docsis 3.1 maybe they are not compatible.
                          What else could I do to fix H264 ?
                          If that fails any routers/modems you would recommend to buy that work well with tinypilot?


                          1. David @david2023-02-21 13:05:20.618Z

                            Thanks for the details @TopBun! From how you described the issue, it sounds like you're encountering a similar issue to others running into H.264 over the internet.

                            Unfortunately, I don't have a good answer for what the issue is, or how to fix it yet - it's something we're currently investigating internally.

                            Once we've learned more about the issue, I'll come back and reply to this thread to give you an update.

                            1. T@TopBun
                                2023-03-01 21:48:38.288Z

                                Problem Fixed: Issue was NAT filtering + VPN browser extension.

                                1. David @david2023-03-02 12:15:54.148Z

                                  Thanks for the update @TopBun! I'm glad you're back up and running with H.264.

                    2. T
                      In reply todavid:
                        2023-02-07 23:31:35.475Z

                        Trying to disable and enable it again when disabling getting this:

                        Also I installed Tailscale Raspbian Buster. Post says to install Debian Buster. Is it the same ? Might it be the issue? How do I update it to Debian Buster if you think it could fix it ?