No internet connection
  1. Home
  2. Technical Support

No keyboard/mouse only at Filevault login screen

By Mike Nestor @BaconKiller
    2021-04-30 18:34:47.332Z

    I've been playing with the hobbyest kit and have had no issues with a few linux systems. I had a friend get the Voyager for use with a headless Mac Mini she has. The keyboard and mouse don't work until we get past the filevault login screen. Kind of defeating the purpose of getting it! Darnit!

    If I plug another keyboard in I can see the typing can get by then the tinypilot keyboard and mouse emulation work. I read in another post here about tinypilot emulating a usb hub. I've used usb hubs before to connect a keyboard/mouse to that system without issue so I'm thinking it isn't that.

    What other things can I look at?

    • 19 replies
    1. Thanks for reporting this. I haven't heard this before and I believe many TinyPilot customers manage Mac Minis, so I'm hoping we can figure out what's going wrong.

      If I plug another keyboard in I can see the typing can get by then the tinypilot keyboard and mouse emulation work.

      If you plug in another keyboard, then TinyPilot works on FileVault? Or it only works after you complete FileVault login with the physical keyboard?

      Can you share the log file from the Voyager? (System > Logs)

      1. BMike Nestor @BaconKiller
          2021-05-01 11:53:43.453Z

          Looks like it didn't see it being connected when at the FV screen?
          Apr 30 13:54:13 tinypilot python[585]: [2021-04-30 13:54:13,952] ERROR in socket_api: Failed to forward mouse event: Failed to write to HID interface: /dev/hidg1. Is USB cable connected?

          1. If you plug in another keyboard, does TinyPilot works on the FileVault screen? Or does TinyPilot keyboard input only work after you complete FileVault login with the physical keyboard?

            1. BMike Nestor @BaconKiller
                2021-05-14 16:46:52.831Z

                Apologies, I've been self isolating. I hope to go test this, something I should have thought to check the first time, soon. The system in question did do a secure reboot last night, so skipped the filevault login, and I was able to do the second login without issue. Not really any news, good or bad, though since I could do that with ARD anyway. I hope to be able to go check with a keyboard plugged in next week.

                1. ServeTheHome reviewed the Voyager and reported a similar issue. Is this an M1 Mac Mini?

                  I'm wondering if the Mac Mini whitelists keyboards by HID identifiers. If you'd like to test my theory, you can plug in a keyboard to the Mac Mini, run lsusb from the Mac Mini to get the HID IDs of the USB devices, and then paste it into these lines of /opt/tinypilot-privileged/init-usb-gadget:

                  echo 0x1d6b > idVendor  # Linux Foundation
                  echo 0x0104 > idProduct # Multifunction Composite Gadget

                  (first number becomes idVendor, second number becomes idProduct)

                  1. BMike Nestor @BaconKiller
                      2021-05-18 15:00:10.078Z

                      Tried with external keyboard plugged in and that didn't work. It is not an M1. I did try to lsusb but since it doesn't exists I used system_profiler. That didn't not work either.

                      1. Sorry, I can't think of anything else to try. I'm not sure why FileVault isn't accepting input.

                        If your friend would like to arrange a return, I'll offer a full refund including return shipping.

                        1. BMike Nestor @BaconKiller
                            2021-05-18 22:17:56.271Z

                            I don't think that is nessessary, it is still useful just not as much as we'd hoped. I might not be able to just remote in and reboot the system as needed but I can at least remotely connect and tell her to plug a keyboard in and type a password way easier than I could tell her to plug a monitor and keyboard in and then tell me what she sees. I'm sure this issue will be resolved at some point.

                            I'd plug my hacker version into a system here to play with more but all I have are mac laptops with usb-c ports so I'm sure that will be WAY different. I've seen where my CalDigit dock doesn't always allow me to enter passwords at FileVault on them but that was random. Some days they work others they don't.

                            Oh wait, I do have an older Air I can try this out on. Will do that soon and let you know what I find.

                            1. In reply tomichael:
                                2021-08-02 21:18:35.514Z


                                Is there any way to make this work? We are having the same issue and it's very important to be able to unlock a MacOS computer remotely - otherwise the password must be shared with a remote user. Is it possible to simulate a keyboard so that the MacOS will allow typing?

                                1. Unfortunately we haven't found a solution for this. It seems to be a limitation of our hardware, so we're looking into alternate hardware that FileVault will accept.

                  2. S
                    In reply toBaconKiller:
                    Luca Soldaini @soldni
                      2021-05-14 23:54:38.579Z

                      Hello! New Voyager user here. I haven't tested your workaround, but I'm am experiencing the same issue. Running a 2018 Intel Mac Mini on macos 11.3. I will report back once I have a chance to try it :)

                      1. M
                        In reply toBaconKiller:
                        Josh Rodriguez @monkeyodeath
                          2022-03-01 19:11:49.640Z

                          Just encountered this issue with my new TinyPilot. (Using a MacBook Pro M1).

                          I think I found a workaround -- if I restart the TinyPilot once I get to the FileVault screen, MacOS seems to recognize the keyboard.

                          Note that you have to be using a USB-A to USB-C adaptor to connect to the MacBook as opposed to a USB-C cable.

                          Looked into trying to power-cycle just the Pi USB-C port itself, but unfortunately that's the only one that doesn't allow power cycling.

                          Not sure if there are other things to try but figured I'd at least post this info. Power-cycling the entire PI isn't a great solution but it at least works.

                          1. MJosh Rodriguez @monkeyodeath
                              2022-03-01 20:45:12.125Z

                              Just an update -- it appears that this also works if I disconnect the USB cable from the TinyPilot from the USB-A/USB-C connector attached to the MacBook, then reconnect.

                              1. BMike Nestor @BaconKiller
                                  2022-03-01 21:48:06.450Z

                                  Interesting. I use a little c program I copied from: to reset a zwave stick in one of my linux systems so I don't have to physically go do that. Maybe that will work?

                              2. B
                                In reply toBaconKiller:
                                Mike Nestor @BaconKiller
                                  2023-03-31 00:56:47.989Z

                                  Just a new datapoint. I moved the server that the Tinypilot Pro was connected to and plugged my Tinker version in. And mouse/keyboard worked perfectly. Plug it back into the Pro and it fails. Little shocked it is behaving like that. In a few weeks that system won't be used anymore so I'll be able to try out plenty of things to figure out why.

                                  1. Thanks for sharing this Mike! It’s interesting to know that a different board appears to work so this could be a useful piece of information for us. Could you please confirm what software you’re running on your Tinker board (e.g. a version of TinyPilot community)?

                                    1. BMike Nestor @BaconKiller
                                        2023-04-07 20:27:11.230Z

                                        The one it works on is the TinyPilot Hobbyist Kit I got in Feb 2021. The Voyager was purchased in April 2021. Voyager fails at FileVault but the Hobbyist works.

                                        1. CCharles Hague @cghague2023-04-11 19:57:36.832Z2023-04-11 21:40:44.219Z

                                          Thanks for confirming! I’ve shared this with the team. It seems likely that this might be a hardware limitation, but we’ll look into it and see if there is anything further we can learn. I’ll let you know if I have any updates.

                                          1. BMike Nestor @BaconKiller
                                              2023-04-14 20:47:33.236Z

                                              @cghague I completely failed to realized that my tinypilot is connected through an HDMI Switch. I'm going to hook up the other one to it and test that out in the next few days. This is the switch I have.