No internet connection
  1. Home
  2. Technical Support

Restarted Tiny Pilot - status light amber and cannot connect

By Travis Omasta @Rianer
    2023-02-28 12:26:46.824Z

    Hello, I was accessing Voyager 2 tiny pilot remotely and was having an extreme lag issue, despite a solid internet connection at both locations. I restarted my tiny pilot and was no longer able to connect. Now that I am back on site I am trying to connect and getting a 502 Bad Gateway screen, and the light on the device is amber not red. I have tried removing the power and plugging it back in, and the light returns to amber.

    Any advice?

    • 19 replies

    There are 19 replies. Estimated reading time: 13 minutes

    1. R
      Travis Omasta @Rianer
        2023-02-28 12:34:00.258Z

        Update: My mistake, the lights on the power side are solid red and flashing green, the amber and green light are on the ethernet port. However when I attempt to access I am getting the 502 Bad Gateway screen with nginx/1.14.2

        1. C
          In reply toRianer:

          Hi Travis, thanks for reaching out to us. I’m sorry to hear you’re having issues accessing your TinyPilot device.

          It sounds like one of the services on your TinyPilot device has failed to start correctly. It might be possible to fix this by simply restarting your TinyPilot device again. If you’ve previously enabled SSH then you can trigger a safe reboot by running sudo reboot. If you haven’t previously enabled SSH, or it’s not responding, then you’ll need to disconnect the power cable (or the network cable if you are using Power-Over-Ethernet), wait 30 seconds, and then reconnect the cable.

          1. RTravis Omasta @Rianer
              2023-02-28 14:00:56.229Z

              Thank you for the quick reply Charles, I have attempted to restart a few times, I will give it a longer time off this attempt. I did enable SSH, to provide remote log in (using tailscale) but I am extremely unfamiliar with SSH in general. Can you provide direction on how I would restart through SSH?


            • R
              In reply toRianer:
              Travis Omasta @Rianer
                2023-02-28 15:14:19.247Z

                Hello Charles and support,

                I was able to SSH into the tinypilot with the channels I had previously established, and execute sudo reboot. However, I am still not able to connect to the device through my browser. I receive the same 502 bad gateway warning. It appears that I am able to connect through taiscale as well, the network device shows up as connected, but going to the ip or tinypilot/ address will not connect to the device.

                Please advise my next steps

                Thank you!

                1. Thanks for getting back to me so quickly. It’s good that SSH is enabled as that will mean we can do some diagnostics and hopefully fix the issue directly. Can you please connect over SSH, run the following command and then share the results with me (a screenshot or photo is fine)?

                  sudo systemctl status tinypilot
                  1. RTravis Omasta @Rianer
                      2023-02-28 15:53:48.867Z

                      Great! Please see screenshot below:

                      1. Thank you for the rapid response! It does indeed look like the TinyPilot service isn’t running correctly. Could you please share your full logs with me? You can do this over SSH by running the following command and then entering “y” when asked if you’d like to upload your log file. A URL will be generated that you can share with me here. Just so you’re aware, it’s normal for this command to result in a lot of text being displayed.

                        sudo /opt/tinypilot-privileged/collect-debug-logs
                        1. RTravis Omasta @Rianer
                            2023-02-28 18:10:06.849Z

                            I executed the command and here is the log.



                            1. Thanks for sharing the logs with me! It looks like a required file may be missing. You may be able to fix this by re-installing TinyPilot with the following command, which you can copy and paste as a single block of text into your SSH session:

                              if [[ -f /opt/tinypilot-updater/install ]]; then
                                (sudo apt remove -y tinypilot || true) && \
                                  cd /opt/tinypilot-updater && \
                                  sudo ./install

                              This command will take some time to complete and will output a large amount of diagnostic information which you can ignore. Once it has completed you should be able to access the web interface. Unfortunately, missing files are often a symptom of filesystem corruption, so if the above doesn’t help then you may need to factory reset your TinyPilot device.

                              1. RTravis Omasta @Rianer
                                  2023-02-28 21:39:43.445Z

                                  I am assuming this means that it failed, and likewise I am still not able to log in.

                                  This is the first time I have restarted the tinypilot since I set it up about 6 weeks ago, and it is a refurbished system that I purchased. I am not sure if any of that is cause for warning.

                                  Is the next step the factory reset?

                                  1. RTravis Omasta @Rianer
                                      2023-02-28 21:45:31.732Z

                                      I followed the link you provided and I don't have the necessary components to follow these steps on hand. Is this something covered under the warranty? As I mentioned this is the first reset of the device, which was refurbished and only set up for a bit over 6 weeks. I purchased it on Jan 9th of this year.

                                      Thanks again!

                                      1. I’m sorry to hear that a manual re-installation didn’t work. The screenshot suggests that files aren’t in the expected locations and so it’s looking increasingly likely that this is due to a corrupt filesystem. I appreciate a factory reset can be a hassle, so as an alternative can you please visit the download page and then follow the instructions for a command line installation? This will use a slightly different method which may help fix the issue, but if it doesn’t please let me know and I’ll ask our customer service team to reach out with further options.

                                        1. RTravis Omasta @Rianer
                                            2023-03-01 15:13:58.891Z

                                            Good Morning Charles,

                                            Well even more fun, the TinyPilot image site does not recognize my order number and email address, despite copying it directly from my order email. I can provide both of those, though I might prefer to not post it on the public forum.


                                            1. Thanks for the quick response, I’m sorry to hear that your license couldn’t be verified. I don’t have access to our order data so I’ll need to ask our customer support team to look into this. Can you please confirm that you ordered directly from our website and that you used the same email address to place your order that you use for this forum?

                                              1. RTravis Omasta @Rianer
                                                  2023-03-01 18:48:34.958Z

                                                  Hi. I did use the email address used on this forum, but I ordered direct with a link provided by Eric via email invoice as I has purchased a refurbish version. I sent an email to him as well regarding this to help connect from both sides.


                                                  1. Thanks for confirming! I can see that our customer support team have replied so hopefully you’ll be able to restore your device using the command line instructions. If that doesn’t work then a factory reset will be required. I understand you don’t have the necessary hardware so as an alternative you could try booting your TinyPilot device from a USB drive but if not please let us know and we can look into other options.

                                                    1. RTravis Omasta @Rianer
                                                        2023-03-03 12:48:26.003Z

                                                        Hello Charles,

                                                        I have successfully ran the cmd line instillation and I am able to access my tiny pilot once again. I there a diagnostic worth running to make sure everything is properly functioning now?

                                                        I did some self diagnostics on accessing my tiny pilot remotely and am looking for some feedback. The primary purpose of me purchasing this device is to use it remotely (on a different network). I previously followed the instruction to install tailscale and am successfully able to connect, however there is excessive lag (often greater than 1s sometimes greater than 5s) between physical mouse movement and visual response. Additionally, I am not able to use my phone with tailscale as it uses the browser on my phone and does not support a touch screen mobile interface (I have no way to execute a mouse click).

                                                        When I looked into it, I found this lag is being generated specifically with the tailscale connection. I can have my laptop on the same network and connected to the tinypilot, and use chrome remote desktop from my phone off network to control it with virtually no lag, however when I connect with my laptop through tailscale (off network) the significant lag is back.

                                                        Do you have any advice? I want to avoid direct port forwarding and leaving myself open to a security issue, but for the purpose of this device the lag is unmanageable. It is also not viable to leave an additional computer on the target wifi as a bridge to use another remote service such as chrome remote desktop, as this requires an excessive amount of computers (target computer, tinypilot, connection computer, and then my remote access point).


                                                        1. RTravis Omasta @Rianer
                                                            2023-03-03 16:39:51.201Z

                                                            I did some more investigation, and it seems like the data being sent to my tiny pilot is not the problem, there is significant video lag being sent out. If i refresh the connection I can get a few seconds without lag, then it builds up again.

                                                            1. Thanks for getting back to me! I'm pleased to hear that you were able to access your TinyPilot device.

                                                              There could be a number of reasons for variable lag, although based on your description it sounds like the video format could be dropping from H.264 to MJPEG. Can you please send me a link to your logs so I can investigate further? Could you please also check if "H.264" or "MJPEG" is displayed in the bottom left corner of the TinyPilot interface when the lag occurs?

                                                              In terms of diagnostics following the reinstallation process - there isn't anything you need to check specifically, although if you do send me a link to your logs I'll check for anything unusual just in case.