No internet connection
  1. Home
  2. Technical Support

Tinypilot not connecting to new router

By Tejas Shah @tshah
    2023-03-04 05:52:41.572Z2023-03-04 06:35:50.291Z

    I have been using tinypilot for 3 months and it was working perfectly good. But I got a new router and not i am not able to connect to the tinypilot anymore do i need to reset something? Also if i connect my old router back it starts working again.

    Solved in post #12, click to view
    • 13 replies

    There are 13 replies. Estimated reading time: 13 minutes

    1. F
      Don Eitner @FreihEitner
        2023-03-05 04:12:47.602Z

        Going on very little detail, it is hard to say. Is your TinyPilot setup with a static or a dynamic IP address? If it is static, can you ping that IP from any computer on the local network? (you could do this with dynamic IP as well, but you'd need to find out what IP your new router assigned to the TinyPilot) If you go into the configuration of your new router, does it show your TinyPilot as a connected device?

        1. TTejas Shah @tshah
            2023-03-05 04:51:29.956Z

            i am not super tech savy but to answer your first question yes i am able to access tinypilot from any device. also i am not sure if i need to have static or dynamic for my tinypilot to work

            1. A@Alt0
                2023-03-05 05:00:45.496Z2023-03-05 05:07:49.956Z

                (Not person above)
                Neither / auto. Don’t give TP a Static IP, unless you know exactly what you are trying to do. Just allow for Dynamic (DHCP) to be assigned via the router. Ensure also that your new router is set to DHCP (that is, it is handing out IP Addesses). Also don’t DHCP Reserve an IP in the router via its MAC, unless you had that setup before in Router 1 and that’s what made it work. What’s the last 2 groups of your Router 1 and Router 2 IPs?
                Both ?

                Secondly, Do you have WinSCP setup to be able to su / root login and browse files? If so it looks like that RPI setting for TP locally can be changed here
                If not I can help you set that up.
                But if you are saying you aren’t too tech savvy then I doubt you changed it in the fist place unless running a command to do so.

                FYI also post your logs here as TP Support staff will ask for them (System > Logs)

                1. TTejas Shah @tshah
                    2023-03-05 05:07:52.620Z
                    1. A@Alt0
                        2023-03-05 05:16:57.608Z2023-03-05 05:23:06.105Z

                        I’m no TP log expert but see TP’s IP is

                        Q: Is this log set with the new router (Router 2 - not working) or old (Router 1 - works) ?

                        I assume you access your new router via
               (Or or .254 ?)

                        Maybe post the 2nd set of logs when TP is plugged into the “other” router, and indicate if it’s the New (non working) or Old (working) router for it.

                        Then could do:

                        • try an update (you are on 2.5.0), optionally via this ssh command Tinypilot not working after update #post-6
                        • try another cable
                        • resetting the new router (non working) to defaults (software GUI button or physically hardware button held down). All routes by default should come with DHCP mode on (again: that hands out IP addresses, as long as the host (TP or a PC) accepts it … that is it doesn’t have a Static IP it’s requesting)
                        1. TTejas Shah @tshah
                            2023-03-05 05:19:23.767Z

                            I did try different cables. The log i posted earlier were from the old router but when i connect to the new router i am not able to access tinypilot at all so i am not able to pull logs

                            1. A@Alt0
                                2023-03-05 05:21:34.459Z2023-03-05 05:29:46.689Z

                                Oh that’s right OK.

                                What’s your new routers IP to get into the interface? I suspect your old is or .0.254

                                If the new Router not 192.168.0.x then TP is probably confused with the router part of the IP changing to something different like .1 or .2

                                In that case when plugging in TP to the new router power cycle it via the power cable unplug, wait a few seconds, plug back in, and then try to access it via the host name.

                                It’s also possible the host name isn’t playing nice in the new router. In that case say the host name is “t” that you changed it to, so try to access it via

                                That’s http://
                                Followed by the TP host name
                                Followed by .local
                                Followed by a trailing forward slash /

                                If that still doesn’t work, AND you confirm that the new router still has pattern (3rd set is a 0 like your old router), then login to the new router GUI and find the page in the new router that list all network devices connected. For each, systematically go through each, plugging in the IP into a browser tab on your PC and see if it comes up with TP’s interface.

                                1. TTejas Shah @tshah
                                    2023-03-05 05:27:05.245Z

                                    sorry for the stupid question. but how can i check that

                                    1. A@Alt0
                                        2023-03-05 05:33:44.020Z2023-03-05 06:07:53.414Z

                                        Does new router have a sticker on it saying how to access it / it’s Default IP?



                                        Something like that?

                                        Otherwise you can google your exact router model which will definitely be on there and search for “ [Model No.] Default login “
                                        Take that IP you discover and plug it into a browser tab.

                                        OR If you have a PC (I’m a Windows guy) press Win + R and type in : cmd /k ipconfig
                                        Your router’s IP will be listed in Default Gateway. That is the IP to paste in your browser and then login there with whatever the defaults are in the Router 2 (new) manual / device sticker. It should then have a webpage listing all devices if you click around on tabs / a side bar and will have their name and IP. You may get lucky and it will show the TP host name (default = TinyPilot unless you changed it in the System > Hostname menu when connected to Router 1) . Otherwise if not shown or obvious, then I’d go through each device’s IP listed and bruteforce check to see if it returns TP’s web sever

                                        Alternatively post your router model here and will see if can help

                                        But just to recap,

                                        • if you find that the Router 2 (new - not working) does have the same 192.68.0 in its IP, then definitely power cycle 🔄 TinyPilot when connecting to the new router.

                                        • I’d also reset Router 2 (new) to complete defaults via the hardware button

                                        • I’d upgrade TP to the latest it detects is available.

                                        • first try the .local syntax addition noted above when connected (and power cycled on the new router) to TP’s host name like http://tinypilot.local/ or https://tinypilot.local/

                                        • in either case (same router IPs or not) I would try to systematically hunt for it’s IP, as mentioned above, assuming router 2 is set to DHCP (which should be turned on by default, especially if doing a hard reset)

                                        1. TTejas Shah @tshah
                                            2023-03-05 06:13:42.583Z

                                            Hey Thanks a lot i was able to get the issue fixed i found out that the IPv4 Address that both the router where assigning to the tinypilot were different and if i put the IPv4 Address assigned to the tinypilot by the new router in the url i am able to access it. Thank You @Alt0

                                            1. A@Alt0
                                                2023-03-05 06:46:45.356Z

                                                Better retract your statement about not being technical if you figured out that IPv4 being the issue haha 😁! Nice work! I didn’t even consider that. Honestly I hate IPv6 addresses. Anyway, Maybe mark it as solved with your answer :-)

                                                1. It looks like this has already been solved with thanks to @Alt0 and @FreihEitner, so thank you both! There's some great information and suggestions in this thread.

                                                  It's common for IP addresses to change, so if you'd like your TinyPilot device to always have the same IP address you can set up a static IP address configuration. You can also connect to your TinyPilot device using the mDNS address (e.g. https://tinypilot.local), as that will always point to your TinyPilot device using the latest IP address.

                            2. A
                              In reply totshah:
                                2023-03-05 04:44:34.659Z2023-03-05 04:57:22.803Z

                                Speculating… Sounds to me like you could’ve assigned TinyPilot a static IP somehow, and the new router is using a new DHCP host range like

                                Where 105 would be the TP device and 2 or 0 or 254 being the new router host (say old router was using

                                What is TinyPilots IP? I’m not sure off hand of a Linux command to query in ssh but sure many out there exist with dr. Google.

                                Compare that to a PC on the LAN. Does it follow the same pattern other than the last 3x numbers? If not then that’s the problem and look up an SSH command to just have RPI just automatically grab whatever DHCP address the router gives it.

                                If it is the same, then I would probably just reset / clean install TP and redo any configurations (if applicable) when connected to the new router.

                                Maybe a Linux / Unix pro can chime in with a command to reset all network adapters to default (remove any static IP) and any other memory that TP could be thinking it needs for the old router.

                                Secondly. Maybe try a different cable, and ensure it’s not some crossover? Wonder if old router was more forgiving if you have some incorrect or badly twisted UTP CAT 5e or 6 cable

                                Tertiary. Try a force upgrade, when connected to the tmrw router before going the clean install route. Via this command which worked for someone else - Tinypilot not working after update #post-6