No internet connection
  1. Home
  2. Technical Support

Dell UEFI Bios - Mouse not working

By Jobey Smith @jobey
    2023-03-15 20:12:38.759Zassigned to
    • @cghague

    Is this a known issue with the newer Dell bios and TinyPilot where the mouse isn't usable? The keyboard works fine, but mouse doesn't.

    • 21 replies

    There are 21 replies. Estimated reading time: 13 minutes

    1. C

      Hi Jobey, thanks for reaching out. I’m sorry to hear you’re having issues with mouse support.

      I’m not aware of any known issues specific to this situation. Can you please clarify the issue for me? For example, did the mouse work prior to a recent software update, does the mouse move erratically and does the mouse work correctly once the operating system has started? It’d also be really helpful if you could send me a link to your logs by going to System, then Logs and then Get Sharable URL the next time the issue is happening.

      1. JJobey Smith @jobey
          2023-03-16 16:32:07.866Z2023-03-16 16:47:10.457Z

          Hi Charles,

          I've only had the TinyPilot for a very short period of time so I can't say if this is affecting other models. This issue is happening across multiple computers and they are all the same model: Dell Optiplex 3000. I think all the new Dell models have this same bios format, however, so I wouldn't be surprised if it affects other models too. The issue goes away when you boot into Windows, but in the bios you can't use the mouse to navigate at all, which makes it difficult. Yes, you can use tab and arrow keys, but the newer bios are made to be used with a mouse.

          Here's the sharable logs you've requested:

          Edit: I've tried plugging in the usb cable from the TinyPilot to every usb connection on the Optiplex 3000, same issue. The keyboard works fine, but the mouse doesn't.

          Edit 2: Here's a completely different Optiplex 3000 if you wanted/needed another set of logs:


          1. Thanks for sharing the logs! It does look like your TinyPilot device is having problems sending input to the connected system, but, unfortunately, it isn't clear why. We can rule out a hardware, software or configuration issue with your TinyPilot device given the keyboard and mouse work in Windows, so it seems reasonable to assume this is a compatibility issue specifically with the UEFI BIOS on your Dell OptiPlex 3000 machines.

            It's not an exact match but I do have a Dell OptiPlex 7050 connected up to a TinyPilot Voyager 2a and I can confirm that the mouse works in the UEFI BIOS on there. We've also not had any other reports of issues like this. I'm wondering if the specific version of the UEFI BIOS on your Dell OptiPlex 3000 machines has some kind of bug or issue that prevents mouse input from working.

            Would you be able to confirm that the Dell OptiPlex 3000 machines accept input from an actual USB mouse? If possible, can you also please check you're running the latest firmware available for your Dell OptiPlex 3000 machines?

            1. JJobey Smith @jobey
                2023-03-17 15:26:32.360Z

                I don't think the older models have the same bios format. Does your 7050 bios look like this:


                This is the new UEFI bios. Not sure which versions it applies to, but definately the late 2022 and 2023 models. The new 5000 and 7000 series all use this same format. I not only verified I was running the latest bios version, but I even manually updated to the one just released this week (doesn't yet show up on the auto update for Dell Command Update), but TinyPilot still can't connect the mouse. Manually connecting a mouse works fine.

                I'm happy to work with someone to get this fixed as its likely going to be a problem for Dell computers going forward.

                1. Thanks for getting back to me! It does seem that I have an older UEFI BIOS on my machine based on that screenshot, which would support the theory that something has changed with how Dell have implemented mouse support. One possibility is that the new UEFI BIOS doesn’t support composite USB devices like the TinyPilot (which essentially behaves like a virtual USB hub). Would you be able to try connecting a mouse to one of your computers using a USB hub and confirming if that works?

                  1. JJobey Smith @jobey
                      2023-03-17 23:23:36.579Z

                      Plugged in a usb hub with the wireless keyboard and mouse dongle plugged into the hub, which is then plugged into the computer. Rebooted into the bios, mouse and keyboard work fine. So its seems the bios can handle hubs okay.

                      1. Thanks for confirming! I appreciate you troubleshooting this with us and I’m still hopeful we can get this to work. Does the UEFI BIOS react to the TinyPilot mouse at all or does it act as if no mouse is connected? Are there any settings in the UEFI BIOS which might relate to mouse support or an option to toggle “USB boot mode” (this is a type of operating mode and isn’t related to the boot order settings)?

                        1. JJobey Smith @jobey
                            2023-03-20 15:56:17.921Z2023-03-20 16:04:03.680Z

                            The UEFI bios doesn't see the mouse at all (when you connect an external mouse to the system a mouse pointer shows up. With just the TinyPilot connected no pointer shows up and clicking on the screen anywhere doesn't do anything). The only thing I see that mentions something similiar to "USB Boot Mode" is "Enable USB Boot Support" under "Integrated Devices". It is already checked:


                            1. David @david2023-03-21 11:34:43.898Z

                              Thanks for checking that!

                              This is a difficult one. I can't think of a reason why the DELL's UEFI BIOS would work with a USB hub, but not with TinyPilot.

                              It's a long shot, but have your tried different USB ports on the OptiPlex? i.e. front vs rear ports, USB 2.0 vs USB 3.0? I wonder if there are any minor differences with how the BIOS handles them?

                              1. JJobey Smith @jobey
                                  2023-03-21 15:56:24.193Z2023-03-21 16:13:56.496Z

                                  Yes, I've tried all 6 of the usb A ports on the 3000 (2 front, 4 rear). I'd be happy to open a support ticket with Dell, but they'd likely not do anything since this is third party.

                                  I have another Dell Optiplex 7000 ordered and they use the same bios. Once it arrives I'll also verify this is happening on that model as well (I don't have a 7000 available for testing until new shipment arrives).

                                  Edit: I noticed the mouse was listed as "/Sensitive". Here are the logs without "Sensitive" being enabled, if that helps:

                                  1. David @david2023-03-21 17:57:05.092Z

                                    Thanks for confirming that!

                                    It would be interesting to see if the behavior persists across models. Please keep us updated.

                                    Thanks for the uncensored log. Unfortunately, it only reiterates that
                                    the target machine isn't consuming the mouse input from TinyPilot and doesn't provide any details beyond that.

                                    It might be worth opening a ticket with Dell since this sounds like an issue with this version of their BIOS.

                                    1. JJobey Smith @jobey
                                        2023-03-25 17:22:58.182Z

                                        I verified the 7000 series has the same problem.

                                        I'm willing to ship you a 3000 series unit (loan, obviously) if you want to troubleshoot this issue further from your end. Just let me know.

                                        1. David @david2023-03-27 12:13:15.070Z

                                          Thanks for confirming that you have the same behavior on the 7000 series as well. This definitely sounds like a compatibility issue with this version of the Dell UEFI BIOS.

                                          Thanks for offering to loan a machine to us. Unfortunately, we're a small remote team and we don't have the resources to troubleshoot this specific issue on a physical machine.

                                          Sorry for the inconvenience on this. I’ve asked our customer support team to reach out via email to find a resolution here. Please let me know if you don’t hear from them within one business day.

                  2. A
                    In reply tojobey:
                    Aaron @asala
                      2023-07-21 17:18:36.141Z

                      I just came across this exact issue on an Optiplex 3000, did you ever find a resolution to this?

                      1. AAaron @asala
                          2023-07-21 17:55:10.423Z

                          I'm also seeing this on a Dell Precision 3570 laptop

                          1. In reply toasala:
                            JJobey Smith @jobey
                              2023-07-21 22:36:53.041Z

                              No, I still don't have a fix for this issue yet.

                            • D
                              In reply tojobey:
                              dragon788 @dragon788
                                2023-07-22 16:41:25.920Z

                                This could be an issue with the "composite" USB device that TinyPilot would present to a system by default. If you try disabling the virtual media so that it instead is a pure "HID" USB device does that enable it to be recognized in the BIOS screens? I believe PiKVM also suffers from the same issue occasionally and has a setting that can be toggled pretty easily, but the default is to keep the virtual media available since most people want to use that functionality.

                                1. JJobey Smith @jobey
                                    2023-07-22 17:24:12.310Z

                                    I don't see a way to completely disable the virtual media option within the web gui.

                                    1. AAaron @asala
                                        2023-07-24 13:31:45.359Z

                                        It looks like they used to have instructions available but the URL points to a "Page Not Found" now.

                                        1. Ddragon788 @dragon788
                                            2023-07-24 15:02:52.292Z

                                            it looks like Michael gave a hint where to make some changes in a previous forum post.

                                      • C
                                        In reply tojobey:

                                        Thanks for the comments @dragon788, @asala, and @jobey!

                                        Older versions of TinyPilot presented a USB storage device to the target system regardless of whether any virtual media was in use, but we changed this in TinyPilot Pro 2.4.0. We removed the outdated help documentation at the same time.

                                        Due to how the USB features operate TinyPilot will still show as a composite device even without virtual media, so, unfortunately, I don’t think there is anything else we can do if the Dell BIOS won’t accept a composite USB device. The only alternative would be to disable either the keyboard or the mouse entirely, as was the case in the TinyPilot prototype.