No internet connection
  1. Home
  2. Technical Support

TinyPilot shows black screen after upgrading macOS to Ventura 13.3

By Steve Wang @stevewang
    2023-04-05 13:08:28.838Z2023-04-26 13:52:46.639Zassigned to
    • @cghague

    TinyPilot worked well when I am using macOS Ventura 13.1, but it shows black screen after upgrading to macOS Ventura 13.3.
    Keyboard and mouse works, but HDMI output is just a black screen.
    It was same whether or not I select MJPEG or H264 mode.
    I tried several solutions related to macOS external monitor black screen issue, but no luck.
    It doesn't even recognize external display in Preferences -> Display settings.
    I am not sure if this is a macOS issue or TinyPilot issue.
    Please let me find the solution as soon as possible.

    Moderator edit

    • 2023-04-14: MacOS's Ventura update has made changes that broke several classes of external display devices, including TinyPilot. The TinyPilot team is actively investigating resolutions to this issue. See this post for details.
    • 2023-04-18: Our investigation into this issue is continuing. We're currently focusing on the metadata that display devices use to negotiate which settings to use, known as the EDID. See this post for details.
    • 2023-04-24: We've identified a fix for this issue and we're working on developing a solution. See this post for details.
    • 2023-04-26: A solution for this issue can now be found in this post.
    Solved in post #28, click to view
    • 37 replies

    There are 37 replies. Estimated reading time: 23 minutes

    1. C

      Hi Steve, thanks for reaching out. I’m sorry to hear you’re having display issues.

      I’m not aware of any compatibility issues with macOS 13.3, although it does seem likely that this is due to the macOS upgrade based on the timing. Could you please try fully shutting down the Mac, disconnecting the display cable from it, powering it back on, logging in, and then reconnecting the display cable? That will hopefully cause the Mac to detect your TinyPilot device. If it doesn’t work, please send me a link to your TinyPilot logs by going to System, then Logs and then get Sharable URL.

      1. Comment deleted
        1. Thanks for getting back to me! I've reviewed the logs and it looks like your TinyPilot device is being correctly detected as a display and that it is negotiating appropriate settings with your Mac. It's possible that the Mac simply isn't outputting anything to your TinyPilot device.

          Can you confirm if you see the text "No Signal" on a black background or if you see a completely black screen? Does anything happen if you click on "Detect Displays" in the Mac display settings (you may need to hold the Option key down to see the button)?

          1. SSteve Wang @stevewang
              2023-04-07 13:45:35.113Z

              It shows black screen, and I can control mouse over it.
              And I've tried clicking "Detect Displays" but nothing happens.

              1. David @david2023-04-07 18:28:38.016Z

                Thanks for trying that, @stevewang.

                Based on the information from all of the users in this thread, this sounds very much like a problem with Ventura 13.3.

                Could you try changing the output resolution and framerate for TinyPilot's display on your Mac to see if that solves this issue? 1080p at 30Hz or 24Hz and 720p at 60Hz are well supported across devices - so there's a chance they might work.

                Earlier today, Apple released Ventura 13.3.1. So updating to 13.3.1 may fix this HDMI issue.

                Please let me know how it goes.

                1. SSteve Wang @stevewang
                    2023-04-07 22:59:17.219Z

                    Thanks for letting me know.
                    I'll try update Ventura OS.
                    FYI, I've tried changing screen resolutions but no lock.
                    One thing was that the screen aspect ratio is 16:10 so there was no such resolution such as 1920x1080 or 1280x720.
                    Maybe this cause the problem or not?

                    1. David @david2023-04-10 08:41:44.128Z

                      Interesting - the lack of 1080p and 720p is odd. Normally, the target machine lists display settings based on information from your TinyPilot. Could you share a screenshot of the resolutions you can select?

                      Are you using an adapter? Can I ask what model of Mac are you using (e.g. 14" MacBook Pro 2022)?

          2. J
            In reply tostevewang:
            Jason P @jason
              2023-04-06 20:28:48.187Z

              I'd also like to say I'm seeing the same issue here. I'm able to connect an external monitor directly to my macbook pro and that works fine, but if i connect the tinypilot to it I'm only seeing a black screen via the web interface. I've tried various combinations of restarts and still see the same issue as stated here.

              1. Mazi @miraziztoy
                  2023-04-07 04:50:04.165Z

                  I have also had the same issue, it is just black screen, i thought i was the only one.

                  1. In reply tojason:
                    David @david2023-04-07 11:15:08.062Z

                    Hi @jason and @miraziztoy - I'm sorry that you're both running into this display issue on your Macs.

                    Can you confirm some details about your hardware and OS? What model of Mac are you using (e.g. 14" MacBook Pro 2022), and is it running Ventura 13.3?

                    Could you also share logs from your TinyPilot? On your TinyPilot's web interface, navigate to System > Logs and click Get Shareable URL. Then paste the link in your reply.

                    1. JJason P @jason
                        2023-04-07 13:50:53.552Z

                        Okay my info is:
                        Model: 14 inch 2021 MacBook Pro
                        OS: Ventura 13.3

                        1. Mazi @miraziztoy
                            2023-04-07 15:02:24.549Z

                            for me it is 14inch, 2019 Macbook Pro and 13.3 Ventura 13.3. will share the logs soon.

                            1. David @david2023-04-07 18:32:48.466Z

                              Thanks for the info, @miraziztoy.

                              From all of the information we've gathered in this thread, it looks like this is an issue with Ventura 13.3.

                              I've suggested to @jason and @stevewang to try changing their output resolutions and framerates to see if that is a potential workaround. Could you try doing the same?

                              I also found that Apple released Ventura 13.3.1 earlier today. So updating your Mac to the latest version may fix this issue.

                            2. In reply tojason:
                              David @david2023-04-07 18:24:58.226Z

                              Thanks for those details, @jason!

                              You logs show that your TinyPilot is receiving a 1080p 50Hz signal from the Mac - so it doesn't look like there's anything odd going on with your TinyPilot specifically.

                              This definitely seems like an issue with MacOS Ventura version 13.3, especially since all of the TinyPilot's with these symptoms connect to Macs on 13.3 after working fine before. I had a quick search online and found that other people have run into HDMI issues after updating to Ventura 13.3 too. So this isn't isolated to TinyPilot.

                              Could you try changing the output resolution and framerate for TinyPilot's display on your Mac to see if that solves this issue? 1080p at 30Hz or 24Hz and perhaps 720p at 60Hz are good places to start.

                              Earlier today, Apple released Ventura 13.3.1. So it might be worth updating to 13.3.1 to see if their update fixes this HDMI issue.

                        2. M
                          In reply tostevewang:
                          azi @miraziztoy
                            2023-04-10 18:39:43.545Z

                            I tried all the below and still not working. find the logs below.

                            even the screen is pitch black i can see the mouse moving from target machine, I have tried changing the screen resolution to almost every option not working still :(


                            1. Pprime @prime
                                2023-04-11 10:46:53.666Z

                                I am having exactly the same issue. I stops working after upgrading macOS to ventura 13.3. Is there any plan to fix this issue now?

                              • S
                                In reply tostevewang:
                                  2023-04-11 20:12:51.464Z

                                  Same here this is blocking all my work now :/ Would love to see if a fix is available. There is no 720p or 1080p resolution available on my computer

                                  1. Q
                                    In reply tostevewang:
                                      2023-04-14 02:17:09.250Z

                                      Same problem. I tried everything but no luck, even getting different cables/adaptors. My Macbook doesn't recognize any external display (usb-c). I have two tinypilots, the older version and the new one. None of them work (and both worked with Monterey). I've tried to troubleshoot with stuff that I've found online regarding Ventura not recognizing usb-c peripherals. The option "allow accessories to connect" is missing, that might be a clue. My hunch is that it has something to do with faulty drivers. Will keep investigating.

                                      1. Q
                                        In reply tostevewang:
                                          2023-04-14 02:18:51.133Z
                                          1. S
                                            In reply tostevewang:
                                            Steve Wang @stevewang
                                              2023-04-17 17:55:58.650Z

                                              Is there any solution to change TinyPilot device display name? That might work if it is possible...

                                              1. M
                                                In reply tostevewang:
                                                Mario @mareox
                                                  2023-09-26 17:13:49.603Z

                                                  Hello, everyone. I am running Mac OS 13.6, and my laptop crashes quite often. I verified my resolution, which is set to 1080p with 50 fps. I have also lowered to different resolutions and fps that are recommended per this link
                                                  I tried to collect the logs from my tinypilot but got this error. Please let me know which logs I need to collect using the cli.

                                                  1. Hi Mario, thanks for reaching out. I'm sorry to hear you're having issues.

                                                    The error message in your screenshot suggests that the filesystem on your device might be corrupted, which would typically require a factory reset to resolve. However, you mentioned that your laptop is crashing, so before we proceed, I'd like to gather more information to ensure we've identified the problem correctly.

                                                    Can you please confirm if the laptop is the target (i.e., the computer physically connected to the TinyPilot device) or the client (i.e., the computer displaying the TinyPilot web interface)? Could you please also clarify what happens during a crash (for example, what do you see, what do you have to do to continue working, and so on)?

                                                    1. MMario @mareox
                                                        2023-09-28 14:56:39.193Z

                                                        Hi Charles, thanks for the prompt response.
                                                        The MacBook Pro is the target. I connect from a Windows PC to manage several devices: 4 Linux servers, 1 Windows laptop, and the MacBook Pro. The MacBook Pro is the only device crashing. Also, I use the KVM switch TESmart 8 Port HDMI KVM Switch
                                                        To get the Mac back and running, I have to physically go to the laptop and turn it back on.

                                                        1. Thanks for getting back to me so quickly!

                                                          It sounds like this could be an issue with your MacBook Pro rather than your TinyPilot device. One possibility is that your MacBook Pro will sleep automatically or power off after a certain amount of time, in which case your TinyPilot device won't be able to wake it back up. You can adjust the settings under "Energy Saver" in the "System Settings" app on the Macbook Pro to prevent this from happening.

                                                          In terms of the error message, that does, unfortunately, look like filesystem corruption. I appreciate it's a hassle, but I'd recommend performing a factory reset as soon as possible.

                                                          1. MMario @mareox
                                                              2023-09-29 03:51:11.049Z

                                                              The Mac is not powering off because the energy settings are set to stay up all the time. I realized is crashing because every time I have to go to wake up the laptop, a crash report comes up to send the diagnostics logs to Apple. I concluded that it was due to a tinypilot issue because it doesn't happen when I work on the laptop with my dock station. Could this be a topic to discuss with Apple instead? Is it worth showing the crash logs here to see if something related to tinypilot?

                                                              Thank you again for the response.

                                                              1. Thanks for getting back to me so quickly. Your TinyPilot device appears to the target computer as a monitor, a USB keyboard, and a USB mouse, so it shouldn’t be possible for your TinyPilot device to crash the target computer. Unfortunately, this indicates the issue lies with the MacBook Pro rather than the TinyPilot device. I’m sorry that it’s not something we can resolve; I’d recommend reaching out to Apple’s support team, who will hopefully be able to advise further.

                                                                1. MMario @mareox
                                                                    2023-09-29 21:36:27.241Z

                                                                    Thank you, I appreciate your time.

                                                        2. Progress
                                                          with handling this problem
                                                        3. C

                                                          Thank you to everyone who has shared their logs and findings with us. I’ve been able to reproduce this and it does seem like there is an issue when using a TinyPilot device with macOS 13.3 and up. It’s currently unclear exactly what is causing the problem, but we’re continuing to investigate and I will share updates as we get them.

                                                          1. M
                                                              2023-04-17 13:47:29.119Zreplies tocghague:

                                                              Any updates to this issue? In my situation it looks like the Mac will also reboot back to the home login screen some times.

                                                              1. C

                                                                Thanks for all of the comments and suggestions!

                                                                I appreciate this is a frustrating issue and so I'd like to share an update. We've been investigating this over the weekend and, unfortunately, we've not been able to isolate the cause of the blank screen.

                                                                We've carried out numerous tests, including using different hardware configurations, external display adapters, booting macOS in safe mode, resetting using recovery mode, adjusting various macOS settings, and more. However, none of these tests had any noticeable result.

                                                                The current focus of our investigation is based around the metadata that display devices use to negotiate which settings to use, known as the EDID. We noticed that switching to our alternative EDID resulted in a slightly different blank screen (with a coloured block being shown).

                                                                I'll keep this thread updated as our investigation progresses.

                                                                1. P
                                                                  prime @prime
                                                                    2023-04-21 20:01:03.115Zreplies tocghague:

                                                                    @cghague thanks for investigating about this problem. Do you have any update? Hoping to see the solution ASAP.

                                                                    1. L
                                                                        2023-04-21 20:48:07.662Zreplies toprime:

                                                                        We bought a tiny pilot specifically for an OSX machine. Let us know if we can help test in any way as the thing is essentially a brick right now and we are having to travel to the laptop.

                                                                        1. C

                                                                          Thank you for all of the comments and the offers of help! I'm pleased to report that we've identified a fix for this issue, and we're working on preparing a solution based on it. I'll share the instructions on this thread as soon as they're available, which should be by Wednesday.

                                                                          1. C

                                                                            Thank you for waiting while we investigated this issue. I'm pleased to confirm that we now have a solution to share.

                                                                            In order to capture display output from your devices, TinyPilot sends a standard message called an EDID through the HDMI port. The EDID tells other devices what video resolutions and refresh rates TinyPilot recognizes.

                                                                            For reasons we've yet to ascertain, macOS 13.3 and onwards are incompatible with our existing EDID. We've developed and tested a new version of our EDID, which resolves the issue. We'll include the new EDID in the next TinyPilot Pro software update, but if you'd prefer not to wait, you can install it manually by connecting to your TinyPilot using SSH and running the following commands:

                                                                            # Back up original EDID
                                                                            cp --no-clobber "${EDID}" ~/tc358743-edid.hex.bak
                                                                            # Set the new EDID
                                                                            echo -ne "" | sudo tee "${EDID}" && \
                                                                              echo '00ffffffffffff0052627698008888882d1e0103' | sudo tee -a "${EDID}" && \
                                                                              echo '800000781aee91a3544c99260f50547fef8081c0' | sudo tee -a "${EDID}" && \
                                                                              echo '8140810081809500a9c081406140271f80f07138' | sudo tee -a "${EDID}" && \
                                                                              echo '164038c0350040442100001eec2c80a070381a40' | sudo tee -a "${EDID}" && \
                                                                              echo '3020350040442100001e000000fc0054696e7950' | sudo tee -a "${EDID}" && \
                                                                              echo '696c6f740a202020000000fd003b3d0f2e100000' | sudo tee -a "${EDID}" && \
                                                                              echo '000000000000014902031f734c010204139f2021' | sudo tee -a "${EDID}" && \
                                                                              echo '223c3d3e3c2309070766030c00300080e2007f00' | sudo tee -a "${EDID}" && \
                                                                              echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
                                                                              echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
                                                                              echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
                                                                              echo '0000000000000000000000000000000000000000' | sudo tee -a "${EDID}" && \
                                                                              echo '0000000000000000000000000000004e' | sudo tee -a "${EDID}" && \
                                                                              sudo v4l2-ctl --device=/dev/video0 --set-edid=file="${EDID}" --fix-edid-checksums

                                                                            If you need to restore TinyPilot's default EDID, SSH into your TinyPilot, and run the following commands:

                                                                            sudo cp ~/tc358743-edid.hex.bak "${EDID}" && \
                                                                              sudo chown ustreamer:ustreamer "${EDID}" && \
                                                                              sudo v4l2-ctl --device=/dev/video0 --set-edid=file="${EDID}" --fix-edid-checksums
                                                                            Reply4 LikesSolution
                                                                            1. J
                                                                              Jason P @jason
                                                                                2023-05-02 19:06:57.296Zreplies tocghague:

                                                                                Did this solution work for others? I’ve updated my tiny pilot to the latest (2.5.4) and am still seeing this same issue and not able to see any video when its hooked up to a Mac with Ventura 13.3. I even tried directly ssh-ing and running the above commands, but still seeing the same issue. :(

                                                                                1. C
                                                                                  Charles Hague @cghague2023-05-02 21:29:34.624Zreplies tojason:

                                                                                  I'm sorry to hear that this hasn't worked for you. I'm not aware of any outstanding issues with this bug, so we'll need to investigate this further. Can you please confirm that you're running macOS 13.3.1 (or newer) and could you please also send me a link to your logs by going to System, then Logs and then Get Sharable URL?

                                                                                  1. J
                                                                                    Jason P @jason
                                                                                      2023-05-02 22:12:13.930Zreplies tocghague:

                                                                                      Correct, I am on OSX 13.3.1 on a new macbook pro, and the tiny pilot is on version 2.5.4 (latest one). Here is a link to my TinyPilot logs:

                                                                                      It's the same issue as before. no video is being displayed when viewing via the web browser, and its also causing my macbook to crash. I've tried to connect my tiny pilot to 2 different macbook pros both running Ventura 13.3.1

                                                                                      1. C
                                                                                        Charles Hague @cghague2023-05-03 16:38:47.217Zreplies tojason:

                                                                                        Thank you for confirming and for providing the logs. It looks like your MacBook Pro is outputting a 1080p video signal at 60fps, which isn’t supported by your TinyPilot device. Can you please try changing to 50fps? You can do this by opening the Settings app, choosing Displays from the sidebar, selecting the “TinyPilot” monitor, and then selecting “50Hz” from the “Refresh Rate” dropdown.