No internet connection
  1. Home
  2. Technical Support

Unable to SSH on macOS Monterey

By @Supercell
    2023-05-04 16:37:49.531Zassigned to
    • @cghague

    I was reviewing the forum for SSH related changes that can be made to TinyPilot and wanted to change some settings via SSH but found out I could not even SSH in macOS Monterey. My TinyPilot works fine otherwise. Anyone else encounter issues with macOS ssh?

    • I am on the latest update TinyPilot version
    • ssh is enabled in gui

    Error message: could not resolve host name TinyPilot: nodename nor servname provided or not known

    Solved in post #2, click to view
    • 3 replies
    1. C

      Hi @Supercell, thanks for reaching out with your question about using SSH on macOS Monterey.

      The error message you mentioned suggests that the ssh utility on macOS can’t find your TinyPilot device on the network. This usually happens if you try to connect using just the hostname (e.g., ssh pilot@tinypilot). Can you please try connecting using ssh pilot@tinypilot.local instead?

      Reply1 LikeSolution
      1. S@Supercell
          2023-05-05 03:21:03.390Z

          That worked, although since I changed hostname it was "ssh pilot@[hostname].local

          1. Thanks for letting me know it worked! As you correctly noticed, the .local address is automatically generated based on the hostname and is then advertised over mDNS to make it easier to connect to your TinyPilot device. The mDNS protocol allows devices to announce themselves, and discover other devices, on a network without depending on DNS servers or static host address mappings.