No internet connection
  1. Home
  2. Technical Support

HTTPS not accessible

By Richard Wang @rcwang
    2023-07-12 19:11:07.225Z2023-07-12 22:13:02.774Zassigned to
    • @cghague


    I am not able to access my Voyager 2 (latest community version) via https, but I can access via http (without the s ). I have tried all the following but to no avail:


    However, they all work if I change URL to start with http://.

    So I ran netstat -tulpn to check if port 443 is being listened and it isn't.

    Any ideas how I can enable HTTPS for tinypilot?


    • 1 replies
    1. C

      Hi Richard, thank you for your question about HTTPS support.

      The community edition of TinyPilot doesn’t include HTTPS support, which means you’ll only be able to access it using HTTP by default. You can improve the security of the community edition by following the suggestions listed under the security considerations section, or you could upgrade to TinyPilot Pro, which includes improved security features such as HTTPS support and password authentication as standard.