No internet connection
  1. Home
  2. Technical Support

Voyager 2 latest community install "no signal" error

By @c0state
    2023-07-18 01:16:44.035Z2023-07-18 01:28:00.359Zassigned to
    • @cghague

    I just installed the latest "community" version via and it seems to work but I get no video signal.
    This exact setup was actually working perfectly fine just before this, but I switched to the community build as my Pro subscription lapsed and I thought I'd give the OSS build a try.
    The video source is just console output from a TrueNAS server over HDMI. I've never had any output issue with it before when on the Pro software.

    Keyboard input is working as issuing Ctrl-Alt-Del does reboot my server.
    The Rasbpian 32-bit Lite base image was used, then the command at the link above was run to do the actual TinyPilot install.

    Ansible emitted no errors AFAICT.
    Last bit of logs are:

    TASK [ansible-role-ustreamer : install uStreamer launcher script] *****************************************************************************************
    changed: [localhost]
    TASK [ansible-role-tinypilot : install TinyPilot Debian package] ******************************************************************************************
    changed: [localhost]
    TASK [ansible-role-tinypilot : install TinyPilot as a service] ********************************************************************************************
    changed: [localhost]
    TASK [ansible-role-tinypilot : enable systemd TinyPilot service file] *************************************************************************************
    changed: [localhost]
    RUNNING HANDLER [ansible-role-tinypilot : reload TinyPilot systemd config] ********************************************************************************
    ok: [localhost]
    RUNNING HANDLER [ansible-role-tinypilot : restart TinyPilot service] **************************************************************************************
    changed: [localhost]
    RUNNING HANDLER [ansible-role-ustreamer : reload systemd config] ******************************************************************************************
    ok: [localhost]
    RUNNING HANDLER [ansible-role-ustreamer : restart uStreamer] **********************************************************************************************
    changed: [localhost]
    RUNNING HANDLER [ansible-role-ustreamer : restart Janus] **************************************************************************************************
    changed: [localhost]
    PLAY RECAP ************************************************************************************************************************************************
    localhost                  : ok=38   changed=20   unreachable=0    failed=0    skipped=16   rescued=0    ignored=0
    + cp /mnt/tinypilot-installer/tmp/tmp.0KV322UPAS.yml /home/tinypilot/settings.yml
    + chown tinypilot:tinypilot /home/tinypilot/settings.yml
    + chmod 0644 /home/tinypilot/settings.yml
    + clean_up
    + rm -rf /mnt/tinypilot-installer/tmp/tmp.0KV322UPAS.yml
    + clean_up
    + sudo umount --lazy /mnt/tinypilot-installer
    + sudo rm -rf /opt/tinypilot-updater /mnt/tinypilot-installer

    Logs at:

    Any ideas? I assume there's some undiscovered bug with the latest code.

    Solved in post #4, click to view
    • 4 replies
    1. C
        2023-07-18 02:38:27.934Z

        Looks like ustreamer is the culprit, not sure why though.

        Stopping the service and running it manually:

        > /opt/ustreamer/ustreamer --host --port 8001 --encoder hw --format jpeg --resolution 1920x1080 --persistent --h264-sink tinypilot::ustreamer::h264 --h264-sink-mode 777 --h264-sink-rm
        -- INFO  [3479.039      main] -- Starting PiKVM uStreamer 5.38 ...
        -- INFO  [3479.040      main] -- Using internal blank placeholder
        -- INFO  [3479.040      main] -- Using H264-sink: tinypilot::ustreamer::h264
        -- INFO  [3479.041      main] -- Listening HTTP on []:8001
        -- INFO  [3479.042    stream] -- Using V4L2 device: /dev/video0
        -- INFO  [3479.042    stream] -- Using desired FPS: 0
        -- INFO  [3479.042      http] -- Starting HTTP eventloop ...
        -- INFO  [3479.042    stream] -- H264: Initializing encoder ...
        -- INFO  [3479.064    stream] -- H264: Configuring encoder: DMA=0 ...
        -- ERROR [3479.094    stream] -- Can't access device: No such file or directory
        -- INFO  [3479.094    stream] -- Waiting for the device access ...
        ^C-- INFO  [3484.148      main] -- ===== Stopping by SIGINT =====
        -- INFO  [3484.148      http] -- HTTP eventloop stopped
        -- INFO  [3484.194    stream] -- H264: Destroying encoder ...
        -- INFO  [3484.199      main] -- Bye-bye
        > ls /dev/video0
        ls: cannot access '/dev/video0': No such file or directory

        So it looks like it thinks the video capture device is /dev/video0 but there is no /dev/video0 device?

        On my Voyager 2:

        > v4l2-ctl --list-device
        bcm2835-codec-decode (platform:bcm2835-codec):
        bcm2835-isp (platform:bcm2835-isp):
        rpivid (platform:rpivid):
        Cannot open device /dev/video0, exiting.
        1. C
          In reply toc0state:
            2023-07-18 03:21:01.417Z

            Did the capture card die?

             > lsusb
            Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
            Bus 002 Device 002: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
            Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
            Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
            Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
            > sudo lspci
            00:00.0 PCI bridge: Broadcom Inc. and subsidiaries BCM2711 PCIe Bridge (rev 20)
            01:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)

            Neither USB nor PCI bus seem to show any video capture devices. There's no obvious hardware failure AFAICT. The LED on the capture card is lit.

            1. C
              In reply toc0state:

              Hi @c0state, thanks for reaching out with your question about the community edition of TinyPilot.

              It sounds like you are running the community edition of TinyPilot on a TinyPilot Voyager device. The community edition of TinyPilot isn’t set up to use the built-in HDMI capture hardware by default, so some extra configuration is needed. Can you please try following these instructions to fix the issue?

              1. C@c0state
                  2023-07-18 19:36:44.643Z

                  Sorry, totally missed that part in the docs. That worked, thanks!