No internet connection
  1. Home
  2. General

No video signal and mouse HID issues

By JB @ninja0n32021-05-17 17:20:48.381Z

Hello,

I just started TinyPilot for the first time, I'm encountering a couple of issues.

Here is my setup:

KVM => Powered HDMI Splitter => TinyPilot / Monitor

USB Keyboard web interface works through the KVM, but I can't get any video signal on the web interface or the mouse to work. I've seen the screen flash once with the actual display contents, but I haven't been able to reproduce that. I get "No Video Signal".

I've also run the updates (initially when I first started the pi, there was no web interface). That brought back the web interface.

Here are my logs: https://logs.tinypilotkvm.com/BKAFMdQI

I noticed I get connection refused errors on the 8000 ports and I also noticed an error relating to mouse HID.

Any help would be greatly appreciated.

Thank you!

  • 7 replies
  1. In reply toninja0n3:
    Michael Lynch @michael2021-05-18 19:17:45.662Z

    Thanks for reporting this!

    The video streaming service is failing to start for some reason:

    May 17 13:07:54 tinypilot ustreamer[3425]: -- ERROR [1737.734    stream] -- Unable to start capturing: Invalid argument
    

    Can you share the output from this command?

    sudo v4l2-ctl --all
    

    What is the OS / hardware of the PC you're connecting to?

    1. NJB @ninja0n32021-05-18 23:56:29.116Z

      Here is the output for the command: https://0bin.net/paste/rrJmamsy#DEBA5XeRQogpzs32fCWG6oCvropkuAt-m9/82uAb+Rh

      I purchased a TinyPilot Voyager (https://tinypilotkvm.com/instructions/voyager/v4); this runs on the Pi that was part of the package I received.

      I only had a chance to get this installed a few days ago, been working on setting up the network for the last couple of months, didn't get to get this installed before.

      Let me know if you need additional info

      1. Michael Lynch @michael2021-05-19 22:25:06.482Z

        Can you share the OS / hardware of the PC you're connecting to?

        Are there any other computers you could try connecting the TinyPilot to? I want to see if this is an issue with the Voyager or something about this particular target machine.

        1. NJB @ninja0n32021-05-20 10:26:21.225Z

          After adding some another system to the KVM running Ubuntu, I can see the output for that one and control the mouse without issues through the KVM.
          The system in question has the following specs:

          • OPNsense 21.1.5-amd64
          • FreeBSD 12.1-RELEASE-p16-HBSD
          • AMD Ryzen 3 3200G with Radeon Vega Graphics (4 cores), 16Gb RAM
          • Console only, but I also don't see any of the pre OS screens

          A note, I know there are issues on FreeBSD 12 and the Picasso (Integrated graphics) AMD drivers for display, but my assumption is that if the monitor can show it, I should also expect the output to be shown on the TinyPilot.

          Somehow after rebooting the initial system, the display through TinyPilot started working; I haven't done any changes to either systems. So far, my attempts had been limited to rebooting the TinyPilot unit, but I hadn't tried rebooting that specific machine.

          I guess this can be marked as solved, not sure what happened or how it got resolved.

          Thanks.

          1. Michael Lynch @michael2021-05-20 19:19:38.641Z

            Oh, nice. OPNSense is what we run in the TinyPilot offices as well!

            Hmm, it's strange that this just solved itself with a reboot. I wish there were more diagnostic information we could collect in these cases, but it's unfortunately difficult to diagnose what's going wrong when the target system's output and the TinyPilot's video capture don't want to talk to each other. Fortunately, compatibility is pretty good, but there are a few edge cases like these where I'd like to eliminate the confusion.

            1. NJB @ninja0n32021-05-20 20:05:15.174Z

              Thanks for the help greatly appreciated

    2. Progress
    3. N
      JB @ninja0n32021-05-17 19:47:20.917Z

      Also worth noting, I tried a direct HDMI connection between the KVM and the TinyPilot as well as a direct connection between one of the PCs and the TinyPilot, same result. No output. I also managed to reproduce the flashing display on the output, by restarting the unit and then plugging in the HDMI cable on the unit.