No internet connection
  1. Home
  2. Technical Support

Upgrading 2.5.0 fails because of GPG Key error

By Dominik @domdorn
    2023-08-23 12:59:21.108Z


    I'm trying to update my Tinypilot pro from 2.5.0 to the latest version. I tried two times through the web interface and just got an error, so I tried again through ssh.
    Upgrading stops in the ansible step:

    TASK [ansible-role-ustreamer : check if legacy Janus package is installed] *********************************************************************************************************************************************
    fatal: [localhost]: FAILED! => {"changed": false, "cmd": "dpkg-query --show --showformat='${Maintainer}' janus | grep TinyPilot", "delta": "0:00:00.048060", "end": "2023-08-23 13:51:20.801843", "msg": "non-zero return code", "rc": 1, "start": "2023-08-23 13:51:20.753783", "stderr": "dpkg-query: no packages found matching janus", "stderr_lines": ["dpkg-query: no packages found matching janus"], "stdout": "", "stdout_lines": []}
    TASK [ansible-role-ustreamer : determine if legacy Janus package is installed] *****************************************************************************************************************************************
    ok: [localhost]
    TASK [ansible-role-ustreamer : uninstall legacy Janus package] *********************************************************************************************************************************************************
    skipping: [localhost]
    TASK [ansible-role-ustreamer : install apt_key dependency] *************************************************************************************************************************************************************
    ok: [localhost]
    TASK [ansible-role-ustreamer : add archive apt repository key] *********************************************************************************************************************************************************
    ok: [localhost]
    TASK [ansible-role-ustreamer : enable Janus apt suite] *****************************************************************************************************************************************************************
    fatal: [localhost]: FAILED! => {"changed": false, "msg": "Failed to update apt cache: W:GPG error: buster-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E98404D386FA1D9 NO_PUBKEY 6ED0E7B82643E131, E:The repository ' buster-backports InRelease' is not signed."}
    PLAY RECAP *************************************************************************************************************************************************************************************************************
    localhost                  : ok=13   changed=0    unreachable=0    failed=1    skipped=2    rescued=0    ignored=1
    + clean_up

    As I currently have no important data on my tinypilot, I wouldn't mind just flashing the card with the newest version if manually upgrading is too much a hassle.


    p.s.: I noticed that in the upgrade scripts it looks for a TP_LICENSE which is unspecified and it just sends the TP-Device-Serial-Number instead. I don't remember getting a specific license key or similar when i bought the Tinypilot.. Did I miss a paper / email and need to fill this in somewhere?

    • 4 replies
    1. David @david2023-08-23 14:11:20.536Z

      Hi @domdorn, I'm sorry that you've run into this update issue.

      This GPG Key error is a known issue when trying to update to 2.5.4. There are a few options for updating here.

      The first option (and the one I'd recommend if possible) is to re-flash your microSD card with the latest version of TinyPilot (2.6.0). Your current version of TinyPilot (2.5.0) is restricted to updating to 2.5.4 and won't receive updates beyond that. That's because the update to 2.6.0 includes a new base operating system which requires a re-flash anyway.

      The second option is a workaround that will allow you to update to 2.5.4.

      First, SSH into your TinyPilot and run the following commands:

      sudo apt-key adv --keyserver --recv-keys 0E98404D386FA1D9
      sudo apt-key adv --keyserver --recv-keys 6ED0E7B82643E131

      Then run the TinyPilot update on the TinyPilot web interface.

      You don't need to worry about TP_LICENSE or TP-Device-Serial-Number - you didn't miss an email or anything like that.

      I hope that helps! Please let me know if you have any other questions.

      1. DDominik @domdorn
          2023-08-23 16:19:43.070Z

          Hi David,

          thanks. When trying to login to the iso download page, it says I need to renew my subscription

          I actually didn't knew that Tinypilot changed to a subscription based model, especially as the price tag is quite hefty.

          1. DDominik @domdorn
              2023-08-23 17:15:31.093Z

              ok, nevermind.. just bought the update.. hope its worth it :-)

              1. David @david2023-08-23 17:52:30.677Z

                Thanks so much for choosing to renew your license! As a small company, we rely on license renewals to fund improvements to TinyPilot’s software. TinyPilot Pro has required a license for a couple of years, but we include a 1-year license with all Voyager devices, so that may explain why you never noticed.

                Since you're making the jump from 2.5.0 to 2.6.0, it's definitely worth taking a look through our changelog and our most recent "What's New in TinyPilot" post to learn about all of the TinyPilot Pro's improvements since 2.5.0.

                Please let me know if you have any questions!