No internet connection
  1. Home
  2. Technical Support

The database file is not compatible with the current version of the app.

By @80x24
    2023-09-01 02:08:48.577Z2023-09-01 15:31:19.576Zassigned to
    • @cghague

    My WebUI is was returning:
    "{"code":null,"message":"The database file is not compatible with the current version of the app."}"

    I did a re-install with:

    curl -L[redacted]/ | sh && sudo reboot
    Now the when trying to access https://tinypilot.local, all I get is:
    502 Bad Gateway
    Solved in post #7, click to view
    • 5 replies
    1. C
      In reply to80x24:

      Hi @80x24, thanks for reaching out. I'm sorry to hear you're having problems accessing your TinyPilot device.

      It sounds like an update may have failed and left your system in an inconsistent state. Can you please try a full reinstallation by running the following snippet over SSH?

      if [[ -f /opt/tinypilot-updater/install ]]; then
        (sudo apt remove -y tinypilot || true) && \
          cd /opt/tinypilot-updater && \
          sudo ./install

      If that doesn't work, could you please share your logs with me by running the following command and then confirming that you'd like to upload the resulting log file when prompted?

      sudo /opt/tinypilot-privileged/scripts/collect-debug-logs
      1. 8@80x24
          2023-09-01 14:36:47.458Z

          The problem right now is that /opt/tinypilot and /opt/tinypilot-updater is empty:

          pilot@tinypilot:~ $ ls /opt/tiny*
          collect-debug-logs  init-usb-gadget  lib  remove-usb-gadget  scripts

          1. Thanks for getting back to me. The errors in the logs and the extra information you provided suggest that the filesystem may be corrupted, which, unfortunately, means you may need to re-image the microSD card. I appreciate it's a hassle, but if the filesystem is corrupted, this is usually the best way forward.

            I've noticed that you were attempting to install TinyPilot Pro in your earlier message, but the logs indicate you may be running the community version of TinyPilot. Could you please let me know which one is correct so I can advise on the best way to re-install?

            1. 8@80x24
                2023-09-01 17:24:33.847Z

                I have Pro. The installation was originally pro, so I tried reinstalling both pro and community edition (through the curl statements) but it still came back broken.

                1. Thank you for confirming; that would indeed explain the inconsistency!

                  As you have TinyPilot Pro, I'd recommend following our factory reset instructions. The instructions will guide you through re-imaging your microSD card, and the process will ensure you have a fresh, up-to-date installation of both TinyPilot Pro and the underlying operating system.