No internet connection
  1. Home
  2. Technical Support

I can't control the device with tinypilot

By @jason.phillips25
    2023-09-25 11:21:46.211Zassigned to
    • @david

    Hi team! I am able to see the screen, but can't control the device with tinypilot.

    Here's the tinypilot log:

    Please support me. Thank you

    • 24 replies

    There are 24 replies. Estimated reading time: 11 minutes

    1. David @david2023-09-25 12:52:02.272Z

      Hi @jason.phillips25, I'm sorry you're having issues controlling your device with your TinyPilot.

      Thank you for sharing that log. Your logs confirm that your TinyPilot can't forward your mouse or keyboard control events to your target machine.

      Were you able to control your target machine before?

      Can you tell me what your target machine is? i.e., is it a desktop, laptop, or something else?

      1. J@jason.phillips25
          2023-09-25 12:54:24.144Z2023-09-25 13:27:27.245Z

          @david Thanks for your reply! Yes, I was able to control the laptop before. The target machine is Windows laptop. Recently, I can't control the target machine. It's been more than a week.

          1. David @david2023-09-25 14:32:45.868Z

            Thanks for the confirmation, @jason.phillips25.

            The first thing to check is your TinyPilot's "Data" cable.

            Can you remove your TinyPilot's data cable from your TinyPilot and your laptop and then check the cable's connectors for any debris? If the contacts look good, can you reconnect the cable to your laptop and see if it now works? It might be a good idea to try a different USB port on your laptop to rule out a bad laptop USB port too.

            If that doesn't work, it's possible that your cable is damaged. I'd recommend testing the cable with another device if possible. Or, if you have a different USB-C to USB-A cable, you could try using that as your TinyPilot's Data cable to see if that fixes this issue.

            Please let me know if that helps and if you have any questions.

            1. J@jason.phillips25
                2023-09-25 14:35:41.268Z

                @david Thank you! I will try to follow your suggestions and keep you posted.

                1. J@jason.phillips25
                    2023-09-25 15:05:41.748Z

                    @david I just tried to use another USB cable and it works for me now. It looks like the original USB cable had a problem. Thank you for your support!

                    1. David @david2023-09-25 17:49:01.167Z

                      You're welcome! I'm glad you're back up and running!

                      Please feel free to reach out again if you have any other questions.

                      1. J@jason.phillips25
                          2023-09-26 10:48:07.119Z

                          @david Hi, Hope you are doing great. I am seeing the same issue this morning. I can't control the device again. Here's the log:

                          Please support me. Thank you!

                          1. David @david2023-09-26 12:25:44.674Z

                            Hi @jason.phillips25, I'm sorry you've hit this issue again.

                            Your new log is basically the same as your previous one - it confirms that your TinyPilot can't send mouse/keyboard events to your laptop.

                            It's interesting that you're seeing this the next day. Do you keep your TinyPilot connected to your laptop? If you disconnect and then reconnect the USB cable connected to your laptop, does that restore functionality?

                            1. J@jason.phillips25
                                2023-09-26 12:27:44.144Z

                                @david Hi, thanks for your reply. The TinyPilot has been connected to the laptop and I tried to disconnect/reconnect the USB cable several times, but it didn't work.

                                1. David @david2023-09-26 14:18:06.445Z

                                  Thanks for confirming.

                                  Are you able to test whether the USB port on the laptop works correctly with other devices? i.e., a USB drive / mouse / keyboard? I'm wondering whether the laptop is behaving in an odd way.

                                  1. J@jason.phillips25
                                      2023-09-26 14:55:30.036Z

                                      @david I just tried to connect TinyPilot to another laptop, but I couldn't control this device as well. Here's the log:

                                      1. David @david2023-09-27 11:15:54.183Z

                                        Thanks for trying that!

                                        Unfortunately, I can't see any obvious causes of this issue. It looks like your TinyPilot is on TinyPilot Pro version 2.6.0, could you update to 2.6.1 to see if helps here? Go to System > Update on your TinyPilot's web interface and click "Update".

                                        1. J@jason.phillips25
                                            2023-09-27 13:52:50.364Z

                                            Thanks, @david Unfortunately, updating the new version of TinyPilot doesn't help me. If possible, can I ship the TinyPilot device back to the Support team, so you guys can take a look at it? Please let me know if it's possible. Thank you

                                            1. David @david2023-09-27 17:51:59.870Z

                                              Thanks for the confirmation, @jason.phillips25.

                                              Unfortunately, as a small company, we don't have the resources to accept customers' devices for individual diagnostics. But I'm happy to continue working with you to get this USB issue resolved.

                                              It's unlikely that this is a hardware issue on your TinyPilot since hardware failures are rare. And I don't think it's a software issue because we got mouse/keyboard commands working when you swapped the cable before. I think it could be the cables causing issues.

                                              I've asked the customer support team to reach out to you via email to get a new USB cable to you.

                                              1. J@jason.phillips25
                                                  2023-09-27 18:56:31.039Z

                                                  @david That sounds good. Please keep me posted.

                                                  1. David @david2023-09-29 11:04:43.461Z

                                                    @jason.phillips25 - did you receive your email from the customer support team? Once you receive your new USB cable, could you try it with your TinyPilot and let me know if that fixes your issue?

                                                    1. J@jason.phillips25
                                                        2023-09-29 11:06:23.231Z

                                                        @david Thanks for asking! Yes, I received the email from the customer support team. I will receive the new USB cable soon. I will keep you posted here!

                        • @fft2023-09-28 05:50:17.048Z

                          Hi @jason.phillips25,
                          you wrote that you got the same issue the "next morning". Did the remote machine go to "sleep-mode" or anything similar (maybe just Monitor dark.)?


                          1. J@jason.phillips25
                              2023-09-28 10:48:35.642Z

                              @fft Thanks, The remote machine didn't go to sleep mode.

                            • J
                                2023-10-16 13:54:03.916Z

                                @david Hello, hope you are doing great. I received the new USB cable a few weeks ago and tried to set it up, but I can't still control the laptop. Here's the logs:

                                Thank you!

                                1. Hi @jason.phillips25, thanks for getting back to us. Dave isn't available today, so I'll quickly jump in here to keep this moving.

                                  I've read through the thread and can see that you've already tried a second USB-C to USB-A cable and tested using your TinyPilot device with a different laptop. I can also see that you could control the target computer previously.

                                  If the above is correct, then one possible explanation could be that the USB-C port on the TinyPilot has developed a fault and isn't forming a reliable connection. Could you please check if wiggling the USB-C end of the cable in the port makes any difference? I appreciate it might sound unlikely, but I've had this exact issue before when using a damaged USB-C port.

                                  If that doesn't work, could you please SSH into your device, run the following command, and post the output here? It will show us whether the emulated keyboard and mouse are present with the proper permissions.

                                  ls --format=long /dev/hidg*
                                  1. J@jason.phillips25
                                      2023-10-16 20:42:33.209Z

                                      @cghague Thanks for jumping in my issue. I really appreciate it! Wiggling the USB-C end of the cable in the port didn't work for me, so I tried to ssh into my device and ran the following command:


                                      1. David @david2023-10-17 15:57:50.607Z

                                        Thanks for the updates, @jason.phillips25.

                                        I think this is a hardware issue on your TinyPilot. I've reached out to the customer support team to figure out a suitable solution. You should receive an email from them soon.

                                        It's a long shot, but could you try a factory reset? If a factory reset doesn't help, that would further confirm that this is a hardware issue on your TinyPilot.

                                        1. J@jason.phillips25
                                            2023-10-17 16:37:40.222Z

                                            Thanks @david I will try a factory reset and keep you posted, but I agree that it's the hardware issue.