No internet connection
  1. Home
  2. Technical Support

No Signal...

By @anon6414517657
    2023-10-10 18:11:00.569Zassigned to
    • @cghague


    I've installed the community/free version of TinyPilot. I noticed that I am unable to obtain video output from my Intel NUC that I have attached a HDMI cord from the Pi, and then with a dongle (usb > hdmi > to the Pi. Both do not present any video output. There are some error messages in my logs that I saw, but I am not sure how to resolve this properly.

    Solved in post #17, click to view
    • 17 replies

    There are 17 replies. Estimated reading time: 14 minutes

    1. C

      Hi Mo, thanks for reaching out. I'm sorry to hear you're having trouble with video capture.

      I've reviewed the logs you provided and can see that the system hasn't recognized the HDMI capture hardware. There could be a few explanations for this issue, so we'll need to investigate further. Can you please confirm if you're using one of the supported USB-to-HDMI dongles, and if not, can you let me know the make and model of the one you are using?

      1. ?@anon6414517657
          2023-10-16 19:31:04.868Z

          Hello Charles,

          Thanks for the response & sorry for the delay. I previously had a license but that lapsed, so I then re-imaged it with the community version. Also this response is two-fold. I am using the HDMI port directly on the Intel NUC, which also resulted in the same issue with 'No Signal' as far as the USB-to-HDMI dongle, I am making use of the StarTech USB > HDBMI Dongle and it says version USB32HDES. Which I feel like I saw that listed as supported, but now I am hard pressed to find that article in that regard.

          1. Thanks for getting back to me!

            I've looked online, and according to the specifications on the Amazon listing, the USB32HDES is an HDMI output device, not a capture device. You'll need a HDMI capture device to use TinyPilot. Many devices will work, but I'd recommend choosing one from our list of suitable devices to ensure compatibility.

            1. ?@anon6414517657
                2023-10-17 02:16:04.437Z

                Oh, I guess I did not realize that. So then, the second part of this is - why isn't the onboard HDMI port working as it worked without incident on the Pro version prior to my license expiring and me reloading with the free version of TinyPilot?

                1. Thanks for getting back to me.

                  I apologize for the confusion, I didn't realize you had a TinyPilot Voyager device. The community version of TinyPilot expects a USB HDMI capture device by default, but you can easily configure TinyPilot to use the internal HDMI capture chip on a TinyPilot Voyager device by performing a custom installation. There is no need to uninstall first. Could you please try this process and confirm that video capture works afterward?

                  1. ?@anon6414517657
                      2023-10-17 22:06:20.378Z


                      Yup, tried that. Fresh install, existing. The logs for the recent attempt is here:

                      Anything stand out?

                      1. Thanks for getting back to me!

                        I can see the following in the logs, which indicates that TinyPilot still seems to be configured for a USB to HDMI adapter:

                        # Settings for an HDMI to USB video capture dongle.

                        The commands listed under step one ("Add the TC358743 overlay option to your TinyPilot /boot/config.txt file") of the instructions linked in my previous comment should switch TinyPilot over to use the internal HDMI capture hardware. Can you please try rerunning those commands and let me know if you see any errors or any other output?

                        1. ?@anon6414517657
                            2023-10-18 00:39:02.108Z

                            This has been done.

                            mo@tinypilot:~ $ grep dtoverlay=tc358743 /boot/config.txt
                            mo@tinypilot:~ $

                            I performed it once more, the RiPi rebooted, still no signal. Here is an updated logs.

                            Surely I am missing something obvious... always is the case. ;-)

                            1. Thank you for getting back to me.

                              It appears that the installation process hasn't made the required changes, as if it had, there would be a second dtoverlay line found by the grep command in your last message.

                              One possible explanation could be that the format of /boot/config.txt isn't as the installer expects. Can you please send me the output of the following command, which will display the contents of that file, including non-printable characters?

                              cat --show-all /boot/config.txt
                              1. ?@anon6414517657
                                  2023-10-18 21:39:23.985Z

                                  Sure thing, here is that output.

                                  mo@tinypilot:~ $ cat --show-all /boot/config.txt
                                  # For more options and information see$
                                  # Some settings may impact device functionality. See link above for details$
                                  # uncomment if you get no picture on HDMI for a default "safe" mode$
                                  # uncomment the following to adjust overscan. Use positive numbers if console$
                                  # goes off screen, and negative if there is too much border$
                                  # uncomment to force a console size. By default it will be display's size minus$
                                  # overscan.$
                                  # uncomment if hdmi display is not detected and composite is being output$
                                  # uncomment to force a specific HDMI mode (this will force VGA)$
                                  # uncomment to force a HDMI mode rather than DVI. This can make audio work in$
                                  # DMT (computer monitor) modes$
                                  # uncomment to increase signal to HDMI, if you have interference, blanking, or$
                                  # no display$
                                  # uncomment for composite PAL$
                                  #uncomment to overclock the arm. 700 MHz is the default.$
                                  # Uncomment some or all of these to enable the optional hardware interfaces$
                                  # Uncomment this to enable infrared communication.$
                                  # Additional overlays and parameters are documented /boot/overlays/README$
                                  # Enable audio (loads snd_bcm2835)$
                                  # Automatically load overlays for detected cameras$
                                  # Automatically load overlays for detected DSI displays$
                                  # Enable DRM VC4 V3D driver$
                                  # Disable compensation for displays with overscan$
                                  # Enable host mode on the 2711 built-in XHCI USB controller.$
                                  # This line should be removed if the legacy DWC2 controller is required$
                                  # (e.g. for USB device mode) or if USB support is not required.$
                                  # Run as fast as firmware / board allows$
                                  mo@tinypilot:~ $
                                  1. Thanks for getting back to me.

                                    The file's contents look correct, which means the installer should be configuring TinyPilot to use the internal HDMI capture hardware. I'll try and reproduce this locally to continue the investigation.

                                    You've mentioned the Raspberry Pi and TinyPilot Pro, so I'd like to confirm my understanding before proceeding. Can you please confirm that you're running the community version of TinyPilot on Raspberry Pi OS Bullseye (Lite) on a TinyPilot Voyager series device?

                                    1. ?@anon6414517657
                                        2023-10-19 16:32:46.269Z


                                        This is so curious. As far as version of Debian I am using, it is lite. Output doesn't specially say lite, should it? I did use the RiPi image creator.

                                        mo@tinypilot:~ $ lsb_release -a
                                        No LSB modules are available.
                                        Distributor ID:	Raspbian
                                        Description:	Raspbian GNU/Linux 11 (bullseye)
                                        Release:	11
                                        Codename:	bullseye
                                        mo@tinypilot:~ $ cat /etc/os-release
                                        PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
                                        NAME="Raspbian GNU/Linux"
                                        VERSION="11 (bullseye)"
                                        mo@tinypilot:~ $```
                                        As far as the RiPi I am using, it is a Tiny Pilot Voyger with the onboard HDMI port.
                                        1. Thanks for confirming! I agree this situation is very unusual, and I understand it must be frustrating, so I've asked our customer support team to reach out to you with another solution so we can get your TinyPilot device back up and running as soon as possible.

                                          1. ?@anon6414517657
                                              2023-10-19 23:21:21.533Z

                                              Appreciate it! In the meantime, let me know if there is any actions I should take on this device, to provide further details of its configuration. =]

                                              1. ?@anon6414517657
                                                  2023-10-23 18:21:03.571Z

                                                  Hey there, Charles.

                                                  Do let me know what you might have found out with this issue. In the meantime, I am thankful to Eric to at least get me up and running. But, certainly do wanna make use of the Community Version. Looking forward to your update when you have one. :)

                                                  1. Thanks, Mo! I'm pleased to hear that Eric was able to help.

                                                    Regarding the community version, I've managed to reproduce the issue and identified the cause. We recently switched to a different distribution method, and a side effect is that some of our installation scripts run only when upgrading or installing for the first time, including the one that switches between HDMI capture devices.

                                                    I've created a bug to fix this, but in the meantime, you can work around this by uninstalling TinyPilot before reinstalling it. To uninstall the TinyPilot package, run the following command:

                                                    sudo apt remove tinypilot

                                                    Ensure that you see the following text indicating that the system will only remove the TinyPilot package:

                                                    The following packages will be REMOVED:

                                                    You can then proceed with the custom installation instructions.

                                                    I hope this is helpful! Thanks for working with us on this investigation!

                                                    1. ?@anon6414517657
                                                        2023-10-26 19:50:47.622Z

                                                        Hey there, Charles! o/

                                                        Happy to report that I was able to successfully install the community version without further issue. Appreciate the attention and help with this.