No internet connection
  1. Home
  2. Technical Support

The following packages have unmet dependencies: janus : Depends: libduktape205, libusrsctp1, libwebsockets16

By Borislav Valkov @papa_joo
    2023-10-27 21:50:05.561Zassigned to
    • @cghague


    I am using Raspberry PI Zero and Raspberry Pi OS Lite (version from October 10th 2023). When I run this script from the repo

    curl \
      --silent \
      --show-error \ | \
        bash - && \
      sudo reboot

    to install version 1.9.1 the result is

    The following packages have unmet dependencies:
     janus : Depends: libduktape205 (>= 2.0.3) but it is not installable
             Depends: libusrsctp1 (>= but it is not installable
             Depends: libwebsockets16 (>= 4.0.19) but it is not installable

    and the installation is stuck on this step

    pushd "${INSTALLER_DIR}"
    sudo ./install


    more specifically on this

    apt-get install -y \

    from install file. Also, when I run this part

    apt-get install -y \

    it also has an error:

    Traceback (most recent call last):
      File "/opt/tinypilot/./scripts/render-template", line 18, in <module>
        import jinja2
    ModuleNotFoundError: No module named 'jinja2'

    Could you help me, cause I am trying 2 days to resolve this and also initially tried on Raspberry Pi OS (Legacy) version and had no success.

    Thanks in advance!

    • 9 replies
    1. C

      Hi @papa_joo, thanks for reaching out. I'm sorry to hear you're having installation problems.

      It looks like you're trying to install TinyPilot onto the "Bookworm" version of Raspberry Pi OS, which, unfortunately, isn't currently supported. We've got internal tickets open to investigate adding support for "Bookworm", but there isn't a fixed timeframe for when it will be done.

      TinyPilot is fully compatible with the legacy "Bullseye" version of Raspberry Pi OS, so you shouldn't see any errors. Could you please try installing TinyPilot on "Bullseye" instead of "Bookworm" and let me know if you have any problems?

      1. PBorislav Valkov @papa_joo
          2023-10-28 17:33:01.503Z

          Hello Charles,

          I tried to re-install TinyPilot on my Raspberry PI Zero with Bullseye and the result is:

          Job for janus.service failed because a fatal signal was delivered to the control process.
          See "systemctl status janus.service" and "journalctl -xe" for details.
          dpkg: error processing package tinypilot (--configure):
           installed tinypilot package post-installation script subprocess returned error exit status 1
          Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u5) ...
          Errors were encountered while processing:
          E: Sub-process /usr/bin/dpkg returned an error code (1)
          + clean_up
          + sudo umount --lazy /var/tmp/tmp.pjyq57Qd3W
          umount: /var/tmp/tmp.pjyq57Qd3W: not mounted.
          + true
          + sudo rm -rf /opt/tinypilot-updater /var/tmp/tmp.pjyq57Qd3W

          If I check

          journalctl -u janus.service --since "1 day ago"

          I get this

          Oct 28 20:25:01 raspberrypi systemd[1]: janus.service: Control process exited, code=killed, status=11/SEGV
          Oct 28 20:25:01 raspberrypi systemd[1]: janus.service: Failed with result 'signal'.
          Oct 28 20:25:01 raspberrypi systemd[1]: Failed to start Janus WebRTC gateway.

          Any ideas on that?


          1. In reply tocghague:
            PBorislav Valkov @papa_joo
              2023-10-30 22:16:49.263Z

              Any ideas how to manage that issue?

              1. Thanks for getting back to me!

                The 11/SEGV error can indicate a problem related to reading or writing to the device's memory. The Raspberry Pi Zero is a very basic device, and while it can run TinyPilot, it can require some optimization, and it may not work well if the device is performing other tasks.

                I appreciate it's a bit of a hassle, but can you please try using a completely fresh install of Raspberry Pi OS Bullseye, with no additional services or desktop environments installed, and see if the issue persists?

                1. PBorislav Valkov @papa_joo
                    2023-10-31 01:01:04.602Z2023-10-31 01:21:04.692Z

                    It is fresh new installed, dedicated only to TinyPilot Raspberry PI OS Lite Bullseye. I setup everything from here and still the same error:

                    janus.service: Start request repeated too quickly.
                    janus.service: Failed with result 'signal'.
                    Failed to start Janus WebRTC gateway.

                    Meanwhile, I just need only that functionality - to reach the Raspberry PI server that is plugged in to PC 2 through USB cable, from PC 1 through wifi and use it as keyboard to PC 2 only. How to proceed with my current device or can you reccommend me buying more powerful one, for example Raspberry PI 4 (maybe the one that you have tested and is reliable)? If it is possible to reduce as much as possible the cost for new hardware and if you could navigate me how to setup my current one I would be very grateful.

                    1. Thanks for getting back to me with those details. TinyPilot should work without issue on a fresh install of Raspberry Pi OS Bullseye Lite, so we'll need to investigate further.

                      You mentioned in your first post that you'd already tried to install TinyPilot without success on Raspberry Pi OS (Legacy). Can you confirm if you've reflashed the microSD card with a new install since then? If you haven't reflashed, could you try redownloading and reflashing the lite version of Raspberry Pi OS (Legacy), as there may be filesystem corruption?

                      1. PBorislav Valkov @papa_joo
                          2023-10-31 19:10:12.983Z

                          Yes, I have reflashed and formatted each time I install different version of Raspberry PI OS. I use only the official tool for installing the OS.

                          1. David @david2023-11-02 12:22:00.632Z

                            Hi @papa_joo, Charles is unavailable at the moment, so I've taken a look at this thread.

                            Thanks for confirming that you've reflashed with Raspberry Pi OS Bullseye Lite.

                            Unfortunately, we only offer technical support on Raspberry Pi 4B devices. The Raspberry Pi Zero isn't officially supported - although some users have managed to use it as a low-performance alternative.

                            Since the Raspberry Pi Zero is not officially supported, I can't offer much help here since I don't have a Raspberry Pi Zero to test on. Do you have any more detailed logs detailing the janus issue you're running into? That may help with understanding what the complete issue is here. It's possible that it's simply a resource / performance limitation.

                            It may help if you try to install the TinyPilot software on Raspberry Pi OS Bullseye Lite before trying to use the Zero optimizations. There's a Github discussion open for users trying to run TinyPilot on alternate hardware which may be useful for you too.

                            1. PBorislav Valkov @papa_joo
                                2023-11-02 12:43:42.880Z

                                Thanks for the answer. Probably it is resource limitations. I will consider buying Raspberry Pi 4 Model B and will try with that and most probably will not have any issues. Thanks one more time :)